Jump to content

Gemini für Abcom IPBOX 250/400


weazle

Recommended Posts

UNOFFICIAL.Gemini-4.1.IPBOX.250s_26-10-2007

 

Build for IPBOX 250S by weazle

 

Info:

Latest u-boot, kernel and drivers (thanks to sandali)

Display time on standby

If you change the standard password it needs to be set in /var/etc/password.txt

otherwise the display script don't work!

ipbox/relook rc layout

mID change not necessarily

user: root

pass: ipbox

 

Notes:

THIS FIRMWARE CAN DAMAGE YOUR HARDWARE - USE IT AT YOUR OWN RISK!

remember: this is a UNOFFICIAL build and you can`t expect support from Gemini developer!

 

DOWNLOAD

 

*************************************************************************

UNOFFICIAL.Gemini-4.1.RELOOK.400S_25-10-2007

 

Build for RELOOK 400S by weazle

 

Info:

Latest u-boot, kernel and drivers (thanks to sandali)

Display time on standby

If you change the standard password it needs to be set in /var/etc/password.txt

otherwise the display script don't work!

ipbox/relook rc layout

mID: DM7000

user: root

pass: relook

 

Notes:

THIS FIRMWARE CAN DAMAGE YOUR HARDWARE - USE IT AT YOUR OWN RISK!

remember: this is a UNOFFICIAL build and you can`t expect support from Gemini developer!

 

DOWNLOAD

Link to comment
Share on other sites

  • Replies 207
  • Created
  • Last Reply

Versuch mal folgendes:

Box ausstecken, auf der Fernbedienung Powerknopf gedrückt halten, dann wieder einstecken und 5 Sekunden warten.

Wenn "SERI" im Display steht, OK drücken.

Notfalls mehrfach versuchen.

 

Was hattest Du vorher für ein Image drauf?

Link to comment
Share on other sites

hab ich schon mehrfach versucht, die Anzeige bleibt immer bei 8888.

Vorher hatte ich das ABCOM Image mit AIO drauf.

 

Habs noch 5x versucht, offenbar keine Chance. Jetzt muss ich mir wohl ein jtag-Interface zulegen. Die Box gehört einem Bekannten und der bekommt am Donnerstag seine Satanlage und freut sich schon auf die Box. Hoffentlich reißt er mir nicht den Kopf ab.

Link to comment
Share on other sites

Hmm, ich hab das Image die letzten Tage mindestens 10x geflasht und keine Probleme gehabt. Da is wohl beim Flashen was schief gelaufen. :)

Wenn Du mir Deine Adresse mitteilst, kann ich Dir leihweise ein JTAG-Interface schicken.

Link to comment
Share on other sites

das wäre super, ich schau aber erst morgen bei unserem Elektronikladen, ob die so ein Interface haben, wenn nicht komme ich gerne auf dein Angebot zurück. Ich muss mich mit der Box weiter vertraut machen, denn einige Bekannte möchten sich die Box noch anschaffen. Die vorhandene Box sollte eigentlich für meinen Sohn sein, nur er muss noch warten :) .

Link to comment
Share on other sites

So, ich hab jetzt nochmal das Abcom Enigma draufgebügelt und danach wieder das Gemini Image.

Absolut keine Probleme.

Da ist bei Dir was schief gelaufen.

 

Wenn Du das JTAG brauchst, einfach PN schicken.

Link to comment
Share on other sites

@weazle

 

ich hab mir ein JTAG bestellt, sollte Donnerstag oder Freitag da sein, vielleicht brauche ich es noch öfters :) .

 

Nochmals vielen Dank für dein Angebot.

 

Bei deinem angepassten Gemini läuft das BP aber ganz normal, man kann also die AddOns usw. verwenden?

Link to comment
Share on other sites

Da heute mein CF-IDE-Adapter aus China angekommen ist, wollte ich mal gern das Gemini-Image per Multiboot testen und mein AB-Com parallel betreiben. Da ich mich bisher noch nicht an Multiboot versucht habe, wollte ich gern wissen, ob es da Probleme durch die Umstellung der mID geben könnte.

Link to comment
Share on other sites

Hallo weazle,

 

ich habe mein JTAG-Interface heute bekommen und verwende die Software, die Onkel Hotte im anderen Thread gepostet hat. Ich erhalte jedoch immer die Fehlermeldung "Communication with Box failed". Ich bin in dieser Beziehung absoluter Laie und gehe daher davon aus, dass das Interface (breiter Stecker) in den Parallelport des PCs gehört. Der andere Stecker hat 20 Pins wobei nur 14 belegt sind, dieses Teil gehört auf die Platine. Der Anschluss dafür liegt direkt neben der Verbindung zum Netzteil. Was amche ich falsch? Habe ich die Box jetzt richtig geschrottet? Ich die Box gebraucht gekauft, kann sie also nicht einfach zurück schicken. Kannst du mir vielleicht helfen?

 

Ich nehme auch gerne Hilfe von anderen an :) :

Link to comment
Share on other sites

Hab das JTAG glücklicherweise noch nicht gebraucht und hab auch keinen Plan davon.

Habs mir nur gleich mit dem Receiver gekauft, falls ich es mal brauche. :)

Kann Dir da leider nicht weiterhelfen.

Link to comment
Share on other sites

Hi,

 

geht bei deinem Gemini der NFS Server?

 

Boote mein Gemini von der Festplatte, wenn ich im BP auf

starten gehe steht bei Portmap und dem anderen Dienst unten immer

noch "gestoppt" und der Server startet irgenwie nicht.

 

TwT

Link to comment
Share on other sites

@michischmitt

 

Wenn du das Standarpasswort geändert hast, musst du die Datei /var/bin/channel_display.sh mit einem unixfähigem Editor bearbeiten.

#!/bin/sh
# config start
USER=root	
PASS=ipbox
# config end

 

Das Auslagern des var Bereiches, auf die Festplatte, wird meines Wissens in den neueren Gemini Versionen nicht mehr unterstützt.

Macht auch wenig Sinn, da die Festplatte dann ständig am rödeln ist.

Link to comment
Share on other sites

das passwort anpassen, nehme ich an.

 

ist der rest auch ok, da immer noch "run" im display steht?:

 

"#!/bin/sh

touch /tmp/.namechan

while [ -e /tmp/.namechan ]

do

NAME=`wget http://$USER:$PASS@localhost/xml/streaminfo -O - | grep '<name>' | sed 's/<name>//' | sed 's/[^ ]//' | sed 's/<\/name>//'`

if [ "$NAME" != "$STAR" ] ;

then

echo $NAME | sed 'y/abcdefghijklmnopqrstuvwxyz/ABCDEFGHIJKLMNOPQRSTUVWXYZ/' | awk '{print substr ($n,1,13)}' > /dev/dbox/fp0

STAR=$NAME

fi

sleep 1

done"

Link to comment
Share on other sites

PASS=ipbox <- da musst du dein neues Passwort eintragen.

 

Hmm, sind die 2 Variablen nicht im File?

Das ganze File sollte so aussehen:

#!/bin/sh

# config start
USER=root	
PASS=ipbox
# config end

touch /tmp/.namechan
while [ -e /tmp/.namechan ]
do
NAME=`wget http://$USER:$PASS@127.0.0.1/xml/streaminfo -O - | grep '<name>' | sed 's/<name>//' | sed 's/[^ ]//' | sed 's/<\/name>//'`
if [ "$NAME" != "$STAR" ];
then
echo $NAME | sed 'y/abcdefghijklmnopqrstuvwxyz/ABCDEFGHIJKLMNOPQRSTUVWXYZ/' | awk '{print substr ($n,1,13)}' > /dev/dbox/fp0
STAR=$NAME
fi
sleep 1
done

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.

×
×
  • Create New...