Jump to content

Keywelt 2007 Squashfs September Image V1 Beta4


SnowHead
 Share

Recommended Posts

  • Admin

Im Download liegt ab heute die Testversion Beta4 des neuen Keywelt-Images,

welche aufgrund vieler Rückmeldungen schon verbessert werden konnte.

Vielen Dank den Testern, welche uns bei der Verbesserung geholfen haben.

Trotzdem weisen wir ausdrücklich darauf hin, dass es sich noch immer um

eine Beta-Release handelt.

 

Wichtig!! Dieses Image ist ausschließlich für erfahrene Nutzer gedacht,

die z.B. wissen, wie man auch unter erschwerten Bedingungen flasht,

was es mit FTP und der Rechtevergabe auf sich hat und die in der Lage

sind, ein Bootlog zu erstellen.

 

Wir bitten Euch es ausgiebig zu testen - wir sind auf Eure Rückmeldungen

angewiesen! Diese müssen fundiert und verständlich sein. Bitte immer eine

genaue Beschreibung der Umstände, die zum Eintreten des (unerwarteten)

Ereignisses führten (möglichst mit Bootlog) posten. Änderungs- oder Verbes-

serungswünsche begründen!

Wer zur konstruktiven Mitarbeit nicht in der Lage ist, läßt bitte die Finger von

diesem Image und verwendet bis zum Release des Images die bekannten und

erprobten Versionen.

 

Um den Thread übersichtlich zu halten, werden die in letzter Zeit zur Gewohn-

heit gewordenen Fragen der Art "wie flashe ich das Image?", "komme nicht per

FTP auf meine Box oder in's Internet", "wie kriege ich Premiere damit hell?"

oder "Finde keine Kanäle, die Boardsuche hat auch nicht geholfen" kommentar-

los gelöscht.

 

Alles, was nicht direkt eine technische Rückmeldung ist, bitte hier rein,

damit man in diesem Thread hier am Ende noch durchsieht.

 

Wir haben uns bemüht, Aussehen und Bedienphilosophie an die von Alex

gewohnten Images anzupassen, um jedem Nutzer der alten Images gleich

wieder das "Keywelt-Feeling" bieten zu können. Das Image ist auf dem CVS-

Stand vom 12.09.2007, bietet also all die Neuerungen, welche seit einem

Jahr so nach und nach im Tuxbox-Forum entstanden sind. Dazu zählen die

HDD/MMC-Unterstützung, der UPnP-Browser, die Personalisierung der Menüs

und die individuelle Belegbarkeit der Farbtasten, ein optionaler Samba-Server,

NFS-Server und und und. Und zusätzlich dazu natürlich wieder den gewohnten

Keywelt-Online-Support.

 

Eine Bedienungsanleitung für das Image gibt es noch nicht, da sich im Laufe

der Enwicklung sicher noch einige Sachen ändern werden. Über die neuen

Standard-Features kann man sich im Wiki oder im Tuxbox-Forum informieren.

 

Um leseresistente Nassauer dazu zu zwingen, diese Warnung wenigstens

mal zu überfliegen, ist das eigentliche Image im Archiv noch mal geschützt

eingepackt und kann nur nach Eingabe der Zusicherung "Ich_bin_ein_Profi"

ausgepackt werden. Der Verweis auf diesen Thread liegt dem Archiv bei.

Da es sich hier noch um eine Testversion handelt, sehen wir es nicht

gern, wenn Leute, nur um sich zu profilieren und ihr kleines Ego auf-

zumotzen die Images kommentarlos und ohne Passwortschutz auf den

diversen ULCs uppen. Da dann nicht klar wird, daß es sich um eine

Testversion handelt, werden über diese Images keine Rückmeldungen

kommen und es wird ein großes Gemecker über die "fehlerhaften Key-

welt-Images" losgehen. Sollten Euch solche Möchtegern-Hacker auf den

ULCs begegnen, wären wir Euch für eine kurze Information dankbar

 

Im zweiten Posting werden wir eine Liste gefundener Fehler und von

Euch geposteten sinnvollen "nice to have"-Voschlägen mit deren Bear-

beitungsstand aktuell halten. Also vor einer Fehlermeldung bitte immer

erst in das folgende Posting schauen, ob der Fehler nicht bereits schon

gemeldet wurde. Wir hoffen, durch die aktive Einbeziehung der Board-

mitglieder in die Entwicklung - wir haben bewusst darauf verzichtet eine

handverlesene Auswahl zu treffen - ein Image schaffen zu können,

welches neben der Ausreizung der technischen Möglichkeiten der DBox

auch eine sinnvolle Bedienung, Fehlerfreiheit und eine große Akzeptanz

bei den Mitgliedern bietet.

 

Abschließend möchten wir uns noch bei folgenden Leuten bedanken,

welche ihren Anteil an der Schaffung des neuen Keywelt-Images geleistet

haben:

  • Worschter (postum) für die Inspiration und die Schaffung des Keywelt-
    Standards bei unseren Images. Deshalb ist ihm dieses Image auch ge-
    widmet.
  • rich, stachi und DrStoned für die Entwicklung und Adaption der Tools
    und Steuermöglichkeiten für die HDD/MMC-Einbindung und die Integra-
    tion dieser Möglichkeiten in das alte KW-Image.
  • windows64bit für Erstellung des neuen Bootbild-Originals nach dem
    Vorbild des alten.
  • Und natürlich, und das ist nicht ironisch gemeint, bei den unermüdlichen
    Entwicklern im Tuxbox-Forum, welche mit der Umsetzung immer neuer
    Ideen und Anregungen Sachen aus der alten DBox herausholen, welche
    man früher nie für möglich gehalten hätte.

Link to comment
Share on other sites

  • Replies 77
  • Created
  • Last Reply

Top Posters In This Topic

  • Admin

Status des aktuellen Images V1_September_2007_beta4:

 

Änderungen gegenüber der Beta 1:

  • Rootsize vergrößert um Sonderwünsche unterbringen zu können
  • Tippfehler in der shellexec.conf "Image über Internet updaten" gefixt
  • Eintrag in shellexec.conf für Premiere Direkt Movie Guide korrigiert
  • hwrtc nachgerüstet
  • Start des NFS-Servers gefixt
  • Verknüpfung /etc/samba -> /var/etc/samba nachgerüstet
  • Handling des Avia-SPTS-Fix-Treibers überprüft
  • MMC-Treiber: Namen und Anordnung im Menü geändert
  • FAT-Unterstützung im Kernel nachgerüstet
  • alternativen IRQ beim HDD-Treiber gefixt
  • Start von multicam.o überprüft
  • scart.conf gefixt
  • Philips-FB-Patch gefixt
  • Konfiguration für Werbezapper in Plugin-Einstellungen aufgenommen
  • "fuser", "dd" und "nc" in die Busybox eingefügt
  • LCD-EPG-Plugin + Konfigurationsmenü standardmäßig eingebaut
  • hddtemp.sh an unterschiedliche Festplatten angepasst
  • Menüfading standardmäßig auf "Aus"
  • SquashEdi funktioniert (min. 80 MB Swap-Partition erforderlich)
  • einige aufgrund Punkt 9 der Boardregeln hier nicht genannten Probleme gefixt

Änderungen gegenüber der Beta 2:

  • Längenbegrenzung der CAID-Ausgabe korrigiert
  • Libs für nachrüstbare Spiele passend gemacht
  • überflüssige Tabs aus der shellexec.conf entfernt
  • Flagfile-Handling für MMC-Swap gefixt
  • Verzeichnis /var/etc/samba/private erstellt und Datei /var/etc/samba/smb.conf eingefügt
  • Startflag des Samba-Servers angeglichen
  • Libs mit neuem Samba-Server gestrippt
  • Menüpunkt "Samba-Server starten" immer erlaubt
  • LCD-EPG-Plugin upgedatet
  • Zeitanzeigen in SquashEdi angepasst
  • "sfdisk" nachgerüstet
  • standardmäßig ext2 für IDE eingestellt
  • Datendienst rausgenommen
  • Wahl des MMC-Dateisystems aus FlexMenü entfernt
  • HDD/MMC-Check zusätzlich auf blauer Taste
  • Sat-Settings von merkwuerden übernommen

Änderungen gegenüber der Beta 3:

  • fstab überarbeitet um Fehlermeldungen abzustellen
  • Filesystem-Umschaltung für HDD in's Menü mit aufgenommen
  • einige Punkt 9 Probleme gefixt

Fehler:

  • recording.start überarbeiten (dazu brauche ich mal eine Zuarbeit)
  • Rechte von lcd_epg.sh auf 755 setzen
  • Ein/Aus-Dreher im HDD-Setup-Menü für Schreibcache und Sleep-Mode fixen
  • lcd_epg.conf erneuern
  • syslogd-Steuerung überprüfen
  • uCode-Auswahl überprüfen
  • tempfs aus fstab entfernen

Ergänzungen:

  • AVIA-SPTS-Fix einbauen
  • auch XFS als HDD-Dateisystem wählbar machen
  • "setconsole" in BusyBox
  • Symbole für fritzboxcallmon in den Libs lassen
  • Sicherheitsabfrage beim Formatieren der MMC
  • mmccombo_auto als default

nice to have:

  • Den Tune-Mode, den Bouquet-Mode, virtual Zap und die avia_gt_proc-Steuerung wird es aus Zeitgründen in absehbarer Zeit nicht geben

ToDo:

 

...

Link to comment
Share on other sites

Da will ich einmal den Anfang machen. Folgende Probleme sind mit bis jetzt aufgefallen.

 

- Für Samba bitte noch den Ordner '/var/etc/samba/private' anlegen und die Konfigdatei /var/etc/samba/smb.conf einfügen.

 

- Könnte man nicht für die Aktivierung des Menüpunktes 'Samba-Server starten' noch die Prüfung unter '/hdd/bin/' und '/mnt/mmc/bin/' einbauen (ist auch in '/var/etc/init.d/start_samba' so drin)? Samba 3.0.24 (Largefilesupport > 2GB) ist ca. 5,5 MB groß und dies passt nicht in den Flasch. Für diese Serverversion passt aber auch die libc.so.6 noch nicht.

 

- Als Schalterdatei wird '/var/etc/.start_samba' angelegt aber '/var/etc/.samba_server' steht in der rcS

 

- LCD-EPG Plugin 0.8 --> Aktuelle Version 0.9

 

- Könnte man SequashEdi mit der Anzeige beim auspacken auf 'Dauer ca. 12 Minuten.' und beim einpacken auf 'Dauer: ca. 30 Min.' ändern oder patchen.

 

- Für das Einrichten der MMC fehlt noch der Befehl 'sfdisk'

 

- Ich würde vorschlagen als Standard die Schalterdatei '/var/etc/.ide_ext2' anzulegen.

 

- Für den Datendienst würden noch Befehle fehlen. Funktioniert dies überhaupt noch oder kann man dies ganz rausnehmen?

 

- Sind in der shellexec.conf nicht etwas zu viele Tabstopps (anstatt Leerzeichen) drin. :D

 

- Könnte man den Shellstarter '/lib/tuxbox/plugins/02_check_tool.so' + .cfg (Blaue Taste -> HDD/MMC-Check) wieder irgendwie mit einbauen? Dies hat den Vorteil, das bei ausgelagerten Ordner '/var/plugins/' oder '/var/tuxbox/plugins/' das nötige unmounten der HDD oder MMC möglich wird um den Filesystemcheck durchzuführen.

 

- "nach HDD-Check wieder mounten" Dieses Problem kann ich bei mir nicht nachvollziehen.

 

- Spricht etwas gegen die folgende Datei '/etc/fstab' da die vorhandene bei mir immer noch zu einer Fehlermeldung führt.

proc /proc  proc defaults 0 0

sysfs /sys  sysfs noauto  0 0

devpts  /dev/pts devpts noauto  0 0

/dev/mtdblock/3    /var    jffs2    defaults    0 0

@Snowhead, Eventuell kommt die Fehlermeldung auch auf Grund der fehlenden Schalterdatei '/var/etc/.ide_ext3'

 

rich

Edited by rich
Link to comment
Share on other sites

Hi Snowhead,

Ging ja sauschnell mit der 2. Beta. :D:o

Habe das Keywelt 2007 Squashfs September Image V1 Beta2 eben mal angetestet.

- int. HDD Erkennung klappt sofort super , nach hdd Treiber-Einbindung.-->Mounten = ok

- HDD Temp ok

- HDD Check lief erst im zweiten Anlauf mit einer vernünftigen Resultatsanzeige.

 

Der erste Test lief innerhalb von 10 sec komplett durch und gab allen 5 Punkten ein positives abgearbeites Resultat aus. :D (grün , X) Die anschließende Auswertung ist ein einzeiliges Popup : "checking Inodes, Blocks and Sizes = Bitte warten".

Vllt lag es am fehlendem Reboot der Box nach der Abschaltung des HDD Caches und des Swaps. Ab dem 2.Test klappt jedenfalls alles super.

 

 

- Im MP/MB werden alle TS-Aufnahmen erkannt und laufen problemlos und ruckelfrei.

 

kl. Fehler 1: In der CAID Ausgabe über der Infobar (nach 3 maliger gedrückter Home-Taste ) wird die letzte Ziffer oben rechts in der ersten Zeile "verschluckt".

In der zweiten Zeile stehen alle CAIDs auf denen das System entschlüsselt wird wieder komplett da. z.b. auf RTL Crime :

 

Zeile 1: [Kudelski (SA) Nagra-------------CAID : 170 ] , (die Ziffer 2 fehlt - obwohl noch genug Platz vorhanden ist.)

Zeile 2 :[ CAIDs :1801 , 1830, 1722 ,1702 ]

 

Ich weiß nicht , ob es in der ersten Beta auch schon so war - ist mir dort nicht aufgefallen.

Eine Schriftgrößenänderung brachte k. Änderung; (logisch, da innerhalb des Infofensters über der Infobar sowieso eine andere Größe und Ausgabe angesprochen wird.)

 

- Scart.conf editiert AN/AUS = OK - keine Probleme mehr

- MMC kann ich leider nicht testen - n.v. --> nur HDDD intern

- Vorschlag:

Die ganze HDD-Geschichte erstreckt sich ja auf 2 Menüs :

 

1. Im FlexMenü Keywelt--->Systemeinstellung--->HDD SetupTool

2. Hauptmenü--->Keywelt Settings--->Systemmenü---->Ucode TreiberMenü ----> HDD Einstellungen

 

In jedem Menü "sitzen" ca. 5-6 HDD Haupteinstellungen. Könnte man die HDD und Swap-Settings ncht vllt. alle zusammen (vom FlexMenü / HauptMenü) gegliedert in einem HDD Bereich unterbringen. Ich vermute aber mal, da der eine Teil im Neutrino CVS-Bereich liegt, wäre der Aufwand zu groß und es musste alles neu kompilert werden ,oder ?

Aber das soll ja auch keine Kritik sein - sondern nur eine kleine Anregung zwecks der Übersichtlichkeit. :P

Um die Swap-Partition abzuschalten , habe ich nämlich als letztes im UcodeMenü nachgesehen.......

 

Super Arbeit.

 

gruß eraser65

Link to comment
Share on other sites

Kommentar dazu von mir:

- Für den Datendienst würden noch Befehle fehlen. Funktioniert dies überhaupt noch oder kann man dies ganz rausnehmen?

Würde ich wegschmeißen. Das Datenzeug läuft meines Wissens nur noch über Astra 23.2E, auf 19.2E ist da schon lange nix mehr. Und die Datendienste dazu müßten erst mal manuell in die myservices.xml eingepflegt werden (als TV-Service, wenn ich's noch richtig weiß). Sat@Once wurde schon lange komplett abgeschaltet.

Ob das Zeug früher überhaupt groß genutzt wurde... :D

Wer ernsthaft DSL via Satellit nutzen will, wird das m.E. sowieso eher über den PC machen, eher er sich mit der dBox2 verrückt konfiguriert. Ist aber meine private Meinung.

 

- Spricht etwas gegen die folgende Datei '/etc/fstab' da die vorhandene bei mir immer noch zu einer Fehlermeldung führt.
proc /proc  proc defaults 0 0

sysfs /sys  sysfs noauto  0 0

devpts  /dev/pts devpts noauto  0 0

/dev/mtdblock/3     /var     jffs2     defaults     0 0

Sollte normalerweise reichen, es sei denn, daß für die HDD-Sachen das in der fstab stehen müßte. Könnte man doch aber bestimmt anders lösen, oder? Sonst gibt's halt bei nicht vorhandenem HDD-If Fehlermeldungen im Logfile.

 

So war mal die ursprüngliche, Beispiel September2006-Beta, die Zeile für den /var Bereich ist angepaßt aufs aktuelle 2007:

proc /proc  proc defaults 0 0

tmpfs /tmp  ramfs defaults 0 0

sysfs /sys  sysfs noauto  0 0

devpts  /dev/pts devpts noauto  0 0

/dev/mtdblock/3     /var     jffs2     defaults     0 0

Link to comment
Share on other sites

  • Admin

@rich

 

Das Samba-Zeugs werde ich noch nachrüsten. LCD-EPG wird aktuali-

siert. Das mit der SquashEdi-Anzeige ändere ich lieber in den Quellen,

da das im Build-Script mit drin ist. "sfdisk" wird nachgerüstet. Standard-

mäßig wird dann .ide_ext2 verwendet. Datendienst fliegt raus. Die

shellexec.conf sieht in meinem Editor OK aus. Check-Plugin kommt

wieder mit auf die blaue Taste. Mit den von Euch geposteten fstabs

wird die HD beim Start nicht gemountet mit der Fehlermeldung

"hdd nicht in fstab gefunden".

 

Edit: Du hast Recht, da sind überflüssige Tabs in der shellexec.conf

und müssen entfernt werden. Ich hasse kwrite.

 

 

@eraser65

 

CAID-Anzeige wird gefixt. Bis auf die Auswahl des MMC-Filesystems

sind im Keywelt-Menü ausschließlich Funktionen und in den System-

Einstellungen ausschließlich Einstellungen. Diese Auteilung ist schon

OK so und den Start von Scripten sollte man nicht fest in's Neutrino

einbauen sondern das im FlexMenü lassen. Die MMC-Filesystemaus-

wahl verschwindet noch aus dem Flex-Menü, da sie schon im Neutrino

drin ist.

 

 

@merkwuerden

 

Wie gesagt, ohne die momentan enthaltene fstab wird die HDD beim

Start mit der oben beschriebenen Fehlermeldung nicht gemountet.

Eventuell kann sich das mal ein Profi angucken.

Edited by SnowHead
Link to comment
Share on other sites

Hallo

 

Bin auch dabei das neue zu testen.

 

Entweder gehts nicht oder ich bekomms nicht gebacken.

Wenn ich in das Menu unter Keyweltsettings ucode Treiber Menu gehe,kann man doch

unter mmc die swap treiber laden.Wenn ich auf ein gehe,werde ich gefragt neu starten,

so und danach steht er wieder auf aus.

Kann mir einer sagen ob ich was falsch mache oder das noch nicht geht.

Karte wurde gefunden alles klappt nur das nicht.

 

mfg

european

Link to comment
Share on other sites

  • Admin

@european

 

Es fehlte das anfängliche Auswerten des Flag-Files beim Öffnen des

Menüs. Wird in der Beta 3 gefixt. Wenn Du es aber auf "ein" stellst,

wird das Flagfile angelegt und der Swap auch aktiviert, unabhängig

davon, ob es beim nächsten Öffnen wieder auf "aus" steht. Ausschal-

ten kannst Du es im Moment nur über manuelles Löschen des Flag-

files /var/etc/.mmc_swap

Link to comment
Share on other sites

Hi, das stimmt nicht, ging vorher auch am Bildschirm.

 

Edit: Technische Information funktioniert bei verschlüsselten Sendern nicht richtig, ging nur ein paar mal, jetzt wird das Bild schwarz und manchmal gibt es Knackgeräusche. Liegt das an irgendwelchen Einstellungen?

Edited by sammy909
Link to comment
Share on other sites

  • Admin

@sammy909

 

Kenne als Kabelnutzer nur diesen. Der alte lief ja auf Kabelboxen

nicht. Beschwerden über fehlende Bildschirmausgabe bitte an die

Devs von Tuxbox richten. Ich habe das Teil nicht angefasst.

 

Edit: vermutlich ist die CPU-Last auf verschlüsselten Kanälen zu

hoch. Die Daten werden aber weiterhin korrekt angezeigt. Postings

bitte nicht noch mal bearbeiten, wenn sie schon beantwortet wurden.

Ich kann nicht ständig den ganzen Thread rauf- und runterscrollen

um zu kontrollieren, ob noch jemand was zu seinem Posting hinzu-

gefügt hat.

 

 

@european

 

In Ordnung ist das nicht. Da Du aber weder schreibst, ob das MMC

oder HDD betrifft, was Du eingestellt hast und wie Du vorgegangen

bist (siehe erstes Posting) kann man da jetzt nicht viel dazu sagen.

Edited by SnowHead
Link to comment
Share on other sites

@ snowhead

 

Bis zum September Image 2006 hatte ich immer einen Blauen Hintergrund mit drei hellgrünen Balken und den entsprechenden Werten.

 

Fehlt mir aber nicht wirklich.

 

Edit: ging aber nur auf meiner Sat-Box. Die Kabelboxen machen das nicht.

 

sorry habe gerade gelesen, das Ihr die Sache schon ausdiskutiert habt.

 

Ich söllte gründlicher lesen.

Edited by ostpreussen
Link to comment
Share on other sites

@ostpreussen

 

Der hat die schon immer nur auf dem LCD und per Telnet ausgegeben.

Für den Bildschirm gibt es die Streaminfo: rote Taste -> blaue Taste

Der jetzt im Image befindliche Satfinder aus dem CVS müßte eigentlich satfind_lcd heißen.

 

Der ursprüngliche satfinder mit Bildschirmanzeige ist noch im September-2006-Beta im Root-Bereich zu finden. Allerdings funktioniert der mit dem 2007er Image nicht mehr, habe den grade mal ausprobiert:

[CPlugins] (id,val):(fd_lcd,21)

[CPlugins] (id,val):(rcblk_rep,350)

[CPlugins] (id,val):(rcblk_anf,150)

[CPlugins] (id,val):(fd_rcinput,18)

[CPlugins] (id,val):(fd_framebuffer,3)

[CPlugins] try load shared lib : libfx2.so

/var/tuxbox/plugins/satfind.so: undefined symbol: doexit

Fehlt also was in den libs.

Link to comment
Share on other sites

Hi!

Bin auch am testen des beta2 img,allerdings wird meine interne hdd nicht gemountet fehler "dieser mountpunkt existiert nicht" Mountpunkt:/hdd.Nun verstehe ich auch den Satz nicht:int. HDD Erkennung klappt sofort super , nach hdd Treiber-Einbindung.-->Mounten = ok

 

temp auslesen =ok

stanby-mode setzen=ok

 

Muss ich noch irgendwelche Einstellungen machen?

 

Gruss

Dietz

Link to comment
Share on other sites

@merkwuerden

 

Und genau diese Fehlermeldung bekomme ich bei lemmings und Co,

obwohl die beim Strippen mit im Verzeichnis lagen. Keine Ahnung, wa-

rum doexit rausfliegt und in welche Lib das eigentlich reingehört.

Merkwürdig. Hab grade mal reingesehen, doexit ist definitv drin in Deiner libfx2.so. Das Satfind-Plugin tut's aber nicht.

 

Grade mal gegengecheckt mit meinem Yadd (CVS vom 13.08.2007), da funktioniert das Plugin einwandfrei. Bei mir ist die libfx2.so 10k größer, aber ungestrippt, beim Yadd is es ja eh scheißegal, wie groß das ist. :P

 

Vielleicht darf die Lib nicht gestrippt werden? Hab sowas früher auch schon mal erlebt: ungestrippt lief die, nach Strippen war das Teil nicht plötzlich mehr lauffähig. Komisches Zeugs... :D

 

Übrigens ist mir noch ein "Fehler" in Erinnerung, war aber im Beta1: beim Onlineupdate vom mg-Vogel wurde die libcrypto.so.0.9.7 noch nach /var/lib gebügelt. Eigentlich unnötig, wenn sie im Root sowieso vorhanden ist. Weiß nicht. ob's schon gerichtet wurde, ich installiere das Zeug normal sowieso manuell, hab das da nur mal ausprobiert, ob das Online-Update funktioniert.

Link to comment
Share on other sites

  • Admin

@merkwuerden

 

Werd es mal mit der ungestrippten versuchen. An der zweiten Sache

kann ich nichts ändern. Die Lib kommt automatisch mit den Additionals.

Da die in den alten Images nicht drin war, mußte die mit runtergeladen

werden. Alle Images greifen aber auf die selben Updatemechanismen

zu.

 

Edit: Funktioniert mit der ungestrippten Lib. Werde die jetzt in die Beta 3

reinnehmen. Danke für den Tipp. Jetzt muß ich nur noch alle ungestrippten

Libs für den Samba-Server rausfinden und zusammensuchen, denn auch

dieser werden leider gestrippt, obwohl die Binaries beim Strippen vorhanden

sind.

Edited by SnowHead
Link to comment
Share on other sites

  • Admin

So, da mein Urlaub zu Ende geht und dann die Zeit absehbar knapp wird,

gibt es gleich mal die Beta 3, in welche die bisher gefundenen Sachen

schnell noch eingearbeitet wurden. Dazu wird gleich der Beta 2 - Thread

weitergeführt, da sich dort noch nicht allzuviel angesammelt hatte. Auch

hier sind wieder penible Tests gefragt, um eventuell innerhalb der näch-

sten 14 Tage eine Release fertigzubekommen, welche auch von nicht so

versierten Nutzern verwendet werden kann, was ja schon immer der An-

spruch des Keywelt-Images war. Allen Mitgliedern, welche bisher wieder

fleißig getestet und vor allem eine Rückmeldung gegeben haben, noch

einmal vielen Dank.

 

Edit: Mir ist gerade noch ein Bug aufgefallen. Das Filesystem steht jetzt

standardmäßig auf ext2 und läßt sich nirgends ändern (außer per Telnet

oder FTP). Das muß ich noch mit in's Neutrino einbauen. Also besser auf

die Beta 4 warten.

Link to comment
Share on other sites

Mit den von Euch geposteten fstabs

wird die HD beim Start nicht gemountet mit der Fehlermeldung

"hdd nicht in fstab gefunden".

@SnowHead

Sorry wenn ich dir noch einmal mit der fstab auf die Nerven fallen muss.

 

Ich hatte in der Beta2 die von mir angegeben fstab so eingebaut und dies hat bei mir auch problemlos ohne Fehlermeldung funktioniert. Dieser Aufbau ist auch schon im KW HDD-Image 2006 Beta7 so gewesen und es hat sich keiner beschwert. Bist du dir Sicher dass die Schalterdatei (/var/etc/.ide_ext3) für dein Filesystem auch schon vorhanden war? Wen dies nicht der Fall ist kommt es durch den danach resultierenden Mountaufruf zu der folgenden Fehlermeldung.

/var # /bin/mount -t /dev/ide/host0/bus0/target0/lun0/part2 /hdd

mount: Can't find /hdd in /etc/fstab

Richtig muss aber der Aufruf so aussehen: /bin/mount -t ext3 /dev/ide/host0/bus0/target0/lun0/part2 /hdd

 

rich

Link to comment
Share on other sites

Technische Information funktioniert bei verschlüsselten Sendern nicht richtig, ging nur ein paar mal, jetzt wird das Bild schwarz und manchmal gibt es Knackgeräusche. Liegt das an irgendwelchen Einstellungen?

 

Das liegt daran, das beim Aufruf der Technischen Informationen der SPTS-Mode eingeschaltet werden muss, das wird automatisch von der Software gemacht. Das führt bei manchen Boxen zum Schwarzbildbug, auch das Knacksen kommt daher. Aber wenn man in den Technischen Informationen schaut, ist denke ich mal, das Fernsehbild eher nebensächlich. Der SPTS-Mode wird ja beim Verlassen der Technischen Informationen wieder abgeschaltet.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...