Jump to content
alborland

vlc und dbox2 leicht gemacht

Empfohlene Beiträge

hi leutz,

für alle die probs mit ihrem vlc haben per dbox filmchen abzuspielen hier ne simple und einfache lösung:

 

voraussetzung: ihr habt erfolgreich bereits eure box in euer heimnetz eingebunden (ip, gateway und namesrver einträge der box!)!!!....

 

1. ladet euch von hier die .zip-version 0.8.4.a sowie die 0.8.6.a als .exe (download) herunter.

 

2. 0.8.4.a.zip-datei entpacken, anschliessend 0.8.6.a.exe installieren ("Full" auswählen)

 

3. den kompletten ordner "http" aus der 0.8.4.a in den hautpordner (C:\Programme\Videolan\VLC) von der 0.8.6.a kopieren, überschreiben bestätigen.

 

4. verknüpfung auf den desktop ablegen für die vlc.exe der 0.8.6.a-version.

 

5. rechte maus auf diese desktopverknüpfung und bei eigenschaften hinter vlc.exe einen

leerschritt und:

 

--extraintf=http --http-host :8080 --sout-transcode-fps 25.0000 --http-caching=32192

 

eintragen und ok.

 

6. die ganze 0.8.4.a kann man nun komplett löschen!

 

7. per desktopverknüpfung vlc aufrufen und bei korrekter dboxkonfiguration sollte es nun einwandfrei per movieplayer funtzen!!! :lol:

 

 

 

 

der umgekehrte weg geht genauso einfach per yweb (2.5.0) klick :

 

1. firefox als browser nutzen (aktuell win-version 2.0.0.2) (download)

 

2. die 3 dateien axvlc.dll, libvlc.dll und die npvlc.dll aus dem vlc-ordner kopieren und in den mozilla-firefox-plugin-ordner einfügen und fertig :lol:

 

 

 

 

weitere voraussetzung für einen reibgunslosen betrieb:

 

- vlc muss in eurer firewall freigegeben sein damit eine reibgunslose verbindung von pc zur dbox klappt (port:8080)

 

- wie ihr den movieplayer konfigurieren müsst kann man hier nachlesen: klick

 

 

 

 

für linux gehts so:

 

bei den neueren Versionen vom VLC wurden einige Dateien vom VLC-Share in einen "old" Ordner verschoben, deshalb funktionieren diese Versionen nicht mir dem Movieplayer. Um dieses Problem zu beheben, muss man im /usr/share/vlc/http links auf die Dateien in /usr/share/vlc/http/old anlegen, oder die Dateien von /usr/share/vlc/http/old nach /usr/share/vlc/http kopieren. Dann funktioniert das Abspielen von Dateien auf der Festplatte auch mit der VLC-Version 0.8.6.a Damit auch DVD's/(S)VCD's unter Linux abgespielt werden können, muss man einen Symlink vom Cdrom Device auf das selbige mit einem Doppelpunkt am Ende anlegen. (z.B.: "ln -s /dev/cdroms/cdrom1 /dev/cdroms/cdrom1:") und in der dboxfiles.html den pfad zum filmordner per editor eintragen

(z.b.: DIR=/home/user/filme)!

 

 

...habs selber so erfolgreich getestet unter win als auch linux, jedoch geht unter linux des yweb-lifeview gedönse nicht, alles andere aber auch :lol:!!!

 

greetz...

Al

bearbeitet von alborland

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Gast Tycus

Alborland, da hoffe ich doch mal fest das die Leute damit mehr Erfolg haben als sonst....

 

Danke dafür......:lol:

 

Kann das einer der Mod´s nicht mal an Magix sein gepinnten Thread hängen passen gut zusammen......

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Super, damit hat es bei mir einwandfrei funktioniert. Hatte schon die andere Anleitung leider erfolglos probiert. Im Movieplayer waren leider keine Dateien sichtbar.

 

Nun geht alles wunderbar

 

Danke

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Gast fluffy

Hallo,

 

bei mir funkt. es einwandfrei- auf Anhieb!!!!

 

Ich habe vorher stundenlang mit den einzelnen VLC-Versionen herumprobiert genauso wie mit der anderen Anleitung--- absolut kein Erfolg (keine Netzwerk-Verbindung, mit mehreren PC´s und Nokia-Boxen probiert)

 

Komponenten der funkt. Version:

 

Acer Aspire Notebook XP Pro

Netgear Gb Switch

Nokia D-Box

 

Bei weiteren Erfolgen melde ich mich wieder-

 

gruß

 

Paul

bearbeitet von fluffy

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

hallo, gute anleitung aber ich muss zurück auf version 0.8.4a.

mit der 0.8.6.a hab ich zwar bild aber absolut keinen ton.

hab mit den audiospuren rumexperimentiert und in den boxsettings einiges ausprobiert.

hab dann einfach mal die 0.8.4a über die 0.8.6a drübergebügelt und schon gings es und dann wieder die 0.8.6a über die installation wieder drüber und den ordner http der version 0.8.4a wieder überschrieben....

geht auch jetzt :lol:

 

glaube es hing an den audiosettings.

habe jetzt:

audiospur: 0

untertitelspur: 1

 

audiospur_id: -1

untertitellspur_id: -1

 

 

 

thx

bearbeitet von atzmo

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi,

erst einmal DANKE für die tolle Anleitung !

habe VCL mit oben angeführter Anleitung soweit am laufen, dass ich *.mpg Files von der HDD im PC zum Laufen bringe.

*.avi Files laufen nicht, laufen aber auch im VCL-Playerüber Menü nicht.

WARUM ?

 

DVD werden über die Box überhaupt nicht abgespielt, hängt sich irgendwann beim ...puffern... auf (DVD läuft, im Player Zeitleiste zu sehen)

VCD´s und gerippte Filme beginnen zu laufen, beginnen aber nach kurzer Zeit mit ...puffern... und brechen dann aber ohne Dbox Absturz.

Alle Scheiben laufen, wenn man sie separat im VCL- Player startet.

Ich vermute mal, das hier ein Netzwerkproblem vorliegt, habe allerdings nicht so viel Ahnung davon:

 

Habe die entsprechende Box über Switch (NETGEAR FS108), an dem auch die Fritz-Box hängt, am PC. Eine weitere Box hängt über DlanDuo (14Mbit) auch am Switch (hiermit kann ich die *.mpg auch ohne puffern anschauen).

 

PS: Streamingwerte NFS: mit Netzwerkkabel 7641/7314; mit DLanDuo 5069/1542

bearbeitet von J161

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Soweit Funzt alles nach diese Anleitung, ergänzend würd ich gern wissen wie ich das ganze als Dienst starten kann, bisher hatte ich immer

 

vlc.exe -I ntservice --ntservice-install --ntservice-options "--sout-transcode-fps 25.0000" --ntservice-extraintf "http"

 

im VLC Verzeichnis eingegeben, aber wie passe ich das jetzt an

 

--extraintf=http --http-host :8080 --sout-transcode-fps 25.0000 --http-caching=32192

 

an?

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

vlc als dienst funktioniert perfekt.

 

vlc 0.8.6a

 

einstellungen-einstellungen-input / codecs - UDP 8080

 

"admin" ordner aus vlc 0.8.0 in den "http" ordner von 0.8.6a

 

 

vlc.exe -I ntservice --ntservice-install --ntservice-options "--sout-transcode-fps 25.0000" --ntservice-extraintf "http"

an eine verknüpfung anfügen und ausführen. den dienst starten.

fertig

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Hi,

erst einmal DANKE für die tolle Anleitung !

habe VCL mit oben angeführter Anleitung soweit am laufen, dass ich *.mpg Files von der HDD im PC zum Laufen bringe.

*.avi Files laufen nicht, laufen aber auch im VCL-Playerüber Menü nicht.

WARUM ?

 

DVD werden über die Box überhaupt nicht abgespielt, hängt sich irgendwann beim ...puffern... auf (DVD läuft, im Player Zeitleiste zu sehen)

Das sieht bei mir genauso aus. Wenn jemand noch eine Lösung dafür hat. Ich fänds Super....

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

hi!

 

avi und mpeg funktionieren mit VLC 0.8.6 unter Ubuntu (feisty) problemlos. Habe nur wie im HowTo auch beschrieben die dateien aus http/old/ nach http verschoben.

 

DVDs funktionieren bei mir auch nicht. nachdem ich den Symlink mit : am ende angelegt hatte lief zwar das DVD-Laufwerk an aber die dbox bleibt bei "puffern" stehen. Mit den http-Dateien von 0.8.4a hat es auch nicht besser funktioniert.

 

Ein weiteres Problem: ich muss VLC erst beenden bevor die dbox den movieplayer beenden kann.

 

Grüße,

G

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Also soweit klappt alles ganz gut, nur noch 1 kleines Problemchen bei dem ich nich weiterkomm. Ich kann alle möglichen Videodateien so abspielen nur hab ich bei der einen mal Ton und bei ner anderen dann nicht.

Liegt nicht am Format soweit ich das sehe, weil bei einer avi geht der Ton bei ner anderen nicht. Kennt das schon Jemand? Am Pc kann ich die Files allerdings ohne Probleme mit Ton über Vlc anschauen, dann muß es doch auch über n Stream gehen.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo,

die Anleitungen sind mittlerweile alle wunderbar. Leider zeigt mir der Movieplayer aber keine Dateien an, die in meinem freigegeben Filmordner sind. Ich verzweifle mittlerweile schon seit Monaten.

Ich bekomme eine wunderbare Verbindung zur Box. Ich habe eine Sagem Box mit Petze Image vom 15.12.2006 Version 2.0 und den vlc player Version 0.8.5. Auf meinen PC läuft nach langen endlosen Versuchen auch das Webinterface vom vlc player. Was kann ich noch machen? ;)

 

Gruß

Ralf

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi,

der Movieplayer braucht keine Freigaben, da er ja auf dem Pc läuft und nur von der Box ferngesteuert wird...

Was sind das für Dateien? .ts-files ? Denn nur diese werden angezeigt, es sei denn, du schaltest mittels "blauer Taste" den Filter aus, dann werden alle Dateitypen angezeigt...

Hast du bei der 0.85 den http-Ordner verschoben?

 

Ciao,

DdD.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo Don,

es sind verschiedene Filmdateien z.B. .mpg,.avi, und .ts dateien gewesen. Er zeigt mir keine Dateien davon an. Wenn ich den Filter ausschalte, zeigt er mir diverse Dateienamen an, die aber nicht wirklich in dem Ordner sind, z.B.: title und ein Pfeil nach rechts. Ich habe dir übrigens ein PM geschickt. Vielleicht besteht ja die Möglichkeit über PM.

 

Gruß

Ralf

;)

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi,

bzgl. der PM siehe meine (geänderte) Signatur...

Alternativ, kannst du ja mal in den Board-Chat kommen, dort bin ich öfters anzutreffen (Wochentags nur abends, am WE auch mal tagsüber) ;)

 

Zu deinem Problem: was hast du in den Movieplayer-Einstellungen als Startverzeichnis eingetragen?

Ich vermute allerdings, dass die Box das WebIF des VLC nicht ansprechen kann... Versuche mal die Version 0.84a und gehe genau nach der Anleitung hier in diesem Thread oder der gepinnten Anleitung von magix hier in diesem Unterforum durch...

 

Ciao,

DdD.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Guten morgen DvD,

mit der Version 0.8.4a habe ich es endlich hinbekommen. Große Erleichterung. Jetzt klappt es mit der Aufnahme und mit dem Abspielen. Den Hinweis in der Signatur hatte ich übersehen. Entschuldigung.

 

Jetzt muss ich nur noch herausfinden, wie man den Fehler wegbekommt, das teilweise nach 5 Minuten der Bildschirm schwarz wird.

 

Danke noch einmal allen, die Ihre Hilfe und Erfahrungen in diesem Board preisgeben.

 

Gruß

Ralf ;)

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi,

schön das es klappt...

Den Hinweis in der Signatur hatte ich übersehen. Entschuldigung.
Den Hinweis konntest du garnicht sehen, ich hab meine Sig erst nach deiner PM geändert ;) ...

 

Ciao,

DdD.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo, die anleitung klappt super zumindest unter linux und XP ....

 

Bei Vista kommt immer die meldung "Puffern" und spring dann irgendwann wieder ins menu zurück, hat jemand eine idee woran das liegen könnte ? Ich hab schon gegoogelt aber ohne erfolg.

 

Gruß

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

hab jetzt auch auf die 4er gedowngradeed da zeigt er mir zumindest den ordnerinhalt richtig an bleibt dann aber immer beim starten des streamservers hängen...was könnte das sein?

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hmm jetzt habe ich mir das alles mal durch gelesen.

 

Meine Frage welche VLC Version ist die Beste ?

 

Ich habe gesehen das es eine Neue 0,86b gibt was ist da wieder besser ?

 

Ich habe die Version 0,80 die ght soweit ab und zu bleibt sie hängen wenn ich ein Stream vom PC auf die Box abspielen will sonst ist sie ok.

 

Welche ist die Beste VLC Version?

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Habe folgendes Problem bei abspielen von VOB Files.

Da der VLC die IFO nicht "anspielt" lasse ich die VOB direkt spielen.

Alleridngs hat der VLC dann keine Info über das Seitenverhältnis.

Im DesktopMode von VLV kann ich unter Video-Seitenverhältnis diesen auf 16:9 anpassen dann passt es.

Wenn ich aber über die DBOX streame is die opion auf dem streamingserver nicht mehr möglich. So habe ich ein vertikal gepresstes Bild auf der 16:9Glotze.

Da ich unbedingt den AC3 Ton will und VLC nbenutzen will (wegen Bitratebegrenzung- antiruckel^^) wäre ich um Hilfe dankbar.

Andere Videodatei bauen für den VLC? TS liest er nicht...

und bei avi usw geht ist bild schlechter bzw kein ac3 ton mit vlc....

 

Danke

Sis

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

nachtrag.

die vobfiles per vlc fangen nach 3 -4 mins spieldauer auch zum ruckeln an.

auch per nfs oder cifs ruckeln die filme (hier als ts gespeichert)

hmmm???

 

sis

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Gast
Du kommentierst als Gast. Wenn du bereits einen Account hast kannst du dich hier anmelden.
Auf dieses Thema antworten...

×   Du hast formatierten Text eingefügt.   Formatierung jetzt entfernen

  Only 75 emoji are allowed.

×   Dein Link wurde automatisch eingebettet.   Einbetten rückgängig machen und als Link darstellen

×   Dein vorheriger Inhalt wurde wiederhergestellt.   Clear editor

×   Du kannst Bilder nicht direkt einfügen. Lade Bilder hoch oder lade sie von einer URL.


  • Wer ist Online   0 Benutzer

    Keine registrierten Benutzer online.

×