Jump to content
SnowHead

Was geht schief beim Flashen oder Debugmodus?

Empfohlene Beiträge

Hier erst mal die Haupt-Problemursachen (geordnet nach Häufigkeit):

 

Given up BOOTP/TFTP boot und boot net failed:

  • PC und Box können sich nicht schnell genug auf eine Geschwindigkeit einigen
  • Firewall, Virenscanner oder SP2 bei XP
  • falsches, defektes oder nicht eingestecktes Netzwerkkabel
  • Netzwerkkarte hat alte Treiber, keine fixe IP oder kann keine 10 MBit/s
  • Netzwerkkarte oder Netzwerkschnittstelle der Box kaputt
  • ein zweiter installiertes Netzwerkadapter führt zu Kollisionen

nach Antwort auf Bootrequest kein TFTP-Transfer:

  • Firewall, Virenscanner, Tools zum anonymen Surfen, Netzwerksniffer (winpcap)
  • ein im Netzwerk laufender DHCP-Server hat statt des PC den Request beantwortet

Was ist bei Problemen zu überprüfen?

  • leuchtet die Link-LED der Netzwerkkarte bei eingeschalteter Box?
  • sind alle Firewalls, Virenscanner (Norton AV deinstallieren!), Tools zum anonymen
    Surfen und Netzwerksniffer deaktiviert/deinstalliert?
  • ist der DHCP-Server auf PC und ggf. Router deaktiviert?
  • laufen weitere NFS-Server auf dem PC?
  • ist mein Nullmodemkabel in Ordnung?

Hinweis: Ein funktionierendes Nullmodemkabel ist bei Netzwerkproblemen

unabdingbar. Zum Einen, um das "boot net failed" fixen zu können, zum

Anderen, um aus dem seriellen Log auf die Fehlerursache schließen zu

können.

 

 

Jetzt die Theorie zum Booten/Flashen übers Netzwerk:

Nach dem Einschalten versucht die Box, vom PC (Bootmanager) eine IP

zugeteilt zu bekommen:

debug: Transmitting BOOTP request via broadcast

debug: Got BOOTP reply from Server IP 192.168.6.25, My IP 192.168.6.202

Kommt stattdessen so etwas

debug: Given up BOOTP/TFTP boot

kam der Bootrequest nicht beim PC an. In den meisten Fällen konnten sich Box und

PC nicht schnell genug auf eine Verbindungsgeschwindigkeit einigen, so daß der

einzige Bootrequest des Bootmanagers in's Leere geht. Abhilfe schaffen entweder

der Flash-Assistent, welcher die Box anweist, den Bootrequest 10 Mal zu wieder-

holen:

debug: autoboot aborted from terminal

dbox2:root>

dbox2:root> boot net net net net net net net net net net

und damit Box um PC genügend Zeit zu geben, die Geschwindigkeit auszuhandeln,

oder folgende Methode bei Verwendung des Bootmanagers:

  • Box über gleichzeitiges Drücken der Standby- und Pfeil-nach-oben-Taste an der
    Front resetten
  • Standby-Taste loslassen, Pfeil-Taste weiter gedrückt halten bis das Prompt in
    der seriellen Konsole erscheint
  • in der seriellen Konsole "boot net" eingeben und Enter drücken
  • weitermachen nach der jeweiligen Anleitung

In einigen Fällen wird der Bootrequest jedoch noch von Firewalls oder Virenscannern

geblockt. Auch das SP2 von Windows XP installiert nicht abschaltbare Schutzfunktio-

nen, welche einen Bootrequest abblocken. Diese Probleme müssen behoben werden,

ehe es weitergehen kann.

Taucht so etwas im Log auf:

debug: Unknown RFC1048-tag debug: 6 debug: 4 debug: c0 debug: a8 debug: 1

ist der Bootrequest statt vom PC von einem DHCP-Server aus dem Netzwerk (Router?)

beantwortet worden. Dieser sollte abgeschaltet werden, da die Box nun versuchen

würde, ihre Bootfiles vom Router statt vom PC zu holen. Die hat der aber nicht.

 

Hat die Box nun ihre IP bekommen, versucht sie ein ausführbares Bootprogramm

(ppcboot) per TFTP vom PC zu laden:

debug: Sending TFTP-request for file C/Dbox2Bootmanager/ppcboot

will verify ELF image, start= 0x800000, size= 140336

verify sig: 263

boot net: boot file has no valid signature

Branching to 0x40000

Wird der TFTP-Transfer durch ein Schutzprogramm auf dem PC geblockt, sieht

das Log allerdings so aus:

debug: Sending TFTP-request for file C/Dbox2Bootmanager/ppcboot

debug: Sending TFTP-request for file C/Dbox2Bootmanager/ppcboot

debug: Sending TFTP-request for file C/Dbox2Bootmanager/ppcboot

debug: Sending TFTP-request for file C/Dbox2Bootmanager/ppcboot

debug: Sending TFTP-request for file C/Dbox2Bootmanager/ppcboot

debug: Sending TFTP-request for file C/Dbox2Bootmanager/ppcboot

debug:

TFTP failed, giving up...

boot net failed

boot: elfcopy failed: 16

In diesem Fall sind die entsprechenden Programme zu deaktivieren.

 

Hat die Box nun die ppcboot bekommen, wird diese ausgeführt. Beim Debug-

Modus bietet die ppcboot die erforderlichen Kommandos an, um die Box in den

Debug zu bringen, beim Flashen versucht die ppcboot, das zu flashende Image

per TFTP vom PC zu holen. Enthält der Pfad und der Dateiname des Images keine

Leerzeichen, sollte an dieser Stelle kein Problem mehr auftreten. In manchen

Fällen kann es jedoch vorkommen, daß das Schutzprogramm erst hier zuschlägt.

Der Flash-Assi würde in diesem Fall seine Arbeit kommentarlos einstellen und neu

booten, beim Bootmanager würde der lange Block aus Rauten fehlen, welcher die

Übertragung des Images anzeigt. Der Bootmanager würde so etwas anzeigen:

BOOTP broadcast 1

BOOTP broadcast 2

BOOTP broadcast 3

BOOTP broadcast 4

BOOTP broadcast 5

 

Retry count exceeded; starting again

Also bei Problemen auch hier die Schutzprogramme des PC überprüfen.

 

 

weitere Fehlermeldungen des Bootmanagers

oder Flash-Assi:

 

Bootmanager: Error 10048 in function Bind Address already in use

Flash-Assi: FEHLER Der UDP Port 67 und 68 wird derzeit von der Internet-

verbindungsfreigabe [sychost.exe] belegt.

oder

Error 10049 in function Bind Adress not available

 

Die gewählte IP wird bereits von einer anderen Anwendung belegt. Meist ist das

die aktivierte Internet-Verbindungsfreigabe (ICS). In den erweiterten Einstellungen

des Internetadapters sind die Haken, welche die Nutzung der Verbindung durch

andere Netzwerkteilnehmer gestatten, zu entfernen.

 

listen:WSocketResolveProto: Cannot convert protocol 'udp',Error '11004

Glückwunsch! Ihr habt euch einen Trojaner eingefangen, welcher Euer Netzwerk

für seine Zwecke verbogen hat. Abhilfe gibt es hier.

 

Unable to open com port (win error code: 5)

Eine andere Anwendung hat sich den COM-Port gekrallt. Meist ist das ein Synchro-

nisationsprogramm für Handys (ActiveSync) oder andere IRDA-Geräte, eine von

einem anderen Programm über den COM-Port eingerichtete Einwahlverbindung

oder ein von Euch gestartetes Programm (HyperTerminal, Terminal, ein zweiter

Bootmanager). Also rausfinden, wer der Verursacher ist, und ihm den COM-Port

wieder wegnehmen.

 

Es wurde keine einzige Netzwerkkarte gefunden, für die der Packet-Treiber

gestartet werden konnte! Bitte bauen Sie eine andere Netzwerkkarte ein!

Hier sollte der Treiber der Netzwerkkarte aktualisiert werden. Auch Netzwerk-

snifferanwendungen wie winpcap installieren und hinterlassen DLL's, welche

den Zugriff des Bootmanagers auf die Karte verhindern. Installiert wird winpcap

unter Anderem von Etherreal oder Nmap.

 

Couldn´t start Packet Driver (C1, )?!

The program will terminate (crash) right now !

Ihr habt eine Pentium-CPU und Windows-XP. Im BIOS des PC muß das Hyper-

threading deaktiviert werden, sonst funktioniert der Bootmanager nicht.

Alternativ kann man (vor allem bei richtigen Dual-Core-Prozessoren) auch die

Mehrprozessorunterstützung durch einen zusätzlichen Eintrag im Bootmenü aus-

schalten, so daß man wahlweise mit oder ohne Multiprozessorunterstützung starten

kann. Der zusätzliche Eintrag sieht so aus:

[boot loader]

timeout=3

default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS

[operating systems]

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /NOEXECUTE=OPTIN /FASTDETECT /USEPMTIMER

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows XP ohne Hyperthreading" /fastdetect /numproc=1

to be continued ....

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Couldn´t start Packet Driver (C1, )?!

The program will terminate (crash) right now !

Ihr habt eine Pentium-CPU und Windows-XP. Im BIOS des PC muß das Hyper-

threading deaktiviert werden, sonst funktioniert der Bootmanager nicht.

 

auch folgende Meldung:

(Packet Driver Fehler beim RARP Server Start)

Lösung

HyperThreading (Multi-Prozessor) im Bios abschalten

 

Bootmanager: Error 10048 in function Bind Address already in use

Flash-Assi: FEHLER Der UDP Port 67 und 68 wird derzeit von der Internet-

verbindungsfreigabe [sychost.exe] belegt.

Die gewählte IP wird bereits von einer anderen Anwendung belegt. Meist ist das

die aktivierte Internet-Verbindungsfreigabe (ICS). In den erweiterten Einstellungen

des Internetadapters sind die Haken, welche die Nutzung der Verbindung durch

andere Netzwerkteilnehmer gestatten, zu entfernen.

 

auch folgende Meldung:

(Fehler 10048-10049)

Lösung:

Internet-Verbindungs-Freigabe abschalten_feste IP Nummer zuweisen

 

stay tuned

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Gast jamalau

HyperThreading abschalten, geht auch ohne im BIOS etwas verstellen zu müssen.

In meinem BIOS kann ich es gar nicht abschalten.

 

Einfach in der boot.ini die untere Zeile einfügen.

Die Partitionsnummern müssen natürlich entsprechend angepasst werden.

 

[boot loader]

timeout=3

default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS

[operating systems]

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /NOEXECUTE=OPTIN /FASTDETECT /USEPMTIMER

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows XP ohne Hyperthreading" /fastdetect /numproc=1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

... ist zwar schon alt, aber eventuell hilfts ja jemandem:

 

CPU Zuordnung geht auch komplett ohne booten oder jeglichen Änderungen an der boot.ini oder dem BIOS.

 

- DBox_Boot.exe starten

- unter "Start->Ausführen" "taskmgr" eintippen (od. ctrl-alt-del)

- zum "Prozesse" tab wechseln

- mit der rechten Maustaste auf "DBox_Boot.exe" und den letzten Punkt wählen. bei meinem englischen System ist das "Set Affinity...", auf deutsch wahrscheinlich "Zuordnung..." oder so ähnlich.

- dann einfach den Haken bei einer CPU entfernen und das Programm läuft nur noch auf der anderen CPU (bzw. einem thread)

 

Gruß.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

hallo

 

danke für den super beitrag.habe meine dbox geplättet,bevor ich das hier gefunden hatte.

 

mfg 505050 :D

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Also ich sag mal ganz fett danke..habe eben einenfslh gemacht wobei raus kam KEIN SYSTEM. Mit dem Flash Tool von Hallenberg hab ich es wieder geschfft das System ans laufen zu bringen.

 

Eure Tips sind Gold Wert THX

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

die UDP port meldung im Flashassi kann man verhindern, indem man folgendes unternimmt:

 

Start->Ausführen->services.msc

 

dann windows firewall gemeinsame nutzung ausschalten und fertig!

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi,

ich möchte gerne einen Nachtrag zu dem Thema setzten.

Ich wollte über den Assis von Hallenberg ein image installieren. Egal was ich gemacht habe. Ich habe mit Netzwerkkarte und Nullmodemkabel gearbeitet. In der Ausgabe von Hallenberg stand immer nur

debug: Sending TFTP-request for file C/dboxifa_tmp/tftpboot/u-boot

ich hatte auch alle Programme beendet. Antivirus usw.

Ich muss noch sagen, das ich zwei Netzwerkkarten im System habe.

Durch einen Tipp durch unseren Chat hier. Habe ich doch mal die andere Netzwerke genommen und dann hat es geklappt.

Das wollte ich also nur sagen, wenn der TFTP nicht gestratet werden kann und auch kein Error kommt und ihr zwei Netzwerkarten habt. Deaktiviert die andere und versucht euer Glück mit der anderen.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Gast
Dieses Thema wurde für weitere Antworten geschlossen.

×
×
  • Neu erstellen...