Jump to content
Melde dich an, um diesem Inhalt zu folgen  
Mr.Servo

aktuelle & regionale Senderbelegungen (Belegungsliste)

Empfohlene Beiträge

Hi Zusammen,
dies ist vielleicht längst bekannt (oder auch weniger), aber ich habe hier im Forum nichts Vergleichbares gefunden!

 

Gültig für: Kabelkunden (Vodafone & Vodafone West {ehemalig Unity Media})

Es gibt bundesweit recht viele Vodafone-Kabelnetze mit unterschiedlichen Belegungen. Dies steht einer einzelnen bundesweit gültigen cables.xml im Wege. Es gibt aber einen Ausweg: Das inoffizielle VF-Kabelforum stellt neben einer regionalen cables.xml auch andere Dateien zum Download bereit.

 

Wie komme ich da ran?
https://helpdesk.vodafonekabelforum.de/sendb/belegung.html
dann Bundesland + Netz oder Stadt/Gemeinde angeben und man kriegt seine eigene die Belegungsliste angezeigt. Jetzt noch ganz runterscrollen und man sieht u.a.:


Die digitale Belegung...
    exportieren für Neutrino
    exportieren für DVB2000
    exportieren für Enigma2
    exportieren für VDR

 

Neutrino anklicken und das Downloadfile "export.zip" enthält nun folgende (regionale) Daten:

 

[Edit/Nachklapp]:
/var/tuxbox/config
  cables.xml
  epgfilter.xml {obsolet, bitte nicht benutzen}
/var/tuxbox/config/zapit
  bouquets.xml {obsolet, bitte nicht benutzen}
  myservices.xml {obsolet, bitte nicht benutzen}
  services.xml {obsolet, bitte nicht benutzen}

 

VORSICHT: Außer der cables.xml bitte nicht die anderen Datein mit einspielen, denn diese befinden sich noch in einem alten Format und führen daher sehr wahrscheinlich zu Problemen in heutigen Images.

 

ACHTUNG: Vorher UNBEDINGT seine eigene /var/tuxbox/config/zapit/ubouquets.xml retten, denn sonst gehen die eigene Senderbelegung "Meine Favoriten" flöten.

 

Danach sicherheitshalber Neustarten und danach die "Automatische Suche (Kabelanbieter)" durchführen und seine ubouquets.xml zurückkopieren/reaktivieren. Dann ggf. seine "Meine Favoriten" noch über die "Bouquet-Verwaltung" nacheditieren. Ich habe das bei mir getestet und habe einen guten Eindruck! Jedenfalls sind alle verfügbaren Sender (auf 33 Transpondern: TV= 360, Radio= 124, Gesamt= 460) gemäß Belegungsliste drin.

 

Hinweis: Die sich momentan im KW-Update befindliche cables.xml (von waves) stammt aus dem Großraum Braunschweig, funktioniert aber soweit auch woanders ganz gut, ist also ein Kompromiß. Ich habe mir mal verschiedene cables.xml aus diversen Regionen runtergeladen und verglichen: Sind nicht so furchtbar viele Abweichungen drin, aber man weiß ja nie...

 

Gruß......Mr.Servo

bearbeitet von Mr.Servo
Formatierung
  • Like 1
  • Thanks 1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Die Unterschiede der einzelnen Regionen liegen meistens bei den regionalen Sendern.....

 

Im Großraum Braunschweig zB der TV Sender "TV38", der natürlich in München oder Hamburg nicht eingespeist wird.

 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Da ja via Helpdesk die Daten im alten Api-Format für die dbox2  ...


        <transponder id="2" onid="270f" frequency="370000000" inversion="2" symbol_rate="6900000" fec_inner="9" modulation="5">
            <channel service_id="dab" name="STB channel config." service_type="28"/>
            <channel service_id="f07" name="Humax PR-HD2000C" service_type="28"/>
            <channel service_id="f8c" name="Humax PR-HD3000C" service_type="28"/>
            <channel service_id="f9a" name="Pace TDC 866 NSDX" service_type="28"/>
            <channel service_id="8" name="Sky Cinema Fun" service_type="1"/>
            <channel service_id="9" name="Sky Cinema Action" service_type="1"/>
            <channel service_id="a" name="Sky Cinema Premieren" service_type="1"/>
            <channel service_id="1e" name="Sky Sport Austria 1" service_type="1"/>
            <channel service_id="2b" name="Sky Cinema Premieren +24" service_type="1"/>
            <channel service_id="204" name="Sky Cinema Classics" service_type="1"/>
            <channel service_id="b" name="Sky Cinema Thriller HD" service_type="19"/>
        </transponder>

bereitgestellt werden rate ich vom direkten Einsatz unter einen aktuellen neutrino davon ab denn aktuell gilt ja dort API 4 bei der es z.B. wie folgt aussieht ...


        <TS id="2" on="85" frq="370000" inv="2" sr="6900000" fec="9" mod="5" sys="2">
            <S i="dab" n="STB channel config." t="28"/>
            <S i="f07" n="Humax PR-HD2000C" t="28"/>
            <S i="f8c" n="Humax PR-HD3000C" t="28"/>
            <S i="f9a" n="Pace TDC 866 NSDX" t="28"/>
            <S i="8" n="Sky Cinema Fun" t="1"/>
            <S i="9" n="Sky Cinema Action" t="1"/>
            <S i="a" n="Sky Cinema Premieren" t="1"/>
            <S i="1e" n="Sky Sport Austria 1" t="1"/>
            <S i="2b" n="Sky Cinema Premieren +24" t="1"/>
            <S i="204" n="Sky Cinema Classics" t="1"/>
            <S i="b" n="Sky Cinema Thriller HD" t="19"/>
        </TS>

 

Die vom Helpdesk bereitgestellten Daten lassen sich aber trotzdem ganz ordenlich mit neuerer Hardware mit einen neueren neutrino-Image nutzen denn dafür gibt es ja das Plugin "Vodafone" dieses erstellt das gewünschte via Auswahlmenü direkt auf der Box und legt gleichzeitig Backupdateien der alten Zapitdaten an welche sich mit den gleichen Plugin direkt wieder herstellen lassen.

 

ps.: Die ubouquets.xml wird von den Plugin nicht angefasst, keine Garantie dass es mit allen Images so einfach geht, da gibt es leider zu viele Unterschiede

 

vodafone.zip

  • Thanks 1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 14 Stunden schrieb Bazi98:

Die vom Helpdesk bereitgestellten Daten lassen sich aber trotzdem ganz ordenlich mit neuerer Hardware mit einen neueren neutrino-Image nutzen denn dafür gibt es ja das Plugin "Vodafone" dieses erstellt das gewünschte via Auswahlmenü direkt auf der Box und legt gleichzeitig Backupdateien der alten Zapitdaten an welche sich mit den gleichen Plugin direkt wieder herstellen lassen.

Hi Bazi98,

ich habe mir das Vodafone-Plugin gezogen, alle drei Dateien ins Verzeichnis /var/tuxbox/plugins kopiert, die Rechte der vodafone.sh auf 755 gesetzt und das Plugin im Menü "blaue Taste" ergänzt. Aber ich kriege nur die Auswahl "Ja / Reset / Nein" und bei "Ja" lande ich im KW-Menü. Ich schätze mal, das ist ein Irrläufer? What's wrong? Fehlt mir noch irgendwas zum ganzen Glück?

Gruß & Danke......Mr.Servo

bearbeitet von Mr.Servo

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 3 Stunden schrieb Bazi98:

bereitgestellt

OK verstanden! Was mich dann aber wundert ist, daß das "alte" API-Format immer noch perfekt im aktuellen KW-Image (beta v4.12b1) läuft. Ich bin jetzt nun auch nicht wirklich der König der cables.xml, aber das "neue" API-Format habe ich bislang noch nie gesehen (was aber auch nix zu heißen mag), auch nicht in "annie's neutrino settings" unter https://github.com/horsti58/lua-data

Kannst Du ein wenig Licht ins Dunkel bringen?

Danke & Gruß......Mr.Servo

bearbeitet von Mr.Servo

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 1 Stunde schrieb Mr.Servo:

 What's wrong? Fehlt mir noch irgendwas zum ganzen Glück?

Gruß & Danke......Mr.Servo

Im Script ist an mehreren Stellen ein Verweis auf dies shellexec...

/var/tuxbox/plugins/shellexec.so

sollte die bei dir im Image wo anders liegen und/oder anders  heisen musst du die entsprechenden Stellen im Script darauf anpassen

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Zu deiner 2 Frage

Es handelt sich bei den als Bsp. zeigten Code-Schipsel nicht um Ausschnitte der cabels.xml sondern um die services.xml also die eigentliche Senderliste sowie auch bouqets.xml die haben inzw. ein anderes Format als in den Downloadpack vom helpdesk für die dbox und deshalb habe ich gewarnt die Dateien aus dem helpdesk einfach so auf eine aktueller Box zu packen;)

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 9 Stunden schrieb Bazi98:

Es handelt sich bei den als Bsp. zeigten Code-Schipsel nicht um Ausschnitte der cabels.xml sondern um die services.xml also die eigentliche Senderliste sowie auch bouqets.xml die haben inzw. ein anderes Format als in den Downloadpack vom helpdesk für die dbox und deshalb habe ich gewarnt die Dateien aus dem helpdesk einfach so auf eine aktueller Box zu packen;)

Danke Dir für die Klarstellung! Dann sind die cables.xml vom Helpdesk formattechnisch in Ordnung, aber die anderen Dateien sind in einem längst obsoleten Format.

Danke für Deine Warnung, ich werde das gleich ganz oben im Thread noch nachtragen!

Gruß......Mr.Servo

bearbeitet von Mr.Servo

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 9 Stunden schrieb Bazi98:

Im Script ist an mehreren Stellen ein Verweis auf dies shellexec...


/var/tuxbox/plugins/shellexec.so

sollte die bei dir im Image wo anders liegen und/oder anders  heisen musst du die entsprechenden Stellen im Script darauf anpassen

Danke für den Hinweis, aber ich sehe gerade, daß sie auch im KW-Image hier abliegt: /var/tuxbox/plugins/shellexec.so

Hast Du noch eine Idee woran es liegen könnte? Läuft das Plugin "Vodafone" denn bei den anderen auf Anhieb?

Gruß & Danke.....Mr.Servo

bearbeitet von Mr.Servo
Schreibfehler

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi,

na, das ist doch mal ein schöner Einstieg für dich, da muss nämlich einiges geändert werden, da hat sich wohl einiges auf der Homepage geändert, vermutlich im Zuge der Integration von UM in VFKD.

 

Mein Tip: immer das Log mitlaufen lassen, dort siehst du dann die Fehlermeldungen (meist sogar mit Angabe der entspr Zeilennummer im Script), wo es hakt. Aktuell kann ich zwar noch das Bundesland auswählen, aber egal, welches ich nehme, gibt es einen curl-Error, weil scheinbar der Pfad nicht stimmt, das müsste man dann nachvollziehen und das Skript entspr anpassen.

 

Ciao,

DdD.

 

PS: eigentlich müsste man sich vorher noch vergewisssern, ob man dadran überhaupt basteln darf, ist ja leider keine Lizenzangabe vorhanden (GPL2 o.ä.) :)

 

PPS: im Skript erfolgt übrigens scheinbar eine Umwandlung von alter API zu API4. ;)

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

@Don de Deckelwech

Danke für die Hinweise! Genau, auf das Thema habe ich auch Lust und basteln darf ich sicher (kriegt ja keiner mit), nur es nicht veröffentlichen, korrekt?

Gruß.....Mr.Servo

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi,

ich gehe davon aus, dass Bazi98 nichts dagegen hat, wenn du es anpasst und wieder hier zur Verfügung stellst, aber auf der sicheren Seite ist man, wenn man sowas von ihm selbst hört... :)

 

Ciao,

DdD.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Wußte nicht, das es das Projekt von Bazi98 ist, aber Danke, dann werde ich gleich mal nachfragen. Bei der Corona-Plugin hatte ich auch Fred vorher gefragt, ob er was dagegen hätte wenn ich seine für KW-modifizierte Version (also eine KW-Pfadanpassung sowie die entfernte Updatefunktion) ins KW setze. War ihm nicht so recht und er hat daraufhin die Sache selbst in die Hand genommen.

Gruß.....Mr.Servo

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

@Bazi98

Weißt Du wen man bezüglich der "Vodafone.sh" um Zustimmung einer Änderung fragen kann?

Gruß.....Mr.Servo

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Mit, die "Vodafone.sh" startet mit "JA / RESET / NEIN" und wenn ich ja drücke lande ich im KW-Menü (blaue Taste).

 

Hier das Log: (rot= Vodafone.sh "läuft"; grün= Abbruch)

 

HD51-FF4F8D:~# [shellexec.so] parent, waiting for child with pid 25394...
[shellexec.so] forked, executing shellexec

[shellexec.so] script return code: 0
[shellexec.so] parent, waitpid() returned..
[shellexec.so] child returned with status 0

Irgendwas stimmt (bei mir?) mit der Shellexec.so nicht oder?

Gruß.....Mr.Servo

bearbeitet von Mr.Servo

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 1 Stunde schrieb Don de Deckelwech:

da hat sich wohl einiges auf der Homepage geändert, vermutlich im Zuge der Integration von UM in VFKD.

Ja, das stimmt. In der Vodafone.sh müßte folgendes geändert werden:

 

Zeile 42

alt: url="https://helpdesk.kdgforum.de"
neu: url="https://helpdesk.vodafonekabelforum.de"

 

Zeile 115

alt: curl --no-progress-meter --insecure -k -L "$url/sendb/kopfstation/$select.html"

neu: curl --no-progress-meter --insecure -k -L "$url/sendb/kopfstationen.html"

 

Wobei sich nicht nur die Adresse sondern auch die Struktur geändert hat. Aber soweit komme ich leider mit "Vodafone.sh" nicht, denn ich lande im plötzlich "Keywelt-Menü". Mist ist das.

 

Gruß......Mr.Servo

bearbeitet von Mr.Servo

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi,

vllt liegts auch an der msgbox. Starte die mal per Telnet mit "/bin/msgbox" und schau so nach, welche Version das ist...

edit: Im NI ist es 2.14

 

Ciao,

DdD.

bearbeitet von Don de Deckelwech

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hier das Ergebnis:

HD51-FF4F8D:~# /bin/msgbox
MsgBox Version 2.14


Syntax:
    msgbox msg="text to show" [Options]
    msgbox msg=filename [Options]
    msgbox popup="text to show" [Options]
    msgbox popup=filename [Options]


Options:
    -v || --version       : only print version and return
    title="Window-Title"  : specify title of window
    size=nn               : set fontsize
    timeout=nn            : set autoclose-timeout
    icon=n                : n=none(0), error(1), info(2) or /path/my.png (default: "info")
    refresh=n             : n=1..3, see readme.txt
    select="Button1,.."   : Labels of up to 24 Buttons, see readme.txt
    absolute=n            : n=0/1 return relative/absolute button number (default: 0)
    order=n               : maximal buttons per line (default: 3)
    default=n             : n=1..buttons, initially selected button, see readme.txt
    echo=n                : n=0/1 print the button-label to console on return (default: 0)
    hide=n                : n=0..2, function of mute-button, see readme.txt (default: 1)
    cyclic=n              : n=0/1, cyclic screen refresh (default: 1)
HD51-FF4F8D:~#

Gruß.....Mr.Servo

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi,

das ist soweit Ok.

Hmm, wenn ich das vodafone-Plugin auf der HD51 im NI-Image starte, kommt das als Ausgabe, wenn ich bei der Auswahl "Ja" auswähle, danach kommt dann die Auswahlmöglichkeit des Bundeslandes:

key: 0160 value 1, translate: 0160 -ok-


[CPlugins] executing script /var/tuxbox/plugins/vodafone.sh
[rcinput:open] opened /dev/input/event3 (fd 45) ev 0x100013
[rcinput:open] opened /dev/input/event2 (fd 48) ev 0x3
[rcinput:open] opened /dev/input/event1 (fd 50) ev 0x100003
[rcinput:open] opened /dev/input/event0 (fd 51) ev 0x100003

 

Vllt hilft das (Markham?)...

 

Ciao,

DdD.

 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Achja: Wenn ich bei "Vodafone.sh" auf JA drücke und dann im Keywelt-Menü (roter Knopf: System-Menü) und das dann wieder verlasse gibt es folgende Fehlermeldung auf dem Bildschirm:

"Pluginausgabe" rc_device: using /dev/input/event1

Vielleicht liegt da der Hund begraben?

Gruß.....Mr.Servo

 

bearbeitet von Mr.Servo

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

@Mr.Servo

 

"shellexec.so" ist nur ein sogenannter "Shellstarter", welcher es ermöglicht, die shellexec aus Neutrino heraus aufrufen zu können.

Das Hilfsprogramm "shellexec" selbst liegt im KW-Image in /bin. Für den Aufruf der shellexec am besten alle Pfadangaben vorher weglassen, da sie in einem Pfad liegt, in welchem beim Aufruf vom System von vornherein nachgesehen wird. Und ohne ".so" am Ende. Also z.B. nur

shellexec /tmp/bundesland.conf > /dev/null

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

@SnowHead

Habe ich gerade eben so umgesetzt, also in "Vodafone.sh" 3x um den Pfadangabe "/var/tuxbox/plugins" rasiert (Zeile 84, 110 und 149).

Resultat: Leider keine Verbesserung.

Habe das "Vodafone"-Plugin eben auch auf meiner CST Neo² gestest.

Resultat: genau das gleiche Verhalten, genau das gleiche Log (siehe oben).

 

Sagt mal, läuft denn das Plugin bei euch im KW-Image? Kann das einer mal gegenchecken, sind ja gerade mal drei Dateichen die hier abliegen. Was kann das sein, daß es ein Script mit einem Aufruf der "/var/tuxbox/plugins/shellexec.so" dermaßen aus der Bahn wirft?

Danke & Gruß......Mr.Servo

bearbeitet von Mr.Servo
Schreibfehler

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi!

also hier die LOG der Mut@ant HD51 (rot= Vodafone.sh "läuft"; grün= Abbruch) :

 

HD51-FF4F8D:~# [shellexec.so] parent, waiting for child with pid 9289...
[shellexec.so] forked, executing shellexec

[shellexec.so] script return code: 0
[shellexec.so] parent, waitpid() returned..
[shellexec.so] child returned with status 0

 

OSD-Fehlermeldung: "Pluginausgabe" rc_device: using /dev/input/event1

 

und hier die LOG der CST Neo2 (rot= Vodafone.sh "läuft"; grün= Abbruch) :

 

 


neo2:~# [shellexec.so] parent, waiting for child with pid 3360...
[shellexec.so] forked, executing shellexec

[shellexec.so] script return code: 0
[shellexec.so] parent, waitpid() returned..
[shellexec.so] child returned with status 0

 

 

OSD-Fehlermeldung: "Pluginausgabe" rc_device: using /dev/input/nevis_ir

 

Das Verhalten ist identisch.

 

Gruß.....Mr.Servo

bearbeitet von Mr.Servo

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Melde dich an, um diesem Inhalt zu folgen  

  • Wer ist Online   0 Benutzer

    Keine registrierten Benutzer online.

×
×
  • Neu erstellen...