Jump to content
Melde dich an, um diesem Inhalt zu folgen  
Spelli99

Keywelt Image installiert, Box bootet nicht mehr

Empfohlene Beiträge

Hallo und einen schönen guten Abend,

 

Habe mir gerade die coolstream Tank abgeschossen.

Hatte vom anderen Bord das Image drauf. Musste die Box neu flashen hat auch alles soweit geklappt. Nur die Doscam bekam ich nicht mehr ans laufen.

Leider bekam ich in den Board auch keine gute Hilfe von denen. Deswegen habe ich mich entschlossen, euer Image zu installieren.

Leider ist mir das daneben gegangen. Habe mir im Download Bereich die "tank_201906221939_KEYWELT_V3.92_Jun.256k.img" runter geladen und installiert.

Nach dem booten bleibt die Box jetzt hängen. Im Display steht "Starting".

 

Ich weiss von Früher, das es die Möglichkeit über USB und serielle Schnittstelle die Box wieder hoch bekommt. Nur eine serielle Schnittstelle habe ich leider nicht mehr zur Verfügung.

Gibt es noch andere Möglichkeiten wie ich die Box wieder beleben kann ?

 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi (edit: kefeqi ;) ),

Link per PN.

Packe den Inhalt des einen .zips und die beiden anderen Dateien auf einen FAT32-Usb-Stick und dann analog zu dieser Anleitung verfahren:

Ciao,

DdD.

 

PS2: achso, zur Erklärung: höchstwahrscheinlich war dein vorhandener Kernel zu alt, der passte nicht zu dem moderneren KW-Image. Der Kernel wäre zwar ausgetauscht worden, aber erst nachdem das Image starten konnte, was aber ja nicht ging. ;)

bearbeitet von Don de Deckelwech

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 16 Stunden schrieb Don de Deckelwech:

Hi (edit: kefeqi ;) ),

Link per PN.

Packe den Inhalt des einen .zips und die beiden anderen Dateien auf einen FAT32-Usb-Stick und dann analog zu dieser Anleitung verfahren:

Ciao,

DdD.

 

PS2: achso, zur Erklärung: höchstwahrscheinlich war dein vorhandener Kernel zu alt, der passte nicht zu dem moderneren KW-Image. Der Kernel wäre zwar ausgetauscht worden, aber erst nachdem das Image starten konnte, was aber ja nicht ging. ;)

 

Hey DdD

Danke für die Dateien, aber leider funktioniert es nicht, es passiert genau das gleiche er bleibt beim Startbildschirm hängen.

Habe darauf das Emergeny Tool vom anderen Forum getestet. Das funktioniert. Danch startet die Box wieder. Wenn ich daraufhin das Keywelt Image

tank_201906221939_KEYWELT_V3.92_Jun.256k.img installiere, dann bleibt die Box wieder hängen.

Wie im anderen Forum ja schrieben wäre dieses Image nicht so alt wie was es dort gibt.

Oder habe ich hier das falsche Image?

 

bearbeitet von Spelli99

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Du nimmst das EFC Image, dann das 302er in den /tmp kopieren und locales Image flashen. Nun solle ein KW Image möglich sein, das liegt am alten Kernel vom EFC wie DdD schon schrieb. 

Wenn nur das Image als File vorliegt, muss der vorherige Kernel das geflasht Image starten, dann wird durch das neue Image ein Kernel Update durchgeführt. Das klappt aber nicht wenn das neue Image mit dem alten Kernel nicht zusammen läuft. 

Anders beim EFC, da liegen alle Partitionen auf dem Stick und werden nacheinander in den Flash geschrieben, beim booten sind alle Image relevanten Partitionen sofort startbereit. 

Wenn KW ein Image als EFC anbietet (alles einzelne Files), hab nicht nachgesehen, dann klappt der Recovery Vorgang genauso. 

bearbeitet von topie88
Ergänzungen
  • Like 1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

@ topie88

Danke für deine Info,

Kann leider kein EFC Image finden. Eventuell kann ich es auch nicht erkennen welches das sein soll.

Es wäre schön wenn du oder ein anderer mir den entsprechenden Link posten kann.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi,

Zitat

Wenn KW ein Image als EFC anbietet (alles einzelne Files), hab nicht nachgesehen,

nein, gibts nicht (nur für Trinity). In meinem Link per PN hab ich ihm das Image, den daraus operierten aktuellen Kernel und die leere env.bin zur Verfügung gestellt.

Vllt hätte noch uldr und u-boot dazugemusst, aber die wurden doch afaik schon seit Ewigkeiten nicht erneuert (war halt faul gestern Abend)? Kann man jetzt wohl leider nichtmehr nachvollziehen, was genau da schiefgelaufen ist...

 

Ciao,

DdD.

edit: falls Spelli99 das nochmal probieren möchte, unter demselben Link wie gestern sind jetzt noch zusätzl. uldr und u-boot vorhanden, die einfach mit auf den Stick. Falls das immernoch nicht klappt (aber das Flashen ansich zumindest vonstatten geht, also hektisches blinken des USB-Sticks), dann ist dort auch noch ne leere "var.arm.jffs2.nand" (soll dann zusätzl. auch mit auf den Stick), die löscht dann auch noch den Var-Bereich. Dann sollte die Box aber wirklich total jungfräulich sein, aber dann sind halt auch alle Einstellungen und Senderlisten weg...

bearbeitet von Don de Deckelwech

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi,

vorallem den Stick beobachten (blinken), ob von dem überhaupt gelesen wird, klappt ja leider nicht jeder Stick an der Coolie... Bootlog (bzw hier halt Flashlog) per Serielle wäre natürlich ideal!

 

Ciao,

DdD.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi, schön, alles weitere im fullmember Bereich, falls du Schwierigkeiten hast. :)

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Melde dich an, um diesem Inhalt zu folgen  

×
×
  • Neu erstellen...