Jump to content
Mr.Servo

[Gelöst] IR-Stream funzt überall, nur nicht im Image

Markham

Gelöst

Nachricht hinzugefügt von Markham

Empfohlene Beiträge

Hallo Zusammen,

ein Phänomen, mit dem im Image implementierten Internetradio. Seit ca. 4-5 Monaten geht folgender Radiostream nicht mehr:

https://klassikr.streamabc.net/klr-movie-mp3-192-19102

Die Streamadresse ist korrekt und hat vor 4-5 Monaten noch tadellos gefunzt. Es liegt übrigens nicht am Imageupdate auf v3.92, es hat wohl eher was mit dem Anbieter "Klassik Radio" zu tun, denn bei anderen IR-Stationen klappt alles perfekt. Aber warum kommt bei "Klassik Radio" kein Ton mehr (betrifft übrigens alle Spartenstreams des Hamburger Senders). Auf anderen Geräten wie externe Internetradiogeräte (z.B. getestet mit zwei Verschiedenen von DUAL) laufen die Spartenstreams von "Klassik Radio" einwandfrei und auch unter Windows ist alles paletti.

 

Hier mein .M3U Eintrag:

 

#EXTM3U
#EXTINF:0,Klassik Radio Movie 192kbps
https://klassikr.streamabc.net/klr-movie-mp3-192-1910214

 

Hier auch noch meine "radio-favorites.xml" (alles andere außer den Klassik Radio Spartenstreams läuft). Legende: grün=läuft, rot=läuft nicht

 

<?xml version="1.0" encoding="iso-8859-1"?>
<!--
    This file contains your own favorites of internet radio stations
    and will be loaded automatically when you start internet radio
-->
<list>
    <station
        url="http://173.244.215.162:8060"
        name="GotRadio Big Score"
        logo="http://live.mystreamplayer.com/configs/images/gotradio48w.png"
    />

    <station
        url="http://klassikr.streamabc.net/klr-movie-mp3-192-1910214/"
        name="Klassik Radio Movie 192kbps"
        logo="https://select.klassikradio.de/assets/images/logos/krselect-logo.svg"
    />

<station
        url="http://klassikr.streamabc.net/klassikradio-simulcast-mp3-hq/"
        name="Klassik Radio Live 192kbps"
        logo="https://select.klassikradio.de/assets/images/logos/krselect-logo.svg"
    />

    <station
        url="http://94.23.51.96:8001"
        name="Cinemix"
        logo="https://i.pinimg.com/564x/c0/93/65/c09365d551901260d836cb36e68b456a.jpg"
    />

    <station
        url="http://strm112.1.fm/moviesoundtracks_mobile_mp3"
        name="1.FM - Movie Soundtrack Hits"
        logo=""
    />

    </list>

 

Hat jemand eine Idee (inzwischen fehlende Portangabe oder sowas)?

Danke & Gruß, Mr.Servo

 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Danke für den Tip, aber leider bringt das Weglassen des "s" nix.. Aber ich schaue mir das trotzdem nochmal näher an, ich sehe gerade daß der Link keiner Mail nicht funzt. Es fehlen ein paar Zahlen am Ende. Hier der Richtige, der aber im Image dann nicht funzt: https://klassikr.streamabc.net/klr-movie-mp3-192-1910214

 

Gibt es denn eine LOG-Datei für das Internetradio? Dann könnte ich ja mal die Fehlermeldung suchen...

bearbeitet von Mr.Servo

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 9 Stunden schrieb Mr.Servo:

Gibt es denn eine LOG-Datei für das Internetradio?

Prinzipiell nicht, jedoch ist die Konsole nutzbar, entweder man stoppt Neutrino und starte Neutrino auf der Konsole neu und verfolgt die Ausgaben, oder man gibt einfach setconsole ein und schaut ob dann verwertbare Ausgaben kommen. 

 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi Markham,

wirst lachen, bin gerade genau dabei das zu tun. Habe inzwischen realisiert, daß Satbaby das Internetradio betreut. Aber ich kann im NI meinen Beitrag nicht abschicken, nur als Entwurf speichern (Fehlermeldung). Habe den Admin angeschrieben, aber nix Rückmeldung. Ergo: Geht leider (noch) nicht, hmmm...:unsure:

Gruß Mr.Servo

bearbeitet von Mr.Servo

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

NACHTRAG: Bei NI war ein neuer Spamfilter aktiviert, der wortlos mein Absenden eines neues Threads unterband. Spamfilter wurde von Admin (kurzfristig?) deaktiviert. Ist nun erledigt!

bearbeitet von Mr.Servo

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi Zusammen,

es gibt eine Lösung um das Problem mit dem Webradio zu umgehen: Man nutzt das WebTV. Wie gehts (getestet mit ImageV3.92_Jun & Mut@ant HD51)?

1. Die gewünschten Links der InternetRadio-Stationen in "/var/tuxbox/webtv/webtv_usr.xml" eintragen. Das kann dann beispielsweise so aussehen:

 

<?xml version="1.0"?>
<webtvs name="[eigene Streams] ">
    <webtv title="Klassik Radio Movie 192kbps" url="http://klassikr.streamabc.net/klr-movie-mp3-192-1910214" epgid="" genre="Movie" description="webtv" />
    <webtv title="Klassik Radio Live 192kbps" url="http://klassikr.streamabc.net/klassikradio-simulcast-mp3-hq" epgid="" genre="Movie" description="webtv" />
</webtvs>

 

2. Abspeichern & Box durchstarten

3. Die IR-Stationen können nun in den "Favoriten" ergänzt werden, genau wie man das mit regulären TV-Sendern macht (Menü->Bouquetverwaltung->hinzufügen->aus WebTV).

4. IR-Stationen aufrufen wie einen gewöhnlichen TV-Sender (vorläufig noch mit schwarzem Schirm)

Wenn jetzt noch das Display gepimpt wird (z.B. mit Shoutcast-Infos & Uhrzeit & Logo & Co.KG), dann könnte man auf das Webradio ganz verzichten.

Gruß, Mr.Servo

bearbeitet von Mr.Servo

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi Markham,

Ist für mich selbstverständlich, das Board hat mir so viel gegeben und wenn ich mal was tun kann...

Satbaby ja bereits eine Überarbeitung von WebTV und Webradio gemacht:

https://www.neutrino-images.de/board/viewtopic.php?f=39&t=3368#p19916

Ich schätze das wird dann erst im nächsten KW-Image mit einfließen? Oder kann ich diese NI-Funktion schon vorab integrieren?

Gruß, Mr.Servo

bearbeitet von Mr.Servo

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Was ich erst jetzt geschnallt habe: Es gibt im Image zwei "Internetradios"! Allerbeste Chancen, daß man das schön verwechselt!

 

1. Inetradio (Internetradio-Abspieler)

Der "Internetradio-Abspieler" (im Menü "blaue Taste" verfügbar) ist wohl eine ältere Version, die aber offentlichtlich aufgrund von Pufferspeicherproblemen qualitativ bessere IR-Sendungen (z.B. 192 kpbs) nicht mehr abspielen kann. Bei "normaler" Qualität (z.B. 128 kbps) klappt es wohl noch. Die eigenen IR-Stationen werden beim "Internetradio-Abspieler" hier eingetragen/verwaltet: /var/tuxbox/config/radio-favorites.xml

Das sieht beispielsweise dann so aus:

 

<?xml version="1.0" encoding="iso-8859-1"?>
<!--
    This file contains your own favorites of internet radio stations
    and will be loaded automatically when you start internet radio
-->
<list>
    <station
        url="http://94.23.51.96:8001"
        name="Cinemix"
        logo="http://d1i6vahw24eb07.cloudfront.net/s96408d.png"
    />
    <station
        url="http://173.244.215.162:8060"
        name="GotRadio Big Score"
        logo="https://cdn-radiotime-logos.tunein.com/s49670d.png"
    />
    </list>

 

 

2. Webradio

Das Webradio ähnelt aus Anwendersicht dem WebTV, es kommt auch problemlos mit qualitativ besseren IR-Sendungen (z.B. 192 kbps) klar. Im KW-Image V3.92 gibt es allerdings (noch) keine Ausgabe von Streaminfos (z.B. Interpret, Song, Uhrzeit, Senderlogo, etc.). Während man WebTV-Sender wie klassische TV-Sender in dem Bouquet "Meine Favoriten TV" hinzufügt, fügt man Webradio-Sender wie klassische Radiosender in dem Bouquet "Meine Favoriten Radio" hinzu. Die eigenen IR-Stationen werden beim "Webradio" (Radio-Taste) hier eingetragen/verwaltet: /var/tuxbox/webradio/webradio_usr.xml

Das sieht beispielsweise dann so aus:

 

<?xml version="1.0"?>
<webradios name="[WebRadio]">
    <webradio title="Klassik Radio Movie" urlkey="0" url="http://klassikr.streamabc.net/klr-movie-mp3-192-1910214" description="" genre=""/>
    <webradio title="Klassik Radio Live" urlkey="0" url="http://klassikr.streamabc.net/klassikradio-simulcast-mp3-hq" description="" genre=""/>
    <webradio title="Klassik Radio Games" urlkey="0" url="http://klassikr.streamabc.net/klr-games-mp3-192-7733162" description="" genre=""/>
</webradios>

 

 

Hier mal ein Eindruck, wie Webradio zukünftig aussehen könnte (Klick=groß):

f3c4e1-1572782586.png

 

Gruß Mr.Servo

bearbeitet von Mr.Servo

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Moin Zusammen,

ich habe nach langer Zeit mal wieder ins NI-Forum geschaut und Satbaby hat geschrieben, daß er Ende Januar den "chunked mode" zu netfile hinzugefügt hat, somit sollte der stream "https://klassikr.streamabc.net/klr-movie-mp3-192-19102" auch in internetradio funktionieren.

Er fragt nach einer Rückmeldung, die würde ich sehr gerne machen, aber was müßte ich bitte tun, im sein NI-Update im Internetradioauf auf KW testen zu können.

 

--> Gibt es vielleicht bald eine neue Release v4.0xb für die Mutant HD51?

 

Gruß & Danke......Mr.Servo

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

@Mr.Servo

 

Ein Image ist geplant. Ich warte nur auf neue Settings und Logos. Wenn die mal kommen, gitbs auch neue Images.

Ich kann dir aber vorab ein Testimage aus dem aktuellen Git für die HD51 bauen.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

@Markham Danke für Dein Angebot. Ich würde es gerne testen und berichten, aber nur wenn der Image-Zusammenbau nicht zu viel Zirkus für Dich darstellt...

Gruß......Mr.Servo

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

@Markham

Danke für das KW-Testimage, das Update hat reibungslos und flott geklappt! Das gute alte Internetradio läuft nun mit dem neuen GIT (satbaby sei Dank) auf Anhieb einwandfrei! Im Klartext: Auch Radiostreams mit höheren Bitraten (z.B. 192 kpbs) laufen nun einwandfrei. Klasse, daß im nächsten KW-Image dann alle daran teilhaben können.

 

Hier nochmal eine kleine Zusammenfassung bezüglich den zwei Möglichkeiten im KW-Image Internetradio zu empfangen:

 

1. Internetradio (empfohlen)

Aufrufen über: "Menü" -> "Multimedia" -> "Internetradio" oder alternativ "Blaue Taste" -> "1 Internetradio"

Eigene Senderliste: /var/tuxbox/config/radio-favorites.xml

 

2. WEB-Radio

Aufrufen über "Radio"-Taste

Eigene Senderliste: /var/tuxbox/webradio/webradio_usr.xml

 

Ich sehe das Problem nun als GELÖST.

 

Vielen Dank an Alle & Gruß.......Mr.Servo

bearbeitet von Mr.Servo
  • Like 1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Sehr gut, so stelle ich mir eine Zusammenarbeit zum Nutzen der Gemeinschaft vor.

 

Vielen Dank an alle Beteiligten.

 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Was jetzt noch schön wäre: Einen "Sticker" am Thread mit "GELÖST". Wer auch immer das dann festlegt. Hilft vielleicht den Usern, weil klare Lösungen sind sicherlich rarer als offene Probleme. Ansonsten sieht man nur Probleme - Probleme, aber man sieht nicht das sie auch gelöst wurden. Steigert dann sicher auch die Neugier, den Thread dann anzuschauen. Ist aber nur (m)eine Meinung...

Ansonsten finde ich die Arbeit, die hier geleistet wird außergewöhnlich. Leider kann ich mich nur begrenzt einbringen, aber man gewinnt ja über die Zeit an Erfahrung...

Gruß.....Mr.Servo

bearbeitet von Mr.Servo

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

@Markham Danke! Ich habe schon versucht den Threadtitel zu ändern, was ja normalerweise auch so klappt. Aber ich fürchte, als Normaluser kann ich nach einer gewissen Zeit nichts mehr daran ändern (Threaderstellung war immerhin schon am 25. Oktober 2019). Jedenfalls darf ich z.B. auch kein Inhalte (hier: "Internetradio" und "IR-Stream") mehr ändern oder ergänzen. Als SuperMod darfst Du das ja, wie man sieht.

Aber Danke, daß Du es für mich übernommen hast.

Gruß.....Mr.Servo

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

  • Wer ist Online   0 Benutzer

    Keine registrierten Benutzer online.

×
×
  • Neu erstellen...