Jump to content
Melde dich an, um diesem Inhalt zu folgen  
wahnfried

NEO2 iwi kaputt geflasht. Bootloader geht noch

Empfohlene Beiträge

moin.

 

hab aus einer NEO1 ein SystemFS auf eine NEO2 geflasht.

Nun geht es bis Boot Kernel.

Hat jemand nen link zu einer recovery anlietung mit seriel kabel?

im netzt sind für nevis unterschiedliche anleitungen mit unterschidlichen

speicher adreessen. so denn.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Moin Zusammen,

 

Hallo Zusammen

 

bei mir leider nicht erledigt. Wahrscheinlich habe ich mit meinem gefährlichen Halbwissen "Kuddelmuddel" gemacht. Kann mir einer helfen und die richtigen Adressen für das Image "Nevis Emergency Flash 3.60" nennen. Der automatische EMERGENCY-Flash nach dem Einschalten über USB-Stick kriegt es nicht korrekt hin, die "system.img" bricht er nach 5 Minuten ab und rebootet wie folgt:

 

Zitat

U-Boot 2009.03-svn1773 (Nov 02 2010 - 15:25:47)     Coolstream HDx  

 

Error: Bad gzipped data
Error: no valid bmp or bmp.gz image at f0060000
Hit any key to stop autoboot:  0
## Booting kernel from Legacy Image at f0080000 ...
   Image Name:   Coolstream Kernel (compressed)
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    2319352 Bytes =  2.2 MB
   Load Address: 00048000
   Entry Point:  00048000
   Verifying Checksum ... Bad Data CRC
ERROR: can't get kernel image!

 

Image bei 0xF0060000 gesucht, wobei "kernel.img" bei 0xF008000 abliegt. Kann es sein, daß hier so ziemlich alles im Eimer ist und ich noch eine alte UBOOT habe?

 

Wie wären denn die Befehle über Putty (via Nullmodemkabel) um die Sache wieder hinzubiegen? Hier 'ne asbachalte Anleitung von früher, aber die Adressen stimmen doch vorne und hinten nicht mehr, korrekt?

 

Zitat

{früher mtd2.img, heute kernel.img}
usb start
fatload usb 0 0 mtd2.img
erase 0xf0060000 0xf047ffff
cp 0 0xf0080000 0x100000
reset

 

{früher mtd3.img, heute system.img}
usb start
fatload usb 0 0x0e000000 mtd3.img
erase 0xf0480000 0xf1ffffff
cp 0x0e000000 0xf0480000 0x4aa335

 

 

Falls ich auch die aktuelle UBOOT einspielen muß, wie lautet die Befehlskette und kann mir die einer Zusenden (Downloads gehen ja zur Zeit nicht)...

 

Oder kann mir einer das komplette Keywelt-Image V3.60 zukommen lassen, damit ich es per USB-Stick einspielen (lassen) kann? Der Download geht ja im Moment nicht und ich hatte nur online geupdated, also kein Image auf meiner Festplatte (passiert mir nicht mehr...).

 

Danke für Eure Mithilfe......Mr.Servo

 

bearbeitet von Mr.Servo
Text "komplettes Image V3.60" ergänzt

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi,

also an der Partitionierung (also den Adressen die du ansprichst), sollte sich schon seit ewigen Zeiten nix geändert haben (wenn überhaupt jemals).

Du spielst vermutlich darauf an:

Zitat

Error: no valid bmp or bmp.gz image at f0060000

Zitat

Image bei 0xF0060000 gesucht, wobei "kernel.img" bei 0xF008000 abliegt.

Mit diesem "Image" ist das Bootbild gemeint, steht ja auch da "no valid bmp ... image at", das hat also nix mit Kernel- oder System-Image zu tun.

 

Ciao,

DdD.

 

PS: du solltest aber längere Logs zeigen, du behauptest zwar, dass das Kernel flashen noch klappt, aber das wage ich einfach mal in Frage zu stellen! Wird denn der USB-Stick überhaupt erkannt, die Coolies sind da ja sehr wählerisch.

 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 9 Minuten schrieb Don de Deckelwech:

PS: du solltest aber längere Logs zeigen, du behauptest zwar, dass das Kernel flashen noch klappt, aber das wage ich einfach mal in Frage zu stellen! Wird denn der USB-Stick überhaupt erkannt, die Coolies sind da ja sehr wählerisch.

Hallo DdD,

Mein älterer USB-Stick läuft einwandfrei an der Neo² (siehe Log).

Die "kernel.img" wird geflashed (siehe Log), nur die "system.img" nicht (siehe Log mit fettem Text). Beide Dateien (v3.60) hat mit Markham heute per PM geschickt, weil der Download nicht geht.

Zitat

▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒ͻ
▒ U-Boot 2009.03-svn1773 (Nov 02 2010 - 15:25:47)     Coolstream HDx           ▒
▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒͹
▒ Chipset information                                                          ▒
▒ Vendor: Conexant  Type: CX2450x (Nevis)  Revision: D0       Fuses: 7EFE6D24  ▒
▒ Option: 00010000  max. clock: 600 MHz    Core voltage: high                  ▒
▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒͹
▒ Clock information                                                            ▒
▒ MPG0: 594.000 MHz  MPG1: 594.000 MHz  HD  : 593.407 MHz  AUD : 491.520 MHz   ▒
▒ PLL0: 432.000 MHz  PLL1: 594.000 MHz  PLL2: 533.333 MHz                      ▒
▒ CPU : 594.000 MHz from PLL1                                                  ▒
▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒͹
▒ Memory configuration                                                         ▒
▒ Start    ▒ End      ▒ Type  ▒ Description                                    ▒
▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒ĺ
▒ 00000000 ▒ 0FFFFFFF ▒ RAM   ▒ System main memory bank #0                     ▒
▒ 10000000 ▒ 17FFFFFF ▒ RAM   ▒ System main memory bank #1                     ▒
▒ F0000000 ▒ F1FFFFFF ▒ FLASH ▒ Spansion S29GL256P (256 Mbit / 16M x 16)       ▒
▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒͹
▒ Serial number: 008-00012655 (08-00316F)                                      ▒
▒ *** Warning - bad CRC, using default environment ***                         ▒
▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒͹
*** Warning: FrontPanel: no ACK
*** Warning: FrontPanel: no ACK
*** Warning: FrontPanel: no ACK
*** Warning: FrontPanel: no ACK
▒ Network configuration                                                        ▒
▒ MAC: Conexant VMAC rev. 07       address: 00-C5-5C-00-31-6F                  ▒
▒ PHY: IC Plus IP101               address: 09                                 ▒
Error: Bad gzipped data
Error: no valid bmp or bmp.gz image at f0060000
▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒ͼ
Hit any key to stop autoboot:  1
Emergency update from usb
(Re)start USB...
USB:   ehci_hcd_init();
CX2450x init hccr e8000100 and hcor e8000140 hc_length 64
Register 10011 NbrPorts 1
USB EHCI 1.00
scanning bus for devices... 2 USB Device(s) found
       scanning bus for storage devices... 1 Storage Device(s) found
reading coolstream/kernel.img
...Device NOT ready
   Request Sense returned 00 00 00
Device NOT ready
   Request Sense returned 00 00 00

2319416 bytes read
coolstream/kernel.img size 236438
Unprotecting 0xF0080000 +0x400000
................................ done
Un-Protected 32 sectors
Erasing 0xF0080000 +0x400000
................................
Erased 32 sectors
Coping to 0xF0080000 size 0x236438
Copy to Flash... .................
done

Device NOT ready
   Request Sense returned 00 00 00
** Can't read from device 0 **

** Unable to use 0 0:1 for fatload **
** Unable to read coolstream/system.img **

 

 

Wenn ich die "kernel.img" lösche dann muß das Übersprungen werden und dann geht er direkt an die "system.img". Das hat dann geklappt (siehe nächste Log), aber booten geht immer noch nicht (siehe übernächste Log).

Zitat

Hit any key to stop autoboot:  1
Emergency update from usb
(Re)start USB...
USB:   ehci_hcd_init();
CX2450x init hccr e8000100 and hcor e8000140 hc_length 64
Register 10011 NbrPorts 1
USB EHCI 1.00
scanning bus for devices... 2 USB Device(s) found
       scanning bus for storage devices... 1 Storage Device(s) found
reading coolstream/kernel.img

** Unable to read "coolstream/kernel.img" from 0 0:1 **
** Unable to read coolstream/kernel.img **
reading coolstream/system.img
...............
Device NOT ready
   Request Sense returned 00 00 00

24379392 bytes read
coolstream/system.img size 1740000
Unprotecting 0xF0480000 +0x01B80000
............................................................................................................................................................................................................................ done
Un-Protected 220 sectors
Erasing 0xF0480000 +0x01B80000
............................................................
Erased 220 sectors
Coping to 0xF0480000 size 0x1740000
Copy to Flash... ..........................................................................................................................................................................................
done

 

Hier das normale Booten ohne Kernel:

Zitat

Hit any key to stop autoboot:  0
## Booting kernel from Legacy Image at f0080000 ...
   Image Name:   Coolstream Kernel (compressed)
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    2319352 Bytes =  2.2 MB
   Load Address: 00048000
   Entry Point:  00048000
   Verifying Checksum ... Bad Data CRC
ERROR: can't get kernel image!
HDx>

 

Gruß.....Mr.Servo

 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi,

augenscheinlich ja, aber: diese komischen "Device not ready" hab ich noch nie in einem Log gesehen:

Zitat

scanning bus for devices... 2 USB Device(s) found
       scanning bus for storage devices... 1 Storage Device(s) found
reading coolstream/kernel.img
...Device NOT ready
   Request Sense returned 00 00 00
Device NOT ready
   Request Sense returned 00 00 00

2319416 bytes read

Es wird zwar angezeigt, dass 2319416 Bytes gelesen wurden (analog beim System später auch entsprechend mehr), aber ehrlich gesagt, ich habe da echt Zweifel ob da alles richtig lief.

Vllt hat jemand noch eine Idee, ich an deiner Stelle würde trotzdem andere Sticks probieren, oder diesen mal neu in Fat32 formatieren.

 

Ciao,

DdD.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo DdD und Markham,

 

GELÖST:  Oh Mann, stundenlang mache ich hier rum, nerve euch beiden ab und und der Fehler liegt (wie von DdD angekündigt) beim USB-Stick.

 

Von sechs USB-Sticks die hier rumfliegen werden vier Stück erst gar nicht erkannt. Gut, dann ist es ja klar. Aber ein Aas wird erkannt, macht aber dann beim Laden der Imagedateien Zickenalarm. Ich habe ihn extra formatiert und nur die Imagedateien aufgespielt. Brachte grad gar nix. Das Einlesen der "kernel.img" dauerte ewig und drei Tage (also ca. 5 Minuten) bis es mehrere Fehlermeldungen gab (Device not ready). Dumm nur, daß danach trotz Fehlermeldung der Flashprozeß (Erasen und Kopieren) lustig weiterläuft und die Illusion eines gelungenen Flashens vermittelt wird. Ansonsten hätte ich den Braten viel früher gerochen und wäre mißtrauisch geworden. Vielleicht kann man das noch korrigieren?

 

Ein sechster USB-Stick wurde ebenfalls erkannt aber hier wurden auch die Imagedateien ordentlich und blitzschnell eingelesen (<30 Sekunden für die "kernel.img"). PENG und es läuft.

 

Danke für eure extrem prompte Rückmeldug und Danke für eure spitzenmäßigen Hilfe!!!!  Saustark! Respekt!

 

Gruß und schönen Abend noch........Mr.Servo

 

 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Gast
Du kommentierst als Gast. Wenn du bereits einen Account hast kannst du dich hier anmelden.
Auf dieses Thema antworten...

×   Du hast formatierten Text eingefügt.   Formatierung jetzt entfernen

  Only 75 emoji are allowed.

×   Dein Link wurde automatisch eingebettet.   Einbetten rückgängig machen und als Link darstellen

×   Dein vorheriger Inhalt wurde wiederhergestellt.   Clear editor

×   Du kannst Bilder nicht direkt einfügen. Lade Bilder hoch oder lade sie von einer URL.

Melde dich an, um diesem Inhalt zu folgen  

  • Wer ist Online   0 Benutzer

    Keine registrierten Benutzer online.

×