Jump to content

Empfohlene Beiträge

Heise-News 0.9

 

Das beliebte Plugin aus der Dbox2 steht nun auch online und offline für die Coolstream zur Verfügung.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Heise-News 1.0

 

Die neue Version gibt es als Onlineupdate für die Coolstream und natürlich für die dbox2.

  • Like 1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Mich hat genervt, daß viele Nachrichten mit extrem kleiner Schrift dargestellt wurden. Eigentlich wurden alle unterschiedlich groß angezeigt.

before1.png

Es zeigte sich, daß das an den sinnlosen teilweise sehr langen URLs am Ende der Seite lag, welche Tuxwetter zwangen, sehr kleine Schrift zu verwenden damit die in eine Zeile paßten.

before2.png

Ich habe deshalb mal frech im Plugin auf dem Server rumgeschmiert um diese Zeilen vor dem Anzeigen rauszuschmeißen. Das Ergebnis sieht schon mal ganz gut aus:

after.png

Sollte es Probleme dadurch geben, bitte melden. Installiert muß nichts werden, da das Script bei jedem Pluginstart direkt vom Server geladen wird.

 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Ich habe jetzt auch die mitten im Text stehende Aufforderung, den Newsletter zu abonnieren, rausgeschmissen, wenn ich schon mal am scripten war.

Früher dachte ich immer, daß dort schon Schluß sei und hatte gar nicht weiter nach unten gescrollt. :D

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo, ich habe mir das Plugin mal auf der H7C installiert, aber beim Start passiert nichts. Also habe ich mit dem vi in das .so hineingesehen. Dort ist von einem heise-Eintrag in /var/etc/update.urls die Rede, der bei mir aber nicht existiert. Ich habe da nur kw-update.com-Einträge.

 

Würdest du den entsprechenden Eintrag bitte mal posten?

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

@hvcls

 

Ich weiß jetzt nicht, wie das auf der ZGemma installiert ist, kann aber sein, daß der Suchstring, mit welchem die Scriptadresse aus der update.urls geholt wird, nicht angepaßt ist und noch auf "Coolstream" steht. In diesem Fall wird die Adresse nicht korrekt gebildet.

Du könntest den Eintrag für die Heise-News in /var/tuxbox/config/flexinc/plugin_run.mnu

 

 

ACTION=§Heise-News, wget -q -O- `grep Coolstream/[0..9] /var/etc/update.urls | sed s/Coolstream.*$//`heise/heise | sh

 

 

durch diesen ersetzen

 

ACTION=§Heise-News, wget -q -O- http://kw-update.com/update/heise/heise | sh

 

den Aufruf noch und mal probieren.

bearbeitet von SnowHead
Pfadangabe korrigiert

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Ich habe vom Script noch ein paar überflüssige Zeilen rausschmeißen lassen. Bitte Bescheid geben falls es Probleme gibt.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi, die plugin_rnu.mnu hab ich gar nicht. Plugin läuft auf meiner Tank nicht. 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 21 Stunden schrieb hvkls:

Hallo, ich habe mir das Plugin mal auf der H7C installiert, aber beim Start passiert nichts. Also habe ich mit dem vi in das .so hineingesehen. Dort ist von einem heise-Eintrag in /var/etc/update.urls die Rede, der bei mir aber nicht existiert. Ich habe da nur kw-update.com-Einträge.

 

Würdest du den entsprechenden Eintrag bitte mal posten?

Das Installationspaket muss noch auf das neue Image angepasst werden. Ist mir durchgegangen.

 

ACTION=§Heise-News,curl -s `grep neutrino/[0..9] /var/etc/update.urls | sed s/neutrino.*$//`heise/heise | sh

Curl deswegen, weil nun /var/etc/update.urls auf https umgestellt wurde und BB-Wget dumm ist.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 1 Stunde schrieb sammy909:

Hi, die plugin_rnu.mnu hab ich gar nicht. Plugin läuft auf meiner Tank nicht. 

 

@sammy909

 

Sorry, die Pfadangabe oben war nicht korrekt. Ist dort korrigiert.

 

 

@Markham

 

Danke für die Korrektur. Hab ja keine ZGemma.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Für das beta Image sollte die Version 1.07 nun online verfügbar sein.

 

Das Installationsskript ist angepasst zur Installation auf die blaue Taste oder ins Keywelt-Menü

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

@Markham

Kommt bei dem vorherigen Image

ACTION=§Heise-News,curl -s `grep neutrino/[0..9] /var/etc/update.urls | sed s/neutrino.*$//`heise/heise | sh

in 

/var/tuxbox/config/flexinc/my_plugin_run.mnu

?

Sorry für die Formatierung, es will bei C&P nicht, wie ich will.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Die neue Version ist noch nicht online. 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 2 Stunden schrieb hvkls:

@Markham

Kommt bei dem vorherigen Image

ACTION=§Heise-News,curl -s `grep neutrino/[0..9] /var/etc/update.urls | sed s/neutrino.*$//`heise/heise | sh

in 

/var/tuxbox/config/flexinc/my_plugin_run.mnu

?

Sorry für die Formatierung, es will bei C&P nicht, wie ich will.

Nein, kommt drauf an, welches du mal von mir bekommen hast. Schau in update.urls und tausche ggf "neutrino" gegen "Coolstream"

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 2 Stunden schrieb sammy909:

Die neue Version ist noch nicht online. 

Welche Box?

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi, ich bekomm es nicht zum laufen. In meiner my_plugin.run.mnu steht nichts drin.  

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Wenn du auf "blaue Taste" installieren ausführst, findest du

/var/tuxbox/plugins/heisenews.cfg
/var/tuxbox/plugins/heisenews.so

und wenn du ins Keywelt Menü installierst, findest du in plugin_run.mnu

ACTION=§Heise-News,curl -s `grep neutrino/[0..9] /var/etc/update.urls | sed s/neutrino.*$//`heise/heise | sh

Die my_plugins_run.mnu ist für die Einträge, die über die Settingsübernahme wieder im Image landen sollen.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

So sieht es bei mir aus. 

 

ke8voela.png

 

gt76rx9l.png

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Deinstalliere das mal und lösche die Reste von Hand, danach neuinstallieren.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

lvduai3a.png
 

 

Edit. Funktioniert jetzt. Danke

bearbeitet von sammy909

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

  • Wer ist Online   0 Benutzer

    Keine registrierten Benutzer online.

×
×
  • Neu erstellen...