Jump to content

sysinfo


GetAway
 Share

Recommended Posts

Ich habe mal mit der Portierung von Sysinfo angefangen.

Die Hauptseite steht schon mal, bin aber noch lange nicht fertig,

soll heißen das ihr euch noch ein wenig gedulden müsst. :mellow:

 

Hier schon mal ein Screenshot:

sysinfo_cs.png

 

Edit:

 

Version 1.00 ist fertig und kann über das Flexmenü (shellexec) oder das

Erweiterungsmenü (Blaue Taste) aufgerufen werden.

 

Folgendes gilt für das KW-Image:

Für alle die Sysinfo über das Erweiterungsmenü aufrufen wollen:

sysinfo (755)--> /var/plugins/

sysinfo.so (755) --> /lib/tuxbox/plugins/

sysinfo.cfg (644) --> /lib/tuxbox/plugins/

Über Taste Menü-> Service->Plugins neu laden ausführen. Fertig.

Sysinfo sollte sich nun über die Blaue Taste starten lassen.

 

Wer Sysinfo über das Flexmenü starten möchte,

fügt z.B. folgende Zeile...

ACTION=§Sysinfo,/var/plugins/sysinfo
...in...
/var/tuxbox/config/flexinc/plugin_run.mnu
...ein. sysinfo.so und sysinfo.cfg werden dann nicht gebraucht.

 

 

Folgendes gilt für das Original-Image:

Für alle die Sysinfo über das Erweiterungsmenü(Blaue Taste) aufrufen wollen:

Die sysinfo.so aus dem Archiv wird nicht gebraucht.

sysinfo umbenennen in sysinfo.so

sysinfo.so (755) --> /var/tuxbox/plugins/

sysinfo.cfg (644) --> /var/tuxbox/plugins/

Über Taste Menü-> Service->Plugins neu laden ausführen. Fertig.

Sysinfo sollte sich nun über die Blaue Taste starten lassen.

Wer sich fürs Original-Image das Flexmenü einbaut, weiß was er tun muss.

Link to comment
Share on other sites

  • Admin

Das Plugin ist jetzt online verfügbar und kann auch im DL-Bereich heruntergeladen werden.

Bitte beachten: wer das Plugin mit dem bisher vorn angehängten Installationsarchiv instal-

liert hat, kann es später nur manuell entfernen da es mit diesem Archiv fälschlicherweise

als Systemtool statt als Plugin installiert wird und daher über das System-Menü nicht mehr

deinstallierbar ist.

Noch mal vielen Dank an GetAway für die Portierung.

Link to comment
Share on other sites

Bitte beachten: wer das Plugin mit dem bisher vorn angehängten Installationsarchiv instal-

liert hat, kann es später nur manuell entfernen da es mit diesem Archiv fälschlicherweise

als Systemtool statt als Plugin installiert wird und daher über das System-Menü nicht mehr

deinstallierbar ist.

 

Doch, einfach in /var/tuxbox/config/kwupdate.conf das "S" an der ersten Stelle durch ein "P" ersetzen und speichern.

 

Sag mir mal auf die Schnelle was bei Dir unter Systemtools zu verstehen ist.:mellow:

Edited by GetAway
Link to comment
Share on other sites

  • 2 weeks later...

@SnowHead

 

Beim installieren des Plugins in KW-Menü wird ein falscher String angelegt.

ACTION=\&CS-SysInfo,/var/plugins/sysinfo

Der sollte eigentlich so aussehen.

ACTION=§CS-SysInfo,/var/plugins/sysinfo
:mellow: Edited by GetAway
Link to comment
Share on other sites

  • Admin

@GetAway

 

Also bei mir legt er das &-Zeichen ohne Backslash davor an. Im Script muß der Backslash aber

drin sein, damit das &-Zeichen über die Konsole nicht verlorengeht. Das §-Zeichen läßt sich

leider nicht über die Konsole übertragen, daher kann nur das &-Zeichen verwendet werden.

Link to comment
Share on other sites

@GetAway

 

Also bei mir legt er das &-Zeichen ohne Backslash davor an. Im Script muß der Backslash aber

drin sein, damit das &-Zeichen über die Konsole nicht verlorengeht. Das §-Zeichen läßt sich

leider nicht über die Konsole übertragen, daher kann nur das &-Zeichen verwendet werden.

 

Kann ich so nicht bestätigen. Habe mir mal das Installer-Paket von MTD-Tool

angeschaut. Dort wird es richtig gemacht. 

Edited by GetAway
Link to comment
Share on other sites

  • Admin

@GetAway

 

Hmm, heute ist es bei mir auch schiefgegangen. Ich habe das Archiv angepasst

und dann klappte es. Danke für den Hinweis.

Das gefixte Archiv ist jetzt online und im DL für die Offline-Installation verfügbar.

Link to comment
Share on other sites

  • 2 months later...
  • 2 weeks later...
  • 4 weeks later...
  • 3 months later...
  • Admin

Leider haben weder Worschter noch ich eine Methode gefunden, den Gateway bei DHCP

über Deviceabfragen herauszubekommen. Die in Neutrino selbst verfügbaren Daten sind

ja von einem Plugin von außen her nicht verfügbar.

Link to comment
Share on other sites

@SnowHead

 

Probier mal.

/ # route -n
Kernel IP routing table
Destination 	Gateway     	Genmask     	Flags Metric Ref	Use Iface
192.168.178.0   0.0.0.0     	255.255.255.0   U 	0  	0    	0 wlan0
0.0.0.0     	192.168.178.1   0.0.0.0     	UG	0  	0    	0 wlan0

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...