Jump to content
Melde dich an, um diesem Inhalt zu folgen  
lapps

Dbox2 nokia sat hängt beim flashen

Empfohlene Beiträge

Hallo zusammen

angefangen hats damit das die dbox 2 nokia sat manchmal von alleine neugebootet hat.

nervig aber ok ...

so letzt ging nichts mehr ... blieb beim booten stehen loading kernel ...

ok hab gedacht eventuell mal neu flashen, das geht leider auch nicht

so nun weiß ich nicht mehr weiter

im anhang boot logs

hallenberg:

¼debug: DDF: Calibrating delay loop... debug: DDF: 67.79 BogoMIPS
debug: BMon V1.0  mID 01
debug: feID dd    gtxID 0b
debug: fpID 5a     dsID http://Hallenberg.com  
debug: HWrev X5  SWrev 0.81
debug: B/Ex/Fl(MB) 32/00/08
WATCHDOG reset enabled
debug: autoboot aborted from terminal
dbox2:root>  boot net net net net net net net net net net
debug: 
BOOTP/TFTP bootstrap loader (v0.3)
debug: 
debug: Transmitting BOOTP request via broadcast
debug: Got BOOTP reply from Server IP 192.168.2.106, My IP 192.168.2.202
debug: Sending TFTP-request for file u-boot
will verify ELF image, start= 0x800000, size= 140064
verify sig: 262
boot net: boot file has no valid signature
Branching to 0x40000


U-Boot 1.3.4 (Tuxbox - Hallenberg.com) (Nov 29 2008 - 23:53:59)

CPU:   PPC823ZTnnA at 67.200 MHz: 2 kB I-Cache 1 kB D-Cache
        *** Warning: CPU Core has Silicon Bugs -- Check the Errata ***
Board: DBOX2, Nokia, BMon V1.0
      Watchdog enabled
I2C:   ready
DRAM:  32 MB
FLASH:  8 MB
FB:    ready
LCD:   ready
In:    serial
Out:   serial
Err:   serial
Net:   SCC ETHERNET
BOOTP broadcast 1
Using SCC ETHERNET device
TFTP from server 192.168.2.106; our IP address is 192.168.2.202
Filename 'u-boot'.
Load address: 0x100000
Loading: Using SCC ETHERNET device
TFTP from server 192.168.2.106; our IP address is 192.168.2.202
Filename 'logo-lcd'.
Load address: 0x100000
Loading: ##
done
Bytes transferred = 7680 (1e00 hex)
BOOTP broadcast 1
Using SCC ETHERNET device
TFTP from server 192.168.2.106; our IP address is 192.168.2.202
Filename 'u-boot'.
Load address: 0x100000
Loading: Using SCC ETHERNET device
TFTP from server 192.168.2.106; our IP address is 192.168.2.202
Filename 'logo-fb'.
Load address: 0x100000
Loading: ####################################
done
Bytes transferred = 179877 (2bea5 hex)

Options:
 1: Console on null
 2: Console on ttyS0
 3: Console on framebuffer
Select option (1-3), other keys to stop autoboot:  0 
Using SCC ETHERNET device
TFTP from server 192.168.2.106; our IP address is 192.168.2.202
Filename 'kernel-cdk'.
Load address: 0x100000
Loading: #################################################################
 ##########################################################
done
Bytes transferred = 627048 (99168 hex)
Using SCC ETHERNET device
TFTP from server 192.168.2.106; our IP address is 192.168.2.202
Filename 'u-initrd'.
Load address: 0x400000
Loading: #################################################################
 ##################################################
done
Bytes transferred = 586812 (8f43c hex)
............................................................... done
Un-Protected 63 sectors
## Booting image at 00100000 ...
  Image Name:   dbox2
  Image Type:   PowerPC Linux Kernel Image (gzip compressed)
  Data Size:    626984 Bytes = 612.3 kB
  Load Address: 00000000
  Entry Point:  00000000
  Verifying Checksum ... Bad Data CRC
=> 
-------------------------------------------------------------
BootP: Request von 00509C1B5E46 erhalten
Error DeleteIpNetEntry: Element nicht gefunden.

BootP: ARP-Eintrag mit IP: 192.168.2.202 und Mac: 00509C1B5E46 gesetzt
BootP: Antwort an 00509C1B5E46 gesendet
TFTP: Sende C:\Program Files\DBOX_IFA\tftp\u-boot
TFTP: Transfer erfolgreich beendet
BootP: Request von 00509C1B5E46 erhalten
BootP: ARP-Eintrag mit IP: 192.168.2.202 und Mac: 00509C1B5E46 gesetzt
BootP: Antwort an 00509C1B5E46 gesendet
TFTP: Sende C:\Program Files\DBOX_IFA\tftp\logo-lcd
TFTP: Transfer erfolgreich beendet
BootP: Request von 00509C1B5E46 erhalten
BootP: ARP-Eintrag mit IP: 192.168.2.202 und Mac: 00509C1B5E46 gesetzt
BootP: Antwort an 00509C1B5E46 gesendet
TFTP: Sende C:\Program Files\DBOX_IFA\tftp\logo-fb
TFTP: Transfer erfolgreich beendet
TFTP: Sende C:\Program Files\DBOX_IFA\tftp\kernel-cdk
TFTP: Transfer erfolgreich beendet
TFTP: Sende C:\Program Files\DBOX_IFA\tftp\u-initrd
TFTP: Transfer erfolgreich beendet

------ Zusatzinformationen ------
Gewählter Netzwerkadapter: ASUSTeK/Broadcom 440x 10/100-integrierter Controller (0)
IP-Adresse des Netzwerkadapters: 192.168.2.106
IP-Adresse die die dbox bekommt: 192.168.2.202
Betriebssystem: Professional  (Build 7600)
CPU 1: AMD Athlon(TM) XP 2200+ @ 1800 MHz
Dateiname des Images: Keywelt_V1_September_2x_SQUASHFS_2009.img
Imagetyp: Zwei Flashs
DBOX-IFA Version: 3.4
------ Powered by http://www.dboxservice-hallenberg.de ------

 

und einmal den Bootmanager

debug: DDF: Calibrating delay loop... debug: DDF: 67.79 BogoMIPS
debug: BMon V1.0  mID 01
debug: feID dd    gtxID 0b
debug: fpID 5a     dsID 01-93.70.2d.07.00.00-2f
debug: HWrev X5  SWrev 0.81
debug: B/Ex/Fl(MB) 32/00/08
WATCHDOG reset enabled
dbox2:root> debug: 
BOOTP/TFTP bootstrap loader (v0.3)
debug: 
debug: Transmitting BOOTP request via broadcast
debug: Given up BOOTP/TFTP boot
boot net failed

Flash-FS bootstrap loader (v1.5)

Found Flash-FS superblock version 3.1
Found file /root/platform/nokia-dbox2/kernel/os in Flash-FS
debug: Got Block #0036

will verify ELF image, start= 0x800000, size= 163276
verify sig: 262
Branching to 0x40000


U-Boot 1.2.0 (Tuxbox) (Feb 21 2009 - 19:30:38)

CPU:   PPC823ZTnnA at 67.200 MHz: 2 kB I-Cache 1 kB D-Cache
        *** Warning: CPU Core has Silicon Bugs -- Check the Errata ***
Board: DBOX2, Nokia, BMon V1.0
      Watchdog enabled
I2C:   ready
DRAM:  32 MB
FLASH:  8 MB
Scanning JFFS2 FS: .... done.
env: found "console" with value ttyS0
env: found "lcd_inverse" with value 0
env: found "lcd_contrast" with value 15
FB:    ready
LCD:   ready
In:    serial
Out:   serial
Err:   serial
Net:   SCC ETHERNET

Options:
 1: Console on null
 2: Console on ttyS0
 3: Console on framebuffer
Select option (1-3), other keys to stop autoboot:  0 
### FS (squashfs) loading 'vmlinuz' to 0x100000
### FS load complete: 670533 bytes loaded to 0x100000
............................................................... done
Un-Protected 63 sectors
## Booting image at 00100000 ...
  Image Name:   dbox2
  Image Type:   PowerPC Linux Kernel Image (gzip compressed)
  Data Size:    670469 Bytes = 654.8 kB
  Load Address: 00000000
  Entry Point:  00000000
  Verifying Checksum ... Bad Data CRC
=>

 

würde mich über hilfe freuen

 

grüße

lapps

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Beim Versuch mit dem Bootmanager funktionierte Dein Netzwerk nicht korrekt, wie unschwer hieran zu erkennen ist:

debug: Transmitting BOOTP request via broadcast

debug: Given up BOOTP/TFTP boot

boot net failed

Sieht fast so aus, als dass das Netzwerk zu träge reagiert und die Netzwerkabfrage nach BOOTP/TFTP verloren geht. Kannst Du vermeiden, indem Du die Box mit gedrückt gehaltener Pfeil-hoch-Taste resettest, sie bleibt dann am Boot-Prompt stehen. In der seriellen Konsole boot net eingeben, dann sollte das mit dem Flashversuch (Boot per Netzwerk) auch funktionieren.

 

Ebenfalls zuverlässig lässt sich das Problem vermeiden, wenn man zwischen Box und PC einen Switch hängt. Obacht: die Netzwerkschnittstelle des PC muss dann zwingend fest auf Half Duplex (10 oder 100) eingestellt werden, weil sonst die Übertragung vom PC aus mit ziemlicher Sicherheit hängen bleibt.

 

Das Starten mit dem im Flash enthaltenen Image funktioniert nicht, weil der Flash-Inhalt entweder korrupt ist

Verifying Checksum ... Bad Data CRC

oder die Box anderweit defekt ist (RAM, Flash-Chip oder auch möglicherweise die CPU kämen da in Frage).

 

Da der vom Hallenberg übertragene kernel-cdk auch nicht geladen werden kann und mit gleicher Fehlermeldung reagiert, tippe ich auf defekten RAM oder eventuell CPU.

 

Lasse ein serielles Log mit dem Bootmanager oder auch diesem Tool (klick) mitlaufen und führe einen Speichertest der Box durch: Box resetten, dabei an der Box die Pfeil-hoch-Taste gedrückt halten, damit wird der Selbsttest initialisiert. Das Ergebnis postest Du bitte hier.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Da du erwähnst das die Box sich ab und an resetet,

könnte an den Microtastern bzw. den Pullup oder Kondensatoren hinter der Frontblende liegen, der Fehler ist häufig und bekannt.

 

Wenn es Probleme beim Flashen gibt,

würde ich auch einen Netzwerkswitch nutzen

und die Netzwerkgeschwindigkeit beim PC auf halfduplex und 10 MBit manuell einstellen.

 

Sicherlich kann auch ein anderer Hardwaredefekt für die Bootprobleme verantwortlich sein, die Dbox2 kommt eben in die Jahre.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hast du schon einmal ein anderes image zum flashen probiert? Wegen "Verifying Checksum ... Bad Data CRC"!

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

serielboxlogger:

 

¼debug: DDF: Calibrating delay loop... debug: DDF: 67.79 BogoMIPS
debug: BMon V1.0  mID 01
debug: feID dd    gtxID 0b
debug: fpID 5a     dsID 01-93.70.2d.07.00.00-2f
debug: HWrev X5  SWrev 0.81
debug: B/Ex/Fl(MB) 32/00/08
WATCHDOG reset enabled
dbox2:root> debug: 
BOOTP/TFTP bootstrap loader (v0.3)
debug: 
debug: Transmitting BOOTP request via broadcast
debug: Given up BOOTP/TFTP boot
boot net failed

Flash-FS bootstrap loader (v1.5)

Found Flash-FS superblock version 3.1
Found file /root/platform/nokia-dbox2/kernel/os in Flash-FS
debug: Got Block #0032debug: Got Block #0004debug: Got Block #0008debug: Got Block #0012debug: Got Block #0016debug: Got Block #0020debug: Got Block #0024debug: Got Block #0028debug: Got Block #0032debug: Got Block #0036

will verify ELF image, start= 0x800000, size= 163276
verify sig: 262
Branching to 0x40000


U-Boot 1.2.0 (Tuxbox) (Feb 21 2009 - 19:30:38)

CPU:   PPC823ZTnnA at 67.200 MHz: 2 kB I-Cache 1 kB D-Cache
        *** Warning: CPU Core has Silicon Bugs -- Check the Errata ***
Board: DBOX2, Nokia, BMon V1.0
      Watchdog enabled
I2C:   ready
DRAM:  32 MB
FLASH:  8 MB
Scanning JFFS2 FS:   .  | / .  - \ .  | / .  - \  done.
env: found "console" with value ttyS0
env: found "lcd_inverse" with value 0
env: found "lcd_contrast" with value 15
FB:    ready
LCD:   ready
In:    serial
Out:   serial
Err:   serial
Net:   SCC ETHERNET

Options:
 1: Console on null
 2: Console on ttyS0
 3: Console on framebuffer
Select option (1-3), other keys to stop autoboot:  1  0 
### FS (squashfs) loading 'vmlinuz' to 0x100000
### FS load complete: 670533 bytes loaded to 0x100000
............................................................... done
Un-Protected 63 sectors
## Booting image at 00100000 ...
  Image Name:   dbox2
  Image Type:   PowerPC Linux Kernel Image (gzip compressed)
  Data Size:    670469 Bytes = 654.8 kB
  Load Address: 00000000
  Entry Point:  00000000
  Verifying Checksum ... Bad Data CRC

 

denke das die box defect is ...

lohnt es sich noch rep zu lassen ?

was wäre ein ersatz für die dbox ? ich möchte im netzwerk schaun können

das is alles

 

grüße und vielen dank

lappy

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

boot net failed

 

Du solltest die Hinweise von @Merkwürden beherzigen und dein Netzwerkproblem beseitigen damit der Flashvorgang durchlaufen kann.

 

Das Image oder Teile davon welche noch im Flash liegen ist defekt und daher kommt dann auch der CRC-Fehler aber das hat nichts mit dem eigentlichen Flashvorgang zu tun denn der ist zu diesem Zeitpunkt bereits abgebrochen worden.

 

Mach mal einen Flash-Erase (@Merkwürden hat dir bereits geschrieben wie das geht) bevor du nochmal versuchst ein Image zu flashen.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

ok sorry mein fehler ...

 

üdebug: DDF: Calibrating delay loop... debug: DDF: 67.79 BogoMIPS
debug: BMon V1.0  mID 01
debug: feID dd    gtxID 0b
debug: fpID 5a     dsID http://Hallenberg.com  
debug: HWrev X5  SWrev 0.81
debug: B/Ex/Fl(MB) 32/00/08
WATCHDOG reset enabled
debug: autoboot aborted from terminal
dbox2:root>  boot net net net net net net net net net net
debug: 
BOOTP/TFTP bootstrap loader (v0.3)
debug: 
debug: Transmitting BOOTP request via broadcast
debug: Got BOOTP reply from Server IP 192.168.2.106, My IP 192.168.2.202
debug: Sending TFTP-request for file u-boot
will verify ELF image, start= 0x800000, size= 140064
verify sig: 262
boot net: boot file has no valid signature
Branching to 0x40000


U-Boot 1.3.4 (Tuxbox - Hallenberg.com) (Nov 29 2008 - 23:53:59)

CPU:   PPC823ZTnnA at 67.200 MHz: 2 kB I-Cache 1 kB D-Cache
        *** Warning: CPU Core has Silicon Bugs -- Check the Errata ***
Board: DBOX2, Nokia, BMon V1.0
      Watchdog enabled
I2C:   ready
DRAM:  32 MB
FLASH:  8 MB
FB:    ready
LCD:   ready
In:    serial
Out:   serial
Err:   serial
Net:   SCC ETHERNET
BOOTP broadcast 1
Using SCC ETHERNET device
TFTP from server 192.168.2.106; our IP address is 192.168.2.202
Filename 'u-boot'.
Load address: 0x100000
Loading: Using SCC ETHERNET device
TFTP from server 192.168.2.106; our IP address is 192.168.2.202
Filename 'logo-lcd'.
Load address: 0x100000
Loading: ##
done
Bytes transferred = 7680 (1e00 hex)
BOOTP broadcast 1
Using SCC ETHERNET device
TFTP from server 192.168.2.106; our IP address is 192.168.2.202
Filename 'u-boot'.
Load address: 0x100000
Loading: Using SCC ETHERNET device
TFTP from server 192.168.2.106; our IP address is 192.168.2.202
Filename 'logo-fb'.
Load address: 0x100000
Loading: ####################################
done
Bytes transferred = 179877 (2bea5 hex)

Options:
 1: Console on null
 2: Console on ttyS0
 3: Console on framebuffer
Select option (1-3), other keys to stop autoboot:  0 
Using SCC ETHERNET device
TFTP from server 192.168.2.106; our IP address is 192.168.2.202
Filename 'kernel-cdk'.
Load address: 0x100000
Loading: #################################################################
 ##########################################################
done
Bytes transferred = 627048 (99168 hex)
Using SCC ETHERNET device
TFTP from server 192.168.2.106; our IP address is 192.168.2.202
Filename 'u-initrd'.
Load address: 0x400000
Loading: #################################################################
 ##################################################
done
Bytes transferred = 586812 (8f43c hex)
............................................................... done
Un-Protected 63 sectors
## Booting image at 00100000 ...
  Image Name:   dbox2
  Image Type:   PowerPC Linux Kernel Image (gzip compressed)
  Data Size:    626984 Bytes = 612.3 kB
  Load Address: 00000000
  Entry Point:  00000000
  Verifying Checksum ... OK
  Uncompressing Kernel Image ... OK
## Loading RAMDisk Image at 00400000 ...
  Image Name:   Ramdisk Image
  Image Type:   PowerPC Linux RAMDisk Image (gzip compressed)
  Data Size:    586748 Bytes = 573 kB
  Load Address: 00000000
  Entry Point:  00000000
  Verifying Checksum ... OK
  Loading Ramdisk to 01f1f000, end 01fae3fc ... OK
Linux version 2.4.36.9-dbox2 (Hallenberg.com)  (gcc version 3.4.6) #1 Sa 29. Nov 23:29:22 CET 2008
On node 0 totalpages: 8192
zone(0): 8192 pages.
zone(1): 0 pages.
zone(2): 0 pages.
Kernel command line: console=ttyS0 root=/dev/ram rw ip=192.168.2.202:192.168.2.106:::::off
Decrementer Frequency = 252000000/60
m8xx_wdt: active wdt found (SWTC: 0xFFFF, SWP: 0x1)
m8xx_wdt: keep-alive trigger installed (PITC: 0x12C0)
Console: colour dummy device 80x25
Calibrating delay loop... 66.96 BogoMIPS
Memory: 30348k available (1048k kernel code, 324k data, 72k init, 0k highmem)
Oops: Kernel Mode Software FPU Emulation, sig: 8
NIP: C0028C88 XER: C000097F LR: C0028C54 SP: C0121840 REGS: c0121790 TRAP: 1000    Not tainted
MSR: 00009032 EE: 1 PR: 0 FP: 0 ME: 1 IR/DR: 11
TASK = c011f910[0] 'swapper' Last syscall: 0 
last math 00000000 last altivec 00000000
GPR00: 00000000 C0121840 C011F910 C01227C4 C0121897 00000000 00002000 00000000 
GPR08: 00000000 00000001 00000002 00000000 C0140000 00031B58 01FFB400 00000001 
GPR16: FFFFFFFF 007FFF00 01FF5940 00000000 C0120000 C0120000 00000000 00000000 
GPR24: C0121890 00000000 C0140AD8 00000000 00000020 C0110000 C0121890 00002000 
Call backtrace: 
C0140AD8 C0133C64 C012F3B0 C0002138 
Kernel panic: Attempted to kill the idle task!
In idle task - not syncing
<0>Rebooting in 180 seconds..
-------------------------------------------------------------
BootP: Request von 00509C1B5E46 erhalten
BootP: ARP-Eintrag mit IP: 192.168.2.202 und Mac: 00509C1B5E46 gesetzt
BootP: Antwort an 00509C1B5E46 gesendet
TFTP: Sende C:\Program Files\DBOX_IFA\tftp\u-boot
TFTP: Transfer erfolgreich beendet
BootP: Request von 00509C1B5E46 erhalten
BootP: ARP-Eintrag mit IP: 192.168.2.202 und Mac: 00509C1B5E46 gesetzt
BootP: Antwort an 00509C1B5E46 gesendet
TFTP: Sende C:\Program Files\DBOX_IFA\tftp\logo-lcd
TFTP: Transfer erfolgreich beendet
BootP: Request von 00509C1B5E46 erhalten
BootP: ARP-Eintrag mit IP: 192.168.2.202 und Mac: 00509C1B5E46 gesetzt
BootP: Antwort an 00509C1B5E46 gesendet
TFTP: Sende C:\Program Files\DBOX_IFA\tftp\logo-fb
TFTP: Transfer erfolgreich beendet
TFTP: Sende C:\Program Files\DBOX_IFA\tftp\kernel-cdk
TFTP: Transfer erfolgreich beendet
TFTP: Sende C:\Program Files\DBOX_IFA\tftp\u-initrd
TFTP: Transfer erfolgreich beendet

------ Zusatzinformationen ------
Gewählter Netzwerkadapter: ASUSTeK/Broadcom 440x 10/100-integrierter Controller (0)
IP-Adresse des Netzwerkadapters: 192.168.2.106
IP-Adresse die die dbox bekommt: 192.168.2.202
Betriebssystem: Professional  (Build 7600)
CPU 1: AMD Athlon(TM) XP 2200+ @ 1800 MHz
Dateiname des Images: Keywelt_V1_Juli_2x_SQUASHFS_2009.img
Imagetyp: Zwei Flashs
DBOX-IFA Version: 3.4
------ Powered by http://www.dboxservice-hallenberg.de ------

 

so nun was neues *gg

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Den von mir geforderten Selbsttest der Box hast Du immer noch nicht durchgeführt.

Lasse ein serielles Log mit dem Bootmanager oder auch diesem Tool (klick) mitlaufen und führe einen Speichertest der Box durch: Box resetten, dabei an der Box die Pfeil-hoch-Taste gedrückt halten (ca. 2 bis 3 Sekunden), damit wird der Selbsttest initialisiert. Das Ergebnis postest Du bitte hier.

Tu das bitte.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

ähm doch eigentlich schon aber ich denke ich mache etwas falsch

also ich starte den seriboxlogger

drücke start und dann an der dbox aus/an und pfeil nach oben

dann resetet die box und das was ich jetzt unten poste kommt

das wars... was mache ich falsch ?

sorry wenn ich etas unbeholfen bin versuche stehts mein bestes zu geben

 

¼debug: DDF: Calibrating delay loop... debug: DDF: 67.79 BogoMIPS
debug: BMon V1.0  mID 01
debug: feID dd    gtxID 0b
debug: fpID 5a     dsID 01-93.70.2d.07.00.00-2f
debug: HWrev X5  SWrev 0.81
debug: B/Ex/Fl(MB) 32/00/08
WATCHDOG reset enabled
dbox2:root> debug: 
BOOTP/TFTP bootstrap loader (v0.3)
debug: 
debug: Transmitting BOOTP request via broadcast
debug: Given up BOOTP/TFTP boot
boot net failed

Flash-FS bootstrap loader (v1.5)

Found Flash-FS superblock version 3.1
Found file /root/platform/nokia-dbox2/kernel/os in Flash-FS
debug: Got Block #0032debug: Got Block #0004debug: Got Block #0008debug: Got Block #0012debug: Got Block #0016debug: Got Block #0020debug: Got Block #0024debug: Got Block #0028debug: Got Block #0032debug: Got Block #0036

will verify ELF image, start= 0x800000, size= 163276
verify sig: 262
Branching to 0x40000


U-Boot 1.2.0 (Tuxbox) (Feb 21 2009 - 19:30:38)

CPU:   PPC823ZTnnA at 67.200 MHz: 2 kB I-Cache 1 kB D-Cache
        *** Warning: CPU Core has Silicon Bugs -- Check the Errata ***
Board: DBOX2, Nokia, BMon V1.0
      Watchdog enabled
I2C:   ready
DRAM:  32 MB
FLASH:  8 MB
Scanning JFFS2 FS:   .  | / .  - \ .  | / .  - \  done.
env: found "console" with value ttyS0
env: found "lcd_inverse" with value 0
env: found "lcd_contrast" with value 15
FB:    ready
LCD:   ready
In:    serial
Out:   serial
Err:   serial
Net:   SCC ETHERNET

Options:
 1: Console on null
 2: Console on ttyS0
 3: Console on framebuffer
Select option (1-3), other keys to stop autoboot:  1  0 
### FS (squashfs) loading 'vmlinuz' to 0x100000
### FS load complete: 670533 bytes loaded to 0x100000
............................................................... done
Un-Protected 63 sectors
## Booting image at 00100000 ...
  Image Name:   dbox2
  Image Type:   PowerPC Linux Kernel Image (gzip compressed)
  Data Size:    670469 Bytes = 654.8 kB
  Load Address: 00000000
  Entry Point:  00000000
  Verifying Checksum ... Bad Data CRC

 

wann soll ich boot net eingeben ??

da habe ich im bootmanager bereits versucht dann bringt er

 

debug: DDF: Calibrating delay loop... debug: DDF: 67.79 BogoMIPS
debug: BMon V1.0  mID 01
debug: feID dd    gtxID 0b
debug: fpID 5a     dsID 01-93.70.2d.07.00.00-2f
debug: HWrev X5  SWrev 0.81
debug: B/Ex/Fl(MB) 32/00/08
WATCHDOG reset enabled
dbox2:root> debug: 
BOOTP/TFTP bootstrap loader (v0.3)
debug: 
debug: Transmitting BOOTP request via broadcast
debug: Given up BOOTP/TFTP boot
boot net failed

Flash-FS bootstrap loader (v1.5)

Found Flash-FS superblock version 3.1
Found file /root/platform/nokia-dbox2/kernel/os in Flash-FS
debug: Got Block #0036

will verify ELF image, start= 0x800000, size= 163276
verify sig: 262
Branching to 0x40000


U-Boot 1.2.0 (Tuxbox) (Feb 21 2009 - 19:30:38)

CPU:   PPC823ZTnnA at 67.200 MHz: 2 kB I-Cache 1 kB D-Cache
        *** Warning: CPU Core has Silicon Bugs -- Check the Errata ***
Board: DBOX2, Nokia, BMon V1.0
      Watchdog enabled
I2C:   ready
DRAM:  32 MB
FLASH:  8 MB
Scanning JFFS2 FS: .... done.
env: found "console" with value ttyS0
env: found "lcd_inverse" with value 0
env: found "lcd_contrast" with value 15
FB:    ready
LCD:   ready
In:    serial
Out:   serial
Err:   serial
Net:   SCC ETHERNET

Options:
 1: Console on null
 2: Console on ttyS0
 3: Console on framebuffer
Select option (1-3), other keys to stop autoboot:  0 
### FS (squashfs) loading 'vmlinuz' to 0x100000
### FS load complete: 670533 bytes loaded to 0x100000
............................................................... done
Un-Protected 63 sectors
## Booting image at 00100000 ...
  Image Name:   dbox2
  Image Type:   PowerPC Linux Kernel Image (gzip compressed)
  Data Size:    670469 Bytes = 654.8 kB
  Load Address: 00000000
  Entry Point:  00000000
  Verifying Checksum ... Bad Data CRC
=> boot net
Usage:
boot    - boot default, i.e., run 'bootcmd'

=>

 

so hoffe etwas mehr informationen gebracht zu haben

herzlichen dank nochmal

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Mein Gott... :beerhat:

 

Du sollst beim Reset die Pfeil-hoch-Taste drücken und dann noch (für 2 bis 3 Sekunden) gedrückt halten. Hab ich doch im letzten Beitrag bereits so geschrieben. Ist das denn so schwer? ;)

Ob das funktioniert, siehst Du am Display, wenn die Box vor dem fünften Balken einige Zeit stehen bleibt, dann ist es richtig. Startet die Box dagegen gleich mit 5 Balken durch, hast Du die Taste zu früh losgelassen. Die Box bleibt übrigens dann nach dem Selbsttest stehen.

 

So sieht das Log des Selbsttestes meiner Nokia im seriboxlogger aus:

debug: DDF: Calibrating delay loop... debug: DDF: 67.79 BogoMIPS
debug: BMon V1.0  mID 01
debug: feID dd    gtxID 0b
debug: fpID 5a     dsID xxxxxxxxxxxxxxxxxxxxxxxxx
debug: HWrev X5  SWrev 0.81
debug: B/Ex/Fl(MB) 32/00/08
WATCHDOG reset enabled
debug: &_text 0x10000, &_etext 0x26160, &_data 0x26160, &_edata 0x29c50
debug: &_end 0x347dc,  &__stack 0x400000
debug: Memory tests (0x400000 -- 0x2000000)
debug: NumberTest: debug: passed
debug: MarchTest: debug: passed
debug: PermTest:  debug: passed

An der Stelle steht sie dann, das ist korrekt für den Selbsttest.

 

Der Bootmanager bringt dann lediglich noch den Eingabe-Prompt, der Rest ist identisch.

debug: DDF: Calibrating delay loop... debug: DDF: 67.79 BogoMIPS
debug: BMon V1.0  mID 01
debug: feID dd    gtxID 0b
debug: fpID 5a     dsID xxxxxxxxxxxxxxxxxxxxxxxxx
debug: HWrev X5  SWrev 0.81
debug: B/Ex/Fl(MB) 32/00/08
WATCHDOG reset enabled
debug: &_text 0x10000, &_etext 0x26160, &_data 0x26160, &_edata 0x29c50
debug: &_end 0x347dc,  &__stack 0x400000
debug: Memory tests (0x400000 -- 0x2000000)
debug: NumberTest: debug: passed
debug: MarchTest: debug: passed
debug: PermTest:  debug: passed
dbox2:root>

Box bleibt dort ebenfalls stehen.

 

Lässt Du die Pfeil-hoch-Taste sofort wieder los, startet nicht der Selbsttest, sondern die Box versucht ohne Selbsttest normal zu booten. Was aber keinen Sinn hat, weil wir so nicht herausfinden, ob der Speicher eventuell kaputt ist.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

sorry sehr peinlich leider bin ich net ganz so bewandert aber ich habs soweit geschaft:

 

seri:

üdebug: DDF: Calibrating delay loop... debug: DDF: 67.79 BogoMIPS
debug: BMon V1.0  mID 01
debug: feID dd    gtxID 0b
debug: fpID 5a     dsID 01-93.70.2d.07.00.00-2f
debug: HWrev X5  SWrev 0.81
debug: B/Ex/Fl(MB) 32/00/08
WATCHDOG reset enabled
debug: &_text 0x10000, &_etext 0x26160, &_data 0x26160, &_edata 0x29c50
debug: &_end 0x347dc,  &__stack 0x400000
debug: Memory tests (0x400000 -- 0x2000000)
debug: NumberTest: debug: passed
debug: MarchTest: debug: passed
debug: PermTest:  debug: passed

 

Bootmanager:

debug: DDF: Calibrating delay loop... debug: DDF: 67.79 BogoMIPS
debug: BMon V1.0  mID 01
debug: feID dd    gtxID 0b
debug: fpID 5a     dsID 01-93.70.2d.07.00.00-2f
debug: HWrev X5  SWrev 0.81
debug: B/Ex/Fl(MB) 32/00/08
WATCHDOG reset enabled
debug: &_text 0x10000, &_etext 0x26160, &_data 0x26160, &_edata 0x29c50
debug: &_end 0x347dc,  &__stack 0x400000
debug: Memory tests (0x400000 -- 0x2000000)
debug: NumberTest: debug: passed
debug: MarchTest: debug: passed
debug: PermTest:  debug: passed
dbox2:root>

 

sorry nochmal

gruß

lapp

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Dem RAM scheint es laut dem Selbsttest gut zu gehen, Fehlermeldung gab es keine. Da wird dann wohl die CPU Deiner Box einen weg haben, worauf auch die Fehlermeldung Deines letzten Flashversuchs hindeutet:

Oops: Kernel Mode Software FPU Emulation, sig: 8

NIP: C0028C88 XER: C000097F LR: C0028C54 SP: C0121840 REGS: c0121790 TRAP: 1000 Not tainted

MSR: 00009032 EE: 1 PR: 0 FP: 0 ME: 1 IR/DR: 11

TASK = c011f910[0] 'swapper' Last syscall: 0

last math 00000000 last altivec 00000000

GPR00: 00000000 C0121840 C011F910 C01227C4 C0121897 00000000 00002000 00000000

GPR08: 00000000 00000001 00000002 00000000 C0140000 00031B58 01FFB400 00000001

GPR16: FFFFFFFF 007FFF00 01FF5940 00000000 C0120000 C0120000 00000000 00000000

GPR24: C0121890 00000000 C0140AD8 00000000 00000020 C0110000 C0121890 00002000

Call backtrace:

C0140AD8 C0133C64 C012F3B0 C0002138

Kernel panic: Attempted to kill the idle task!

In idle task - not syncing

Rebooting in 180 seconds..

Dieser Fehler (und andere) entstehen bei defekter CPU oder RAM. Hier lässt sich per Ferndiagnose jetzt allerdings nix mehr genau sagen. Wenn Du Gewissheit haben willst, kannst Du die Box in eine Fachwerkstatt zwecks Prüfung geben, z.B. zu Ralf-Jürgen Bader. Er wird Dir genau sagen können, was da defekt ist, und ob eine Reparatur lohnt.

Wenn es die CPU sein sollte, kannst Du die Box beerdigen, das kommt an die 100 Euro, dafür kriegst Du locker eine andere dBox2.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Zu den Ausführungen von @Merkwürden möchte ich noch folgendes ergänzen.

 

Der FPU-Kernelfehler tritt auch auf wenn illegale Operationen erfolgen, z.B.: ein Sprungbefehl ins Nirvana ausgeführt wird oder floating point Operationen daneben gehen, da dein Image nach wie vor nicht richtig im Flash steht ist ein derartiges Verhalten durchaus im Bereich des möglichen und aus meiner Sicht auch der Grund für den Kernel-Fehler.

 

Du solltest nochmal flashen aber davor den Flash mal völlig löschen, starte dazu die Box neu und halte die "Pfeil nach unten Taste" so lange gedrückt bis im Display "Flash Erase" steht, jetzt das Image laden aber sorge dafür dass dein "Boot net Problem" vorher beseitigt ist oder fange die Box im Bootloader-Prompt ab und gib den Befehl "boot net" dann ein.

 

Wenn des Laden des Image abgeschlossen ist dann schalte die Box nicht sofort aus sondern warte 1-2 Minuten um dem Flash-Baustein Zeit zu geben alle Zellen in den richtigen Zustand zu bringen, wenn Flashbausteine in die Jahre kommen dann kann es vorkommen dass einzelne Zellen etwas länger brauchen und wenn zu schnell neu gestartet wird dann gibts eventuell Bit-Fehler, nach dem Ausschalten würde ich ebenfalls wieder 1-2 Minuten warten und dann erst neu starten.

 

Das ist jetzt keine Garantie auf Erfolg aber eine Möglichkeit dass die Box doch wieder läuft, hilft das auch nicht dann kannst du nur noch einen Kostenvoranschlag einholen.

  • Like 1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

;):beerhat::)

ja dachte ich mir schon ... schad drum werd ich wohl in ebay setzen

 

kannst du mir einen ersatz empfehlen der ähnlich kann wie die dbox ?

im unteren preissegment?

 

vielen herzlich dank für die klasse hilfe !!!!

 

gruß

lapp

 

edit

@gandal hab ich gar net gelesen gehabt ...

vielen dank werde das gleich mal testen

bearbeitet von lapps

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Melde dich an, um diesem Inhalt zu folgen  

  • Wer ist Online   0 Benutzer

    Keine registrierten Benutzer online.

×
×
  • Neu erstellen...