Jump to content

Empfohlene Beiträge

Bei dieser Portierung des DBox-Plugins gibt es keine Einschränkungen gegenüber der

DBox-Version. Aufgrund des höheren Farbraums ist hier sogar eine Farbgestaltung der

Masken möglich, welche keine Wünsche mehr offenlassen dürfte. Voraussetzung für

die aspektabhängige Maskenauswahl ist allerdings, daß diese Erweiterung der pzapit

im Image enthalten ist. Anderenfalls wird bei allen Aspekten mit der gleichen Masken-

position gearbeitet. Im KW-Image ist diese Erweiterung selbstverständlich implemen-

tiert und funktioniert auch schon ganz gut.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Ich habe noch mal eine abgeänderte Version angehängt. Die Verwendung absoluter

Koordinaten macht den Austausch und die Übernahme der Config einfacher.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

In der neuen Version von logoset kann man zusätzlich mit den

Lautstärketasten die Transparenz der Masken verändern.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi,

 

Ich weiß nicht warum, aber logoset funktioniert bei mir nicht.

Nach 3 Sekunden schließt sich die Maske, manchmal schaffe

ich es mit den Pfeiltasten das Ding zu bewegen.

pzapit -var = 3

 

Fix resourcen leak:

--- logoset.c.orig	2010-03-20 23:17:03.000000000 +0100
+++ logoset.c	2010-03-21 18:30:22.000000000 +0100
@@ -106,6 +106,7 @@ int main (int argc, char **argv)
					}
				}
			}
+			fclose(fh);
		}

		system("touch /tmp/.logomask_kill");

bearbeitet von GetAway

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

@GetAway

 

Danke für den Fix. Habe es oben geändert.

Eventuell läßt Du Dich durch das Benehmen von logoset irritieren. 3 Sekunden,

nachdem eine Maske nicht mehr bewegt wird, wird sie statt transparent in

ihrer ursprünglichen Farbe dargestellt. Sobald sie aber wieder bewegt wird, wird

sie wieder transparent. Oder es entsteht ein segfault wenn 3 Sekunden nach dem

Start der Hilfetext eingeblendet werden soll. Ich bin standardmäßig von HD-Auflö-

sung des Framebuffers ausgegangen. Wenn dort nur die Hälfte zur Verfügung steht

weil eine fossile Röhre angeschlossen ist, kann ich mir gut vorstellen, daß es dann

knallt. Ich teste lediglich mit Standardauflösung.

Bei einer kleinen Auflösung würden übrigens alle Scripte, welche die msgbox mit ab-

soluten Tabulatoren verwenden, Probleme bekommen.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

@SnowHead

 

Hi, mir ist gerade aufgefallen, dass es bei logoset noch keine Unterscheidung LCD/CRT gibt.

Der Hilfetext ist bei mir unten abgeschnitten, außerdem ist die grüne Schrift kaum lesbar.

Besser wäre es die Schrift wieder auf gelb umzustellen.

bearbeitet von GetAway

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Probiere bitte mal die logoset.so.tar.gz auf dem Server. Ich habe keine Röhre mehr.

 

Die Schrift wird nicht mehr abgeschnitten, ist aber aufgrund der Farbe schlecht lesbar.:mellow:

logoset.png

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Die Schrift wird jetzt oben abgeschnitten. Viel besser lesbar ist sie auch nicht.

Könntest du eine leuchtendere nehmen, also ein helles gelb.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

@GetAway

 

OK, nächster Versuch mit hellgrün. Die Sichtbarkeit der Schrift hängt aber immer

vom darunterliegenden Fernsehbild ab. Hellgelb ging bei hellem Untergrund gar nicht.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Nachdem ich das Coolstream-Bild auf meinem neuen Fernseher unskaliert anzeigen lasse,

fiel mir auf, daß man die Masken nicht ganz bis an die untere und rechte Bildschirmkante

bewegen bzw. ausdehnen konnte. Außerdem war nun das Parken im 16:9-Modus nicht be-

nötigter Masken außerhalb des Sichtbereiches nicht mehr möglich.

In der Version 1.1 können deshalb nun einzelne Masken bei den verschiedenen Bildformaten

mit der Fav-Taste inaktiv gesetzt werden. In diesem Fall werden sie bei der Einstellung in

roter Farbe dargestellt und können nicht in Größe und Position geändert werden. Im Normal-

betrieb werden diese Masken ausgeblendet. Diese Festlegung gilt nur für das jeweile Bild-

format. Im 16:9-Format ausgeblendete Masken können z.B. im 4:3-Format weiterhin dar-

gestellt werden. Die Masken können nun auch bis ganz an die Bildschirmgrenzen manövriert

werden. Da diese Logomask-Version nur im KW-Image richtig funktioniert, ist das Update aus-

schließlich online über das KW-Menü möglich.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo Snowhead,

ich nutze seit längerem das NG Return Image,auch dort ist Dein PlugIn implementiert,das ist Klasse.

Leider wird die Box seit dem neuesten Update "NG 2.2" unbedienbar (z.b. N24HD ,Maske für Laufschrift und Logo in Grün) sobald die definierten Masken dann gestartet werden. (Im NG 2.0 funktionierte noch alles super)

Kannst Du mir trotz Fremdimage einen Tip geben ,wo ich zur Fehlersuche (vielleicht muss ja nur in der Config was angepasst werden oder ich versuche eine frühere Version) ansetzen könnte ?

 

Leider bleiben meine Threads im NG Return Board und coolstream.to diesbezüglich unbeantwortet ,deshalb versuche ich es direkt hier bei Dir.

 

Nachtrag bzw.Update: Inzwischen gibt es Hilfe im NG-Board,der temporäre Fehler kann reproduziert werden...

 

http://www.ng-return.com/wbb2/thread.php?postid=284255#post284255

 

Ich übe mich also in Geduld ,nutze die Gelegenheit für ein Danke an dieser Stelle und freue mich auf eine weitere schöne Zeit mit Logomask (demnächst :D)

 

mfg renaldo

bearbeitet von renaldo

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

@renaldo

 

In der KW-Beta läuft logomask problemlos ohne das sich was aufhängt. Ich muß allerdings

gestehen, daß das eine KW-eigene Version von logomask ist, welches die Fähigkeit der

KW-pzapit den eingestellten Zoom-Modus mitzuteilen für die Skalierung der Masken aus-

nutzt. Das ist allerdings der einzige Unterschied zu der im CVS veröffentlichten.

Ich weiß allerdings nicht genau, was passieren würde, wenn die KW-Version von logomask

in das NG-Image geraten wäre. Da könnte es aufgrund fehlender Informationen wohl schon

zu Problemen kommen.

Probier mal das Plugin aus der 2.0-Image-Version. Vielleicht ist ja im Git was schiefgelaufen.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Sorry für die Aufregung, ich wars.

Damit das viele forken beim Start der Plugins aufhört, habe ich im NG die shellstarter entfernt und direkt *.so gestartet.

So blieb logomask natürlich aktiv und kam nicht in den Background.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Vielen Dank Ihr Zwei ,

ich warte geduldig auf ein kleines NG-Update bei Gelegenheit und bin echt froh,das dieses PlugIn weiterhin funktionieren wird...

Herzliche Grüsse renaldo

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi,

ich habe Folgendes beobachtet: es kommt ab und an vor, dass man, bevor die eigentliche Logomask eingeblendet wird, ganz ganz kurz genau in der Mitte des Bildschirms das kleine Einstellungsrechteck (also die Grundform, die man erst vergrössern und verschieben muss) eingeblendet wird. Das geschieht sehr schnell, und ist leider schwer zu reproduzieren.

 

Man kann das am besten beobachten, wenn die Box unter Last (bzw Speichermangel leidet), dann läuft das quasi in Zeitlupe ab. Falls du (SnowHead) oder jemand anderes da vllt ein Video oder sowas von braucht, kann ich mal versuchen das gezielt nachzustellen und aufzuzeichnen. Aber vllt wird da nur unnötig eine Programmroutine aufgerufen oder so, die man eigentlich garnicht sehen können dürfte.

 

Noch etwas anderes: da ja inzw auch andere Sachen direkt ins NeutrinoHD eingeflossen sind (zB ein Werbezapper), könnte man Logomask nicht auch da reinbringen oder zumindest eine Art Schnittstelle (Socket o.ä.), wodurch der Logomask-daemon zumindest für die Zeit anderweitiger Menüeinblendungen von Neutrino innehält? Sieht iwie blöd aus, wenn die Menüs von den Logomasks wieder verdeckt werden...

 

Ansonsten kann ich nicht meckern, ist ne super Sache... :D

 

Ciao,

DdD.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

@DdD

 

Das von Dir beobachtete Verhalten kommt daher, daß beim Senderwechsel ein Zustand

eintreten kann, bei dem der alte Sender nicht mehr und der neue noch nicht gemeldet

wird. In diesem Fall weiß das Programm nicht, für welchen Kanal es die Masken zeichnen

soll und nimmt so lange erst mal den Defaultwert.

Natürlich wäre es besser, wenn logomask direkt als daemon im Neutrino integriert wäre.

Dann hätte es immer Zugriff auf den aktuellen Kanal und Tuning-Zustand und könnte mit

der Neutrino-Menüdarstellung besser zusammenarbeiten. Vielleicht baut das ja mal einer.

Im CVS sind die Quellen ja schon.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi,

ok, danke, ist einleuchtend, und deshalb halt auch nicht zu fixen.

 

Vielleicht baut das ja mal einer. Im CVS sind die Quellen ja schon.

Ja, das wäre schön. OSS rules! ;) Andererseits scheinen ja nicht sooo viele Leute LM zu benutzen. Obwohl auf N24 und n-tv inzw ganz gute Dokus kommen, und da lohnt sich das Plugin dann echt!

 

Ciao,

DdD.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi,

wirklich schon fast 5 Jahre? Hammer.

 

Naja, es gab ja letztes Jahr einige Änderungen bei Logomask (nicht nur) für die Coolie, das Feature mit /tmp/.logomask_pause ist eigentlich perfekt, nur:

seit dem läuft die Coolie nur maximal zweieinhalb bis drei Tage durch, dann kackt sie ab (TV-Bild läuft noch weiter, eine Bedienung ist aber nicht mehr möglich, Stecker ziehen oder per Telnet "reboot" absetzen hlft nur). Sowas hier kommt dan als letzes im Bootlog:

Zitat

 

key: 006c value 0, translate: 006c -cursor down-
key: 0166 value 1, translate: 0166 -info-
[/tmp/zapit.sock] Command ignored: cmd 0 version 0 received - server cmd version is 7
[/tmp/zapit.sock] Command ignored: cmd 0 version 0 received - server cmd version is 7
[/tmp/zapit.sock] Command ignored: cmd 0 version 0 received - server cmd version is 7
[/tmp/zapit.sock] Command ignored: cmd 0 version 0 received - server cmd version is 7
[/tmp/zapit.sock] Command ignored: cmd 0 version 0 received - server cmd version is 7
[/tmp/zapit.sock] Command ignored: cmd 0 version 0 received - server cmd version is 7

Eben hatte ich dann dazwischen noch ne Meldung von (ich glaube, hab es leider zu schnell weggedrückt, sorry):

[/tmp/sectionsd.sock] Command ignored: cmd 0 version 0 received - server cmd version is 5

Jeweils dann immer im Wechsel, und zwar beides mehrmals (also mind 2-3 mal) pro Sekunde!

 

Hat sonst niemand der 3 oder 4 anderen Logomasknutzer ähnliche Probleme? Ich vermute, dass durch die oben schon angesprochenen Änderungen im Plugin, einfach zu viele Abfragen auf zapit/sectionsd einprasseln und die irgendwann die Grätsche machen. Denn wenn ich den Code richtig interpretiere, wird ja 1 oder sogar 2 mal pro Sekunde der Status abgefragt.

 

Da ich das mit dem sectionsd.sock eben das erste mal gesehen hatte: wird die Abfrage vom sectionsd-Status überhaupt noch gebraucht, welchen Sinn hat das, abzufragen ob der läuft? Ich mein das hier:

Zitat

system("wget -Y off -q -O /tmp/logomask.stat http://localhost/control/zapto?statussectionsd");

 

Wie kann ich helfen das zu debuggen? Mir ist klar, das wird nicht einfach, zumal ich ja jeweils auch fast 3 Tage warten muss.

Wenn ihr weitere Infos braucht, ich geb mir Mühe.

 

Ciao,

DdD.

 

PS: mein Traum wäre ja, das logomask entweder

a) auch so eine IPC aufbaut (wie zapit und sectionsd zu Neutrino eh schon) oder

b) logomask ein integraler Bestandteil von Neutrino wird (so ähnlich wie zB der Werbezapper), wobei das Schöne ja wäre, dass mit logoset der "kompliziertere Teil" ja eh als "Plugin" verbleiben kann, für logomask müsste "nur" (klar,ist leicht gesagt, ich kanns leider nicht) das Einlesen der .conf und die grosse Schleife implementiert werden... Wie gesagt: Traum. :)

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

@DdD

 

Zu den Änderungen im CVS kann ich nichts sagen, stecke da nicht mehr so drin. Am besten mal dort melden.

 

Den "Traum", das Plugin als Demon gleich im Neutrino mit laufen zu lassen besteht schon länger. Das würde allerdings ein komplettes Neuschreiben des Plugins bedeuten, da hier völlig andere Zugriffs- und Ausgabemechanismen verwendet werden müssen. Bisher hat sich leider noch keiner gefunden, der bereit ist, den zu betreiben.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Gast
Auf dieses Thema antworten...

×   Du hast formatierten Text eingefügt.   Formatierung jetzt entfernen

  Only 75 emoji are allowed.

×   Dein Link wurde automatisch eingebettet.   Einbetten rückgängig machen und als Link darstellen

×   Dein vorheriger Inhalt wurde wiederhergestellt.   Clear editor

×   Du kannst Bilder nicht direkt einfügen. Lade Bilder hoch oder lade sie von einer URL.


  • Wer ist Online   0 Benutzer

    Keine registrierten Benutzer online.

×
×
  • Neu erstellen...