Jump to content

Probleme beim Verbinden mit NAS-Laufwerk


Empfohlene Beiträge

Halli hallo !

 

Der liebe BA.STA-Buliwyf Hat mir nen NAS Laufwerk geschickt um zu testen, ob das meinen Ansprüchen genügt.

Nu will ich auch fleißig und schnell testen, damit wir den Deal festmachen können.

 

Meine Vorstellungen:

Ich möchte dieses NAS Laufwerk (kann kein NFS, nur CIFS) mit meiner Dreambox koppeln, so dass von mir dort ausgelagerte .ts-Files

über den Mediaplayer der Dream abspielbar sind. Gleichermaßen auch Fotos und Musik.

 

Was habe ich bisher gemacht:

Das NAS-Laufwerk ist eingerichtet, eine CIFS-Freigabe (export/hdd) existiert und ist über meine PC`s mit Benutzername und Passwort

aufrufbar. Auch den Mediaserver hab ich eingerichtet, so dass von den PC`s neben dem Netzwerkordner auch direkt ohne Benutzername und Passwort

die freigegebenen Medien sichtbar und auch abspielbar sind.

 

An der Dream komme ich nun nicht so recht weiter.

Auch ier sehe ich über den Dateimanager im Pfad /mnt/Upnp die freigegebenen Ordner und Dateien.

Jedoch kann ich die Netzwerkfreigabe nicht mounten.

 

Über den Netzwerkbrowser, so habe ich mittlerweile erkannt, kann ich lediglich NFS-Freigaben auf entsprechenden Laufwerken einrichten.

Das klappt zwar wunderbar, aber das NAS kann ja kein NFS.

 

Somit habe ich versucht über den Punkt "Netzwerkfreigaben" eine Verbindung herzustellen.

Habe demnach bis auf die IP, den Benutzer und Pass sowie die Art der Freigabe die Standardwerte übernommen.

Allerdings ist die Verbindung zu dieser CIFS-Freigabe nicht aktiv.

 

Ich muss dann erst in den Automount Einstellungen diese Freigabe nochmals eintragen.

Erst danach sehe ich im Mediaplayer der Box auch einen Ordner "Verzeichnis", so wie die Vorgabe im "Automount" gegeben ist.

Aber auch hier greift die Box nicht auf den Ordner zu, so dass ich die Dateien sehen könnte.

 

Auf der Box habe ich einen Ordner /net im Pfad /mnt, den habe ich dann mal bei "Verzeichnis" eingetragen.

Aber auch da bekomme ich keine Verbindung zum Freigabeordner.

 

Wo ist hier mein Denkfehler ?

Wenn ich also über den Netzwerkfreigabe-Assistent ne Verbindung sehe und diese einrichte, muss die noch separat gemountet werden,

wenn ja, wo ?

 

P.S. Normale "Windows-Freigaben" auf dem PC sehe ich auf der Box und kann die auch einrichten, nur nicht vom NAS.

 

Und zuletzt, wenn die CIFS nicht gehen sollten, Upnp funktioniert ja auf der Dream. Wie kriege ich aber das Upnp-Verzeichnis ohne

Probleme im Mediaplayer der Box aufgerufen ?

 

Hoffe, ich hab mich verständlich ausgedrückt, weil ich selebr total verwirrt bin mittlerweile !

 

Danke schonmal für Eure Antworten.

Gruß

double_d

Link zum Beitrag
Auf anderen Seiten teilen

Welches image verwendest du?

Also bei meinem Newnigma2 gehen auch cifs maounts über den Netzwerkbrowser im Newnigma menü.

 

Ein cifs mount kann man auch von hand auf telnet machen. Ich würde dir es per Netzwerkbrower empfehlen, aber per telnet sollte es so gehen:

mount -cifs Ip_des_Servers:Freigabename_auf_Server \pfad_zum_freigabe_Verzeichniss_auf_der_Dream

 

Auf der Dream musst du ein Verzeichniss haben in das du mountest. Am besten nimmste eins unter media. z.B. /media/hdd.

 

Gruß

Kai

Link zum Beitrag
Auf anderen Seiten teilen

Ich hab das eben mal nachgespielt. Hab allerdings kein NAS in dem Sinne, sondern einen Linux-Server

u.a. mit Samba-Freigaben. Eine solche habe ich gerade per CIFS auf der Box gemountet... in den

Automount-Einstellungen den Typ auf CIFS gestellt, die entsprechenden Daten eingegeben. Als

Mountpunkt "test" habe ich mal "test" genommen.

Nach dem Speichern der Einstellungen wird mir im Mediaplayer unter "Network Mount" dann auch der

Mountpunkt "test" angezeigt, und ich kann problemlos drauf zugreifen.

Von Hand kann man dann mit "/media/net/test" auf die Freigabe zugreifen.

 

Das ganze zwar auf ner 800er mit Gemini 4.5, aber in der Hinsicht hat sich da nichts geändert, sollte

so also auch bei dir funktionieren.

Link zum Beitrag
Auf anderen Seiten teilen

Ja klar kannst auch ein vorhandenes nehmen.

Wenn du von hand mountest muss du halt ein existieredndes Verzeichniss angeben. Welches ist egal.

Wenn du weiter probs hat mach mal den mount von hand und poste die rückgabe fals es nicht tut.

 

Gruß

Kai

Link zum Beitrag
Auf anderen Seiten teilen

Beim Gemini kannst du das schön mit automount machen, entweder direkt im BluePanel oder einfach in die auto.network eintragen.

Ein Beispiel wie ich eine Freigabe einbinde:

 

extport -fstype=cifs,rw,soft,rsize=8192,wsize=8192,user=dream,pass=dream ://192.168.0.5/extport

 

wobei extport der Name der Freigabe ist, auf der Box findest du die Sachen dann unter /media/net

 

 

grüße

Link zum Beitrag
Auf anderen Seiten teilen

So, es hilft leider alles nichts !

 

Bis auf den mount-Befehl über Telnet geht gar nichts. Und dabei kann ich zwar über den Mediaplayer auf die Freigabe zugreifen, allerdings werden die Files nicht abgespielt. Bildschirm bleibt schwarz, obwohl das Netzlaufwerk arbeitet.

 

Die einzige Möglichkeit bei allen meinen Versuchen war die direkte Anwahl einer Datei über den Dateimanager im Pfad /Upnp.

Dabei wird zwar die Datei abgespielt, allerdings crasht die Box beim Beenden der Wiedergabe.

 

Jetzt möchte ich aber nochmals nachfragen, damit ich das verstehe.

Im Automount-"Editor" gebe ich manuell die Einstellungen an.

 

Mountpunkt - wäre mein Ordner auf der Box, den ich angelegt habe. Z.B. /mnt/net

Type - ist cifs

Options und Buffergröße - Einstellungen, die erstmal nix mit der reinen Verbindung zu tun haben. Options steht auf rw

Name oder IP - ist die IP des Nas-Laufwerk

Freigabe - ist die Freigabe auf dem NAS-Laufwerk

 

Gebe ich das so ein, habe ich keinen Zugriff auf das Laufwerk. Egal ob ich über den Dateimanager oder über den Mediaplayer das Laufwerk auswählen will. Im Dateimanager ist der Ordner (Mountpunkt) leer und im Mediaplayer ist er erst gar nicht da.

 

Nun gibts aber auch noch den Netzwerkbrowser und den Freigabe Manager.

Was machen die denn nun ? Stellen die nur eine Verbindung zum Freigabeordner her und richten im Hintergrund die Mount-Einstellungen ein, oder wie habe ich das zu verstehen.

 

Im Netzwerkbrowser sehe ich meine beiden PC`s udn das NAS. Wenn ich einen dieser Einträge aufrufe muss ich Benutzernamen und Passwort eingeben und danach kommt nix mehr. Zumindest beim NAS.

 

Im Freigabe Manager kann ich Freigaben einrichten. Aber wozu sind die gut, wenn ich das im Automount schon verknüpfen kann. Ist doch beides nicht das Gleiche, oder ? Ich peil das nicht !

 

Meine Eingaben dort sind:

Aktiv - an

Lokaler Freigabename - frei gewählt (wüsste sonst nicht was da rein soll)

Freigabetyp - CIFS

Server IP - die IP vom NAS

Server Freigabe - Freigabename auf dem NAS

use as HDD replacement - nein

Freigabeoptionen - rw, nolock

 

Danach habe ich zwar die Symbolik für diese Freigabe, aber sie ist mit einem roten Kreuz markiert. Demnach kommt keine Verbindung zustande.

 

Wie gesagt, ich peil das nicht, warum es diese zwei Möglichkeiten gibt und warum keine funktioniert.

 

Vielleicht erbarmt sich nochmal einer um mir da aufs Pferd zu helfen. :)

Link zum Beitrag
Auf anderen Seiten teilen

Also bei mir sieht das im Automount so aus und funktioniert ganz gut...

 

Mountpunkt: Netzlaufwerk

Type: cifs

Options: rw

Username: root

Passwort: dreambox

Buffer Größe: rsize=8192,wsize=8192

Name oder IP: 192.168.178.200

Freigabe: /Aufnahme

 

Username und Passwort müssen eingegeben werden auch wenn der Ordner für jeden offen ist.

Link zum Beitrag
Auf anderen Seiten teilen

Die Kernelmodule sind eingeschaltet und laufen.

 

Die Freigabe auf dem NAS heißt /export...ich hatte anfangs den Fehler gemacht, dass ich den Unterordner /hdd auch mit in die Mounteinstellungen eingetragen hatte. Das funktionierte nicht bei der Eingabe des Befehls über Telnet.

 

Von daher kommt jetzt bei der Eingabe des Befehls über Telnet kein Fehler und danach sehe ich auch wie schon beschrieben den Ordner und die Dateien, kann aber nichts abspielen. Beim Automounter erscheint allerdings auch kein Fehler.

Der nimmt den Eintrag einfach so an und gut, reicht aber irgendwie nicht aus. Anschließend habe ich den Ordner nicht in der Verzeichnisübersicht. Habe gedacht, dass ich diesen Eintrag dann noch aktivieren muss, finde da aber auch keine Möglichkeit. Letztlich habe ich Enigma einfach dann neu gestartet, aber auch mit dem Null-Ergebnis.

 

Den einzigen Fehler, wenn man ihn so nennen kann, habe ich beim Freigabe Manager.

Dort erscheint nach Eintrag aller Daten, wie oben beschrieben, in der Symbolik ein rotes Kreuz, was wohl verdeutlicht, dass keine Verbindung zur Freigabe hergstellt wird.

 

Richte ich das NAS-Laufwerk als Mediaserver ein, dann hab ich ohne irgendwelche Mounts direkt im Ordner /Upnp auf der Box alle (Media)-Dateien, die in den Freigabeordnern des Laufwerks liegen. Hier wird auch ohne murren direkt abgespielt, allerdings crasht da die Box, wenn ich ne Wiedergabe beende.

 

Bei dem NAS-Laufwerk handelt es sich um ein LaCie Ethernet BigDisk.

Link zum Beitrag
Auf anderen Seiten teilen

Puh, ist mir jetzt echt ein Rätsel, könntest du das ganze bitte mal in die auto.network eintragen? Muss gestehen über die

Gui hab ich da noch nie was gemacht, die Datei liegt unter /etc bei mir sieht ein Eintrag so aus:

 

Auf dem Server 192.168.0.5 gibt es eine Freigabe "extport" und das ganze ist so eingetragen:

 

extport -fstype=cifs,rw,soft,rsize=8192,wsize=8192,user=dream,pass=dream ://192.168.0.5/extport

 

und erscheint dann unter /media/net/extport

 

 

Grüße

Link zum Beitrag
Auf anderen Seiten teilen

na dann.....schaun mer mal:

 

geh bitte mit telnet auf die Dream und lege ein neues Verzeichnis an

mkdir /mnt/ddmod

 

(ok, ein bischen Spaß muss sein)

 

dann bitte manuell mounten (natürlich musst Du User und Passwort so angeben, wie auf dem NAS angelegt):

mount -t cifs -o user=double,password=dd //IP_Deines_NAS/export /mnt/ddmod

 

Nun bitte entweder die Fehlermeldung posten oder die Ausgabe des Befehls

mount

und die Ausgabe des Befehls

ls /mnt/ddmod

 

...wir wollen doch erstmal sehen, ob es an was grundsätzlichem klemmt....

 

Die Leerzeichen sind hier schwer zu lesen - am besten copy und paste und dann editieren...

 

 

OT: Glückwunsch!

Link zum Beitrag
Auf anderen Seiten teilen

Anbei die Ausgabe vom Befehl mount

 

root@dm7025:~# mount
/dev/root on /boot type jffs2 (ro,noatime)
/dev/mtdblock/3 on /boot/mnt/flash type jffs2 (rw,noatime)
/dev/loop/0 on /boot/mnt/squashfs type squashfs (ro)
none on / type unionfs (rw,dirs=/boot/mnt/flash/delta=rw:/boot/mnt/squashfs=ro,d
ebug=0,delete=whiteout,copyup=preserve)
none on /dev type devfs (rw)
proc on /proc type proc (rw,nodiratime)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw)
usbdevfs on /proc/bus/usb type usbfs (rw)
tmpfs on /var type tmpfs (rw)
tmpfs on /tmp type tmpfs (rw)
/dev/hda1 on /media/hda1 type ext3 (rw)
none on /sys/fs/fuse/connections type fusectl (rw)
fuse on /media/Upnp type fuse (ro,nosuid,nodev,user_id=0,group_id=0)
//192.168.1.25/export on /media/ddmod type cifs (rw,nodiratime,unc=\192.168.1.25
\export,username=admin,domain=,rsize=16384,wsize=16384)

 

Und beim Befehl ls /mnt/ddmod kriege ich "hdd" angezeigt in blau !

 

Habe jetzt auch festgestellt, dass ich den Mountpunkt über den Eintrag "Internal Flash" aufrufen kann und dort auch die Dateien auf dem NAS sehe. Allerdings auch von dort werden sie nicht abgespielt !

Link zum Beitrag
Auf anderen Seiten teilen

...also der mount geht schon mal...

 

wenn Du nach /media/ddmod mountest, sollten wir auch nach

ls /media/ddmod

schauen :D

 

Öhh, ja natürlich..hehe ! :P

Allerdings kriege ich bei beiden die gleiche Ausgabe.

 

Habe auch mittlerweile festgestellt, dass ich nun im Mediaplayer unter "Internal Flash" durch die Ordnerstruktur bis /media/ddmod gehe, sehe ich auch meine Dateien. Wenn das so sein soll, dann ist das so. Eleganter wäre es allerdings, wenn "Network" direkt als Verzeichnis anwählbar wäre...aber wie gesagt, wenns anders geht und ok ist, nehme ich das so hin.

 

Leider spielte er gestern Nacht die .ts-Files aber immer noch nicht ab, bis ich gemerkt hatte, dass es Aufnahmen meiner Dbox2 waren. Ich habe dann mal eine .ts-Datei von der internen Festplatte aufs NAS kopiert und siehe da...sie wurde abgespielt. :)

 

Heute abend probiere ich das nochmal mit dem Automount ob das dann auch so funktioniert, dann wäre ich soweit zufrieden.

 

...bis auf...ja bis auf die Kopiergeschwindigkeit zwischen Dream und NAS.

Wenn ich die noch erhöhen könnte, wäre ich gänzlich zufrieden. :P

Mit nem FTP-Programm (Filezilla) habe ich grad mal 6 Mbps zustande gekriegt. mit WSFTP waren es dann schon 16 Mbps.

Da ist doch auch irgendwas nicht richtig, oder ? Klar, es hängt schon an der Architektur, aber alle Geräte sind an einer FritzBox 7170 per Kabel angeschlossen.

Hole ich nen Film von der Dream auf den Rechner, liegen fast dauerhaft 80-90 Mbps an.

Link zum Beitrag
Auf anderen Seiten teilen

Öhh, ja natürlich..hehe ! :lol:

Allerdings kriege ich bei beiden die gleiche Ausgabe.

..was nicht wirklich normal ist :D . Das wichtigste ist aber, dass die CIFS-Verbindung selbst funktioniert. Letztlich kannst Du dich jetzt mit den verschiedenen (mehr oder weniger sinnvollen :) ) Möglichkeiten des E2-mountens befassen. :D ....seit Einführung des Netzwerkbrowsers macht mir E2 endgültig keinen Spaß mehr :P .

 

Leider spielte er gestern Nacht die .ts-Files aber immer noch nicht ab, bis ich gemerkt hatte, dass es Aufnahmen meiner Dbox2 waren.
:D .... schick die DBox-TS-Files einmal durch PX (Funktion "zu TS") dann werden die auch wieder abgespielt :P

 

 

...bis auf...ja bis auf die Kopiergeschwindigkeit zwischen Dream und NAS.

Wenn ich die noch erhöhen könnte, wäre ich gänzlich zufrieden. :D

Mit nem FTP-Programm (Filezilla) habe ich grad mal 6 Mbps zustande gekriegt. mit WSFTP waren es dann schon 16 Mbps.

...das ist deutlich zu wenig. Wie schnell ist denn die FTP-Verbindung NAS<->PC?
Link zum Beitrag
Auf anderen Seiten teilen
  • 3 weeks later...

So, melde mich mal zurück von der Front !!! :D

 

Ich hab es jetzt endgültig hingekriegt...nach etlichen verzweifelten Versuchen mit dem Automounter war es eine Klitzekleinigkeit, die man erstmal wissen muss.

 

Ich hatte im Automount (mit dem Netzwerkbrowser komme ich immer noch nicht zurecht :) ) den Mountpunkt auf der Box immer vorgegeben. Das Verzeichnis /mnt/ddmod oder der Mirror /media/ddmod ließ sich zwar immer manuell über Telnet mounten und ich bekam auch eine Verbindung zum NAS, aber sobald Enigma neu gestartet wurde, oder die Box in den deep-Standby gegangen ist, war der Mountpunkt weg und ich kam nicht mehr per Netzwerk aufs NAS.

 

Egal was ich im Automounter eingestellt hatte.

Fehler an der Sache war hier, dass der Mountpunkt nicht auf ein voreingestelltes Verzeichnis gesetzt werden kann.

Man gibt lediglich einen Verzeichnisnamen an (in meinem Fall habe ich "filme" gewählt, und der Mountpunkt wird dann automatisch ins Verzeichnis /net geschrieben und das Unterverzeichnis dort erstellt.

 

Bis ich dahinter gekommen bin, hatte ich 6Millionen graue Haare mehr...:P

 

Nachdem diese Hürde also genommen war, funktioniert es mit dem NAS und der CIFS-Freigabe auch ganz verträglich. Ich kann sogar darauf aufnehmen. Allerdings habe ich jetzt ein anderes Problem. Meine Netzwerkkonfiguration verabschiedet sich von Zeit zu Zeit automatisch. Der Netzwerkadapter ist eingestellt und konfiguriert, aber ohne einen Neustart oder Wakeup aus dem Deep-Standby kann ich zwischendurch mit der Box nicht mehr online gehen und kann somit auch nicht mehr auf die Netzfreigaben zugreifen. Ich muss dann ständig manuell die Netzwerkverbindung wieder aktivieren.

Telnet ist dann logischerweise auch nicht mehr möglich.

 

Gibt es da eventuell einen Sleep-Timer, der das Netzwerk nach x-Minuten Inaktivität ausschaltet ?

Ich hab bisher keine solche Einstellung gefunden.

Was ich aber glaube irgendwann am Anfang mal gesehen zu haben war ein Netzwerkdienst im BluePanel.

Kann mich auch irren, aber wenn es da einen gegeben hat, dann ist der nicht mehr da.

Wie könnte ich Dienste/Daemons nachinstallieren oder hinzufügen ?

Oder ist es ein Kernel-Modul, welches ich versehentlich ausgeschaltet habe ?

 

Mit dem Netzwerk ist es mir bereits mehr als 10mal passiert, dass es weg war.

Link zum Beitrag
Auf anderen Seiten teilen
  • 7 years later...

Hallo, ich probiere jetzt seit 3tagen meine dreambox 800 HD mit Newnigma2 mit dem Netzwerk zu verbinden, aber ich bekomme den Ball vor der Netzwerk Freigabe einfach nicht grün, egal ob ich aufs nas, Laptop oder oder auf die mutant 51 hd zugreifen möchte.. Anders rum kann ich auf die dreambox zugreifen.. NFS Editor und samba Server sind auch installiert.. Ich weiß einfach nicht weiter.. Mit openatv klappt das sofort. Openatv ist ein super Image, nur läuft bei mir nicht mal die 4.2 richtig. Lange umschaltzeiten und reagiert überhaupt sehr langsam. Deshalb würde ich es gerne mit Newnigma2 zum Laufen kriegen!

Link zum Beitrag
Auf anderen Seiten teilen

Hallo, ich probiere jetzt seit 3tagen meine dreambox 800 HD mit Newnigma2 mit dem Netzwerk zu verbinden, aber ich bekomme den Ball vor der Netzwerk Freigabe einfach nicht grün, egal ob ich aufs nas, Laptop oder oder auf die mutant 51 hd zugreifen möchte.. Anders rum kann ich auf die dreambox zugreifen.. NFS Editor und samba Server sind auch installiert.. Ich weiß einfach nicht weiter.. Mit openatv klappt das sofort. Openatv ist ein super Image, nur läuft bei mir nicht mal die 4.2 richtig. Lange umschaltzeiten und reagiert überhaupt sehr langsam. Deshalb würde ich es gerne mit Newnigma2 zum Laufen kriegen!

ohh... sehe gerade das der letzte beitrag erst 8 jahre her ist.. ;) hoffentlich kann mir trotzdem noch jemand helfen.

Link zum Beitrag
Auf anderen Seiten teilen
  • Wer ist Online   0 Benutzer

    Keine registrierten Benutzer online.

×
×
  • Neu erstellen...