Jump to content

dboxulle

Full Member
  • Posts

    624
  • Joined

  • Days Won

    3

Everything posted by dboxulle

  1. 0; 38; 39; 78; 75; . . . usw. Das klappt und Dank deiner Hilfe konnte ich deine "greps" so umbauen, dass ich mir nun aus der json 4 Temps "rausschneide" von 4 channels und die dann in eine RRD Database schreibe mit einem Script Super! Nun verzweifele ich gerade daran ein erzeugtes PNG vom Server per FTP auf eine Fritz zu schicken... weil man beim Ubuntu Server Standard-FTP keine Login-Daten mitgeben kann... evtl hast Du dazu noch eine Idee? Dieses PNG enthält dann die Graphen von den Sensoren aus der RRD und das will ich dann irgendwie mit dem Tablet abrufen können (soll dann auch alle 30 Min per Script erstellt und auf die Fritz geschoben werden). Danke nochmals!!!
  2. Danke dir Snowhead Da ich die Graphen mit einem Tablet anrufen möchte, werde ich sie wohl mit deinem grep und Cronjob zerpflücken und in RRDtool schreiben. Könntest Du nochmals diesen Befehl prüfen: line=`wget -q -O- http://192.168.178.197/weather.json | grep humidity | cut -d'"' -f4 | sed -e s/^$/0/g -e s/$/";"/g` echo `date +"%Y/%m/%d %H:%M:%S"`\; $line >> luftfeuchtigkeit.csv Ich habe ihn 3 mal händisch abgetippt und auch in Notepad++ kopiert und in UTF8 umgewandelt aber er schreibt immer nur das Datum und die Uhrzeit in die .CSV Danke nochmals!
  3. Hello again Ich komme nicht weiter, da ich das Projekt vermutlich falsch angegangen bin Mein Plan war, aus der JSON eine Log Datei zu erstellen, welche man dann einfach schön visualisieren kann (Verlauf der Temperaturen und Luftfeuchtigkeit von 4 ausgewählten Sensoren) Aber nach langer Recherche geht das so wohl nicht (mit meiner Log Datei und die dann auslesen und mit Highcharts, Grafana, usw. zu visualisieren)... Laut Recherche muss man die Werte erst in eine Datenbank schreiben? influx, RRDtool, SQL, SQLlite, NOSQL,... Geht das nicht anderes ? Habt ihr da eine Idee zu? Mir raucht schon der Kappe von den ganzen Möglichkeiten aber ich weiß nicht, mit welcher man es am klügsten umsetzt Danke vorab mal wieder
  4. Oh ha super! Danke für die ganzen Infos auch dazu
  5. Kurze Rückmeldung: Läuft genau wie erwartet Danke! Und eine Nachfrage: Ich will die Werte in eine Datei schreiben mit >> luftfeuchtigkeit.log Die Werte stehen dann alle pro Wert = 1 Zeile untereinander. Ist das zur späteren Auswertung sinnvoll? Oder wäre es besser, pro Auslesen eine Zeile mit allen Werten getrennt durch Komma, Semikolon oder Doppelpunkt zu erzeugen? Wenn ja : Wie macht man das beim in die Datei schreiben? Danke euch fürs Helfen
  6. Wer denkt sich so etwas aus? Danke dir, SnowHead, das führe ich mir morgen zu Gemüte!
  7. Hallo, ich möchte eine weather.json nach den Werten von humidity durchsuchen und in eine Datei schreiben. Diese sind immer - in der selben Zeile wie das Wort "humidity" UND - zweistellige, ganze Zahlen ODER - 0 ODER - leer ("") Wenn "" gefunden wird soll gern auch eine 0 dafür geschrieben werden. Die zweistelligen, ganzen Zahlen finde ich Immerhin. Mit wget 192.168.178.197/weather.json -q -O - | grep -A0 "humidity" | grep -o "[0-9][0-9]" -> Oder geht das noch besser??? Aber die anderen beiden "Suchvorgaben mit Umwandlung "" in 0" bekomme ich nicht hin... Wichtig wäre auch, dass DIE REIHENFOLGE der Sensoren beibehalten wird. Kann mir jemand einen Tipp geben? DANKESCHÖN
  8. Im Download-Bereich findest Du alles... Und wie ich es gesehen habe wird sogar noch einem neuen Image gebaut
  9. Danke soweit! ich werde es am Woe mal testen
  10. Erst einmal Danke für die Anleitung und sorry für die Verwirrung :/ Ich meinte, meine Sicherungen liegen im BR-Strukturformat vor. Also Ordner BDMV und darunter der STREAM-Ordner mit 2 oder 3 m2ts Dateien. Kann ich diese über die Cooli über das Netzwerk abspielen? Ich weiß, dass ich die m2ts-Dateien evtl. noch zusammenführen muss. Hast Du da noch einen Tipp? Danke nochmals
  11. Hallo alle zammen Ich suche eine Möglichkeit, am besten über die Coole Neo2 eine ISO oder VOB Datei auf einem NAS abzuspielen. Über den Movieplayer scheint es nicht direkt zu gehen... Ich meine bei meiner Suche mal ein Plugin gesehen zu haben, weiß aber nicht, ob es dies auch für das KW gibt? Habt ihr eine Idee? Danke und schönes Wochenende
  12. Danke, habe es über Safarl, Dolphin und Chrome über iPhone probiert, immer derselbe Fehler. Ich werd es über den Rechner machen nachher. Grüße
  13. Hallo, ich wollte Markham eine PN senden aber es kommt immer ein Datenbankfehler „Array“ Wie kann ich ihn erreichen? VIele Grüße
  14. Danke für die Recherche DdD! Dann bin wohl etwas verwirrt... Ich war mir sicher, da ich seit Jahren kein anderes Image mehr nutze. Und es irgendwie hinbekommen hatte (meine ich). Hab' eben nochmal neu geflasht: Kein Moviebrowser unter dem Schrift-Menü.
  15. Leider keine Änderung. Weder in der Darstellung bei Änderung der Werte, als auch in den Menüeinträgen. Kein Moviebrowser vorhanden :/
  16. Du hast es erkannt! Diese Einträge fehlen bei mir komplett! Warum auch immer... Danke für den Tipp Ich werde sie nachher nachtragen und testen und berichten! VG
  17. "Kann bestätigen, dass es keinen Eintrag "Moviebrowser" gibt." Super Danke, dachte schon meine Augen wollen nicht mehr Das mit dem Dateibrowser werde ich am Woe mal testen... Oder kann ein "Progger" hier noch einen Tipp geben ?
  18. Leider habe ich da keinen Eintrag "Moviebrowser" Ich habe auch schon geguckt, ob ich bei "Menüs anpassen" etwas ausgeblendet habe, aber ist alles sichtbar... Wie kann das sein?
  19. Das Image ist ganz frisch geflasht... Hast Du da dort den Eintrag?
  20. Genau da taucht der Eintrag bei mir nicht auf ? Ich habe das MAI2016 3.10 Image für Coolstream Neo2
  21. Tach all Kann mir jemand auf die Sprünge helfen bitte... Ich möchte die Schriftgrösse in der "Meine Aufnahmen" Übersicht (Playtaste) ändern und finde es nicht wieder.... Spaltenbreite habe ich gefunden und auch wie man andere Menüs anpasst (EPG, Senderübersicht...) Danke für einen Denkanstoß PS Eben kam ein Datenbankfehler und dieser Text wurde nicht übernommenen
  22. @punchy Bist Du mit der Box online? Und wie Markham schrieb, war es bei mir auch: Nach der Installation ist der Punkt dann ausgegraut.
  23. Top! Das war es. Vielen Dank! Festplatte angestöpselt, sie wurde erkannt und gemountet
  24. Treiber dachte ich wäre integriert? Wie installiere ich den? Log: Hmmm Treiber ntfs dachte ich ist interferiert? Das wusste ich nicht. Hast Du nen Tipp wie das geht? LOG: om3917_set_parameters: DEMOD UNLOCKED scsi5 : usb-storage 2-1:1.0 usb_storage: module is already loaded scsi 5:0:0:0: Direct-Access WD Elements 10B8 1012 PQ: 0 AN SI: 6 sd 5:0:0:0: Attached scsi generic sg1 type 0 scsi: killing requests for dead queue scsi: killing requests for dead queue sd 5:0:0:0: [sdb] Spinning up disk.........ready sd 5:0:0:0: [sdb] 3906963456 512-byte logical blocks: (2.00 TB/1.81 TiB) sd 5:0:0:0: [sdb] Write Protect is off sd 5:0:0:0: [sdb] Mode Sense: 47 00 10 08 sd 5:0:0:0: [sdb] Assuming drive cache: write through sd 5:0:0:0: [sdb] Assuming drive cache: write through sdb: sdb1 sd 5:0:0:0: [sdb] Assuming drive cache: write through sd 5:0:0:0: [sdb] Attached SCSI disk usb 2-1: USB disconnect, address 9 scsi: killing requests for dead queue usb 2-1: new high speed USB device using cx2450x-ehci and address 10 usb 2-1: New USB device found, idVendor=1058, idProduct=10b8 usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=5 usb 2-1: Product: Elements 10B8 usb 2-1: Manufacturer: Western Digital usb 2-1: SerialNumber: Xxxx scsi6 : usb-storage 2-1:1.0 usb_storage: module is already loaded scsi 6:0:0:0: Direct-Access WD Elements 10B8 1012 PQ: 0 AN SI: 6 sd 6:0:0:0: Attached scsi generic sg1 type 0 scsi: killing requests for dead queue scsi: killing requests for dead queue sd 6:0:0:0: [sdb] Spinning up disk.........ready sd 6:0:0:0: [sdb] 3906963456 512-byte logical blocks: (2.00 TB/1.81 TiB) sd 6:0:0:0: [sdb] Write Protect is off sd 6:0:0:0: [sdb] Mode Sense: 47 00 10 08 sd 6:0:0:0: [sdb] Assuming drive cache: write through sd 6:0:0:0: [sdb] Assuming drive cache: write through sdb: sdb1 sd 6:0:0:0: [sdb] Assuming drive cache: write through sd 6:0:0:0: [sdb] Attached SCSI disk
×
×
  • Create New...